Na woluminie NTFS nie można usunąć pliku lub uzyskać do niego dostępu

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 159199 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL159199
Rozwiń wszystko | Zwiń wszystko

Symptomy

Na woluminie NTFS nie można usunąć pliku lub katalogu albo nie można uzyskać do niego dostępu. Przy próbie wykonania na pliku jednej z tych operacji system Windows NT zwraca komunikat o błędzie „Odmowa dostępu”. Nie można wyświetlić uprawnień, właściciela ani zawartości pliku. Plik pojawia się jednak na liście zawartości katalogu w Menedżerze plików lub w Eksploratorze Windows. Dzieje się tak nawet wtedy, gdy użytkownik próbuje uzyskać dostęp do pliku, do którego ma uprawnienia. Nawet administrator nie może przejąć pliku na własność.

Przyczyna

Istnieją dwa przyczyny:
  • Plik znajduje się w stanie tzw. „oczekiwania na usunięcie”. Plik został usunięty, ale nadal są otwarte dojścia do niego. System NTFS oczekuje, aż wszystkie dojścia do tego pliku zostaną zamknięte, zanim zaktualizuje indeks. Jeśli w tym czasie nastąpi próba uzyskania dostępu do pliku, system NTFS odmawia dostępu. Ponieważ plik jest wymieniony w indeksie, ale faktycznie jest usunięty, widać plik, ale nie można uzyskać do niego dostępu.
  • Plik uległ uszkodzeniu.

Rozwiązanie

Rozwiązania tych dwóch problemów są następujące:
  • To zachowanie jest zgodne z projektem. Wystarczy po prostu poczekać, aż dojścia do pliku zostaną zamknięte i plik zostanie usunięty z indeksu. Jeśli w tym stanie znajduje się katalog, upewnij się, że z tym katalogiem ani z żadnym katalogiem poniżej niego w drzewie katalogów nie jest skojarzony żaden udział. Plik zniknie po ponownym uruchomieniu komputera, ponieważ wszystkie dojścia są zamykane podczas zamykania systemu.
  • Uruchom polecenie CHKDSK /F dla woluminu zawierającego dany plik.

Właściwości

Numer ID artykułu: 159199 - Ostatnia weryfikacja: 19 września 2003 - Weryfikacja: 1.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Słowa kluczowe: 
kbother KB159199

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com