ACC: Running Current and Earlier Versions of Access Simultaneously

Article translations Article translations
Article ID: 159333 - View products that this article applies to.
This article was previously published under Q159333
Novice: Requires knowledge of the user interface on single-user computers.

Expand all | Collapse all

On This Page

SUMMARY

You can install multiple versions of Microsoft Access 97 and earlier on the same computer, and you can even run the separate versions simultaneously with one exception: you cannot run Microsoft Access 1.x and Microsoft Access 2.0 at the same time.

NOTE: For information about running Access 97 and Access 2000 on the same computer, please see the following article in the Microsoft Knowledge Base:
241141 ACC2000: How to Install Access 97 and Access 2000 on Same Computer

MORE INFORMATION

As long as you set up each version of Microsoft Access in its own folder (directory), you can have more than one version installed on your computer at the same time.

NOTE: You may receive an error message if you install Microsoft Access 7.0 on a computer where Microsoft Access 97 is already installed. For information about resolving the error, please see the following article here in the Microsoft Knowledge Base:
159793 ACC: "Can't Load Mspdox35.dll" Err Msg Installing MS Access 95
When you have more than one version of Microsoft Access on the same computer, Microsoft Windows can only associate one version of Microsoft Access with the .mdb file extension. By default, the version of Microsoft Access that you installed most recently starts when you open an .mdb file directly by using a shortcut, an icon, Windows Explorer, or File Manager. If you want to open a database (.mdb) file in another version of Microsoft Access, you must start that version, and then open the database.

You can change which version of Microsoft Access is associated with the .mdb file name extension by using the following instructions.

NOTE: Windows 95 and Windows NT version 4.0 offer the Open With and Send To shortcut menu commands as alternatives to changing the .mdb file association. For more information about using these options, see the following articles in the Microsoft Knowledge Base:
141017 How to Add Items to the "Send To" List
141275 How to Open a File with Other Than Associated Program

Changing File Association in Windows 2000

  1. Right-click Start, and then click Explore.
  2. On the Tools menu, click Folder Options.
  3. Click the File Types tab.
  4. Under Registered file types, click Microsoft Access Database or Microsoft Access Database Application, and then click Advanced.
  5. In the Actions box, click Open, and then click Edit.
  6. Type the following command in the Application used to perform action box to associate .mdb files with Microsoft Access 1.x or 2.0:
    C:\Access\Msaccess.exe %1
    Type the following command line for Microsoft Access 7.0 or 97:
    C:\Program Files\Microsoft Office\Office\Msaccess.exe /Nostartup "%1"
    NOTE: If the path to the correct version of Msaccess.exe on your computer differs from the path in the examples, make sure to change the path to what it is on your computer.
  7. Click OK in the Editing Action for Type dialog box.
  8. Click OK in the Edit File Type dialog box.
  9. Click Close in the Folder Options dialog box, and then quit Windows Explorer.

Changing File Association in Windows 95 and Windows NT version 4.0


  1. Right-click Start, and then click Explore.
  2. On the View menu, click Options.
  3. Click the File Types tab.
  4. Click Microsoft Access Database or Microsoft Access Database Application in the Registered file types box, and then click Edit.
  5. In the Actions box, click Open, and then click Edit.
  6. Type the following command in the Application used to perform action box to associate .mdb files with Microsoft Access 1.x or 2.0:
    C:\Access\Msaccess.exe %1
    Type the following command line for Microsoft Access 7.0 or 97:
    C:\Program Files\Microsoft Office\Office\Msaccess.exe /Nostartup "%1"
    NOTE: If the path to the correct version of Msaccess.exe on your computer differs from the path in the examples, make sure to change the path to what it is on your computer.
  7. Click OK in the Editing Action for Type dialog box.
  8. Click OK in the Edit File Type dialog box.
  9. Click OK in the Options dialog box, and then quit Windows Explorer.

Changing File Association in Windows NT version 3.51


  1. Double-click the File Manager icon in the Main group.
  2. On the File menu, click Associate.
  3. Type mdb in the Files with Extension box.
  4. Click Change Type.
  5. Type the following command in the Command box to associate .mdb files with Microsoft Access 1.x or 2.0:
    C:\Access\Msaccess.exe %1
    Type the following command for Microsoft Access 7.0 or 97:
    C:\Program Files\Microsoft Office\Office\Msaccess.exe /Nostartup "%1"
    NOTE: If the path to the correct version of Msaccess.exe on your computer differs from the path in the examples, make sure to change the path to what it is on your computer.
  6. Click OK in the Change File Type dialog box.
  7. Click OK in the Associate dialog box.

REFERENCES

For more information about associating file types with programs, search the Windows Help Index for "associating."

Properties

Article ID: 159333 - Last Review: January 19, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Access 1.0 Standard Edition
  • Microsoft Access 1.1 Standard Edition
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Keywords: 
kbenv kbfaq kbinfo kbsetup KB159333
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com