PRB: Messages Blocked with SQLMail and Exchange Client

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Article ID: 159425 - View products that this article applies to.
This article was previously published under Q159425
This article has been archived. It is offered "as is" and will no longer be updated.
BUG #: 66337 (Windows NT)
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SYMPTOMS

If SQLMail is set up with the Exchange client to use a Microsoft Mail Post Office, Compuserve Mail or Internet Mail, outgoing messages will be blocked in the Personal Message Store's Outbox and no incoming messages will be received.

CAUSE

The architecture of the Exchange client does not allow the spooler process to run under a service like SQL Server and hence the messages are never sent or received.

WORKAROUND

There are two workarounds for this issue depending on the mail source:
  1. Install Microsoft Exchange Server and set up SQLMail with it, following the instructions in the following article in the Microsoft Knowledge Base:
    153159 HOW TO: Troubleshoot SQL Mail with Microsoft Exchange Server
    Then have Microsoft Exchange Server forward the mail to the appropriate destination.
  2. For additional information on issues related to SQL Mail, see the following article:
    263556 INF: How to Configure SQL Mail

Properties

Article ID: 159425 - Last Review: October 4, 2013 - Revision: 4.0
APPLIES TO
  • Microsoft SQL Server 6.0 Standard Edition
  • Microsoft SQL Server 6.5 Standard Edition
Keywords: 
kbnosurvey kbarchive kbinterop kbother kbprb KB159425

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