Article ID: 159994 - Last Review: November 1, 2006 - Revision: 3.1

Services For Macintosh Does Not Unlock Record After a Personal Computer Releases Lock

This article was previously published under Q159994
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SYMPTOMS

A file lock may not appear to be free on a Macintosh computer attached to a MAC Volume when the following occurs:
  1. A personal computer-based application locks a record in the file on a Macintosh Volume.
  2. The Macintosh attempts to lock the same record and gets a return code indicating that the record is already locked.
  3. The personal computer-based application releases its lock on the record.
  4. The record still appears to be locked when viewed from the Macintosh even though it is not locked.

CAUSE

The cached information for the lock in Services for Macintosh is not cleared out when the personal computer lock is removed.

STATUS

Microsoft has confirmed this to be a problem in Windows NT version 3.51.

A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Product Support Services for more information.

APPLIES TO
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
Keywords: 
kbnetwork KB159994
 

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