Chybová zpráva: Chyba defragmentace jednotky <x>. Windows může není...

Překlady článku Překlady článku
ID článku: 160043 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při spuštění programu Defragmentace disku (Defrag.exe) může zobrazit následující chybová zpráva:
Chyba defragmentace jednotka <drive>. Windows nelze získat přístup k části jednotky. Klepněte a provést pokyny pro spuštění programu ScanDisk. Důležité: Tento problém vyřešit, které musí spustit program ScanDisk a zvolte možnost důkladnou.
ID no: DEFRAG005
Poznámka: může být nahrazena "ID No: DEFRAG005" část chybové zprávy „ ne ID: DEFRAG006. "

Příčina

K této chybě dochází, když je defragmentace nelze číst nebo zapisovat chybných sektorů na pevném disku. Defragmentace je nelze zapisovat do sektoru, zobrazí se chybová zpráva DEFRAG005. Když je defragmentace nelze číst ze sektoru, zobrazí se chybová zpráva DEFRAG006.

Řešení

Před pokusem o tento problém vyřešit byste nejprve vytvořit záložní kopii důležitá data na pevném disku. Po tak učiníte, spusťte program ScanDisk (Scandskw.exe) a provést úplný test na pevném disku. Použijte uvedený postup:
  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, přejděte na položku Systémové nástroje a potom klepněte na položku ScanDisk.
  2. Klepněte na pevný disk, který je odkazováno v chybové zprávě a potom klepněte na přepínač Úplný v oblasti typ test.
  3. Klepněte na příkaz Možnosti, ověřte, zda je vybrán oblasti systému a data a klepněte na tlačítko OK.
  4. Klepnutím na tlačítko Spustit test začít.
ScanDisk vyhledat chybné sektory nebo spuštění programu ScanDisk problém neodstraní, nakonfigurujte ScanDisk zjistit časové limity disku a zkontrolujte každý cluster pětkrát při provádění kontrolu povrchu. Použijte uvedený postup:
  1. Otevření souboru Scandisk.ini ve složce Windows\Command pomocí libovolného textového editoru (například Notepad).
  2. Vytvořte oddíl [prostředí] v souboru, pokud v části není již existovat a přidejte následující řádky do oddílu:
    ScanTimeOut = on
    NumPasses = 5
    Všimněte si, že "ScanTimeOut ="a"NumPasses =" řádky již mohou existovat, ale s různými hodnotami.
  3. Uložte a zavřete soubor Scandisk.ini.
  4. Klepněte na tlačítko Start, klepněte na příkaz vypnout, klepněte na tlačítko "Restartujte počítač v režimu MS-DOS" a potom klepněte na tlačítko Ano.
  5. Zadejte následující řádek a stisknutím klávesy ENTER spusťte program ScanDisk
    scandisk <drive>:
    kde <drive>je písmeno jednotky pevného disku, který chcete zkontrolovat. Povšimněte si, že by měla spustit kontrolu povrchu při ScanDisk vyzve vás k tomu, opravit všechny chyby, že ScanDisk najde a zobrazit a uložit ScanDisk vytvoří soubor protokolu.
  6. Po dokončení ScanDisk zadejte exit a stiskněte klávesu ENTER se vrátíte Windows 95.
  7. Defragmentace spustit znovu.
Pokud stále zobrazí výše chybová zpráva, spustit defragmentace konsolidovat volného místa, potom defragmentovat pouze soubory a provést úplné defragmentace (soubory i volné místo). Postupujte takto:
  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, přejděte na systémové nástroje a potom klepněte na příkaz Defragmentace.
  2. Klepněte na pevný disk, který je odkazováno v chybové zprávě a potom klepněte na tlačítko OK.
  3. Klepněte na tlačítko Upřesnit, klepněte na tlačítko konsolidaci pouze volné místo a potom klepněte na tlačítko OK.
  4. Budete vyzváni k ukončení defragmentace klepněte na tlačítko Ne.
  5. Klepněte na pevný disk, který je odkazováno v chybové zprávě a potom klepněte na tlačítko OK.
  6. Klepněte na tlačítko Upřesnit, klepněte na tlačítko defragmentovat pouze soubory a potom klepněte na tlačítko OK.
  7. Budete vyzváni k ukončení defragmentace klepněte na tlačítko Ne.
  8. Klepněte na pevný disk, který je odkazováno v chybové zprávě a potom klepněte na tlačítko OK.
  9. Klepněte na tlačítko Upřesnit, klepněte na tlačítko "Úplná defragmentace, (soubory i volné místo)" a potom klepněte na tlačítko OK.
  10. Budete vyzváni k ukončení defragmentace, klepněte na tlačítko Ano.
ScanDisk vyhledat chybné sektory nebo spuštění programu ScanDisk problém nevyřeší, obraťte se na výrobce počítače nebo pevný disk o další řešení může problém.

Další informace

Mnoho pevných disků mít sektory nepoužitelný. Pokud sektory byly označeny jako chybné ScanDisk nebo jiný nástroj disku, defragmentace zobrazí jako bílá pole s červenou řádku přes něj sektor. To označuje, že clusteru byla označena jako chybná a nelze ukládat data.

Pokud použijete nástroj disk nemůže rozpoznat chybných sektorů na pevném disku nebo disku nástroj nespouštějte v pravidelných intervalech, může existovat nepoužitelný, které nejsou označeny jako chybné sektory na disku. V tomto případě může není zjistíte, že existují dokud Windows 95 se pokusí uložit data v nich chybné sektory. Je tedy možné zobrazit při použití jednotky normálně chybné sektory. Pokud chybné sektory začít se zobrazí v pravidelných intervalech, pevný disk třeba opravit nebo vyměnit.

Poznámka: možné zabránit zobrazení odstraněním některých souborů na pevném disku chybová zpráva, ale tím tak nevyřeší problém, který je příčinou chybová zpráva se zobrazí. Defragmentace disku nečte z nepoužívaných sektorů při defragmentaci jednotky. Proto pokud na pevném disku existuje nepoužitelný sektor, který neobsahuje žádná data, problému popsaného v tomto článku pravděpodobně nenastane.

Odkazy

Nápovědu pro běžné úlohy údržby systému Windows Vista naleznete na následujícím webu:
Fix problems with common system maintenance tasks

Vlastnosti

ID článku: 160043 - Poslední aktualizace: 29. října 2009 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 95
  • Microsoft Plus! 95 Standard Edition
  • Microsoft Windows 98 Standard Edition
Klíčová slova: 
kbmt kbdefrag kbenv kberrmsg kbscandisk KB160043 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:160043

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com