Сообщение об ошибке: Обращении к странице памяти в модуле Wininet.dll

Переводы статьи Переводы статьи
Код статьи: 160158 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При использовании Microsoft Internet Explorer, MSN или Microsoft Network, может появиться сообщение об ошибке сообщение, похожее на одно из следующих сообщений:
  • Программа Iexplore вызвала ошибку неверной страницы в модуле Wininet.dll.
  • Msnviewr вызвала ошибку неверной страницы в модуле Wininet.dll.
  • Файл Urlmon.dll связан с отсутствующим файлом экспорта Wininet.dll.
  • Программа Iexplore вызвала ошибку деления в модуле Wininet.dll.
  • Msnviewr вызвала ошибку деления в модуле Wininet.dll.
  • Программа IExplore вызвала исключение c0000006h в Wininet.dll

Причина

Это может происходить по одной из следующих причин:
  • Кэширование файлов в папке временных файлов Интернета может быть поврежден.
  • Папка журнала или папки кэша, используемые Internet Explorer будут повреждены.
  • Повреждены файлы индекса, используется для отслеживания содержимого папки журнала и кэша.

Решение

Чтобы устранить эту проблему, используйте один из следующих методов:

Способ 1

Удалите папку временных файлов Интернета. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт Программы, а затем нажмите кнопку Командная строка.
  2. Введите deltree tempor ~ 1, а затем нажмите клавишу ВВОД. При появлении запроса на подтверждение удаления, нажмите клавишу Y и нажмите клавишу ВВОД.
  3. Введите exit, а затем нажмите клавишу ВВОД.
  4. Нажмите кнопку Internet Explorer значок и необходимые папки будут повторно построенная при запуске.
Если проблема продолжает возникать, переходите к следующему способу.

Способ 2

Очистите папки журнала и кэша, используемые Internet Explorer. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Параметры на Представление меню в Internet Explorer.
  2. Нажмите кнопку Навигация Нажмите кнопку Очистка журнала в области журнал, а затем нажмите Да в появившемся диалоговом окне.
  3. Нажмите кнопку Дополнительно Нажмите кнопку Параметры в разделе временные файлы Интернета нажмите кнопку Очистить папку, а затем нажмите кнопку Да в появившемся диалоговом окне.ПРИМЕЧАНИЕ: После выполнения этих действий, проверьте, если неполадки повторяются. Если он не будет разрешена, продолжите выполнение шага 4.

  4. В Панель управления, дважды щелкните значок Установка и удаление программ.
  5. В списке установленных программ выберите Internet Explorer и нажмите кнопку Добавление и удаление.
  6. После удаления обозревателя Internet Explorer, перезагрузите компьютер. При появлении сообщения «Запуск Windows 95» нажмите клавишу F8 и выберите Командной строки в меню загрузки.
  7. Введите следующие команды, нажимая клавишу ВВОД после каждой команды.

    ПРИМЕЧАНИЕ: При нажатии клавиши ВВОД после ввода каждой из следующих команд deltree следует приглашение подтвердить удаление папки. Если этот запрос не отображается, команда deltree может был введен неправильно.

          cd \windows
          smartdrv
          deltree tempor~1
          deltree history
          cd system
          ren mshtml.dll mshtml.old
          ren shdocvw.dll shdocvw.old
          ren inetcfg.dll inetcfg.old
          ren actxprxy.dll actxprxy.old
          ren wininet.dll wininet.old
          ren cachevu.dll cachevu.old
          ren inetcpl.cpl inetcpl.old
          ren shlwapi.dll shlwapi.old
          ren url.dll url.old
          ren urlmon.dll urlmon.old
          ren wsock32n.dll wsock32n.old
    						
  8. Нажмите сочетание клавиш CTRL + ALT + DELETE, чтобы перезагрузить компьютер и перезагрузить Windows в обычном режиме.
  9. Переустановите обозреватель Internet Explorer с Компакт-диска MSN.

Свойства

Код статьи: 160158 - Последний отзыв: 21 апреля 2013 г. - Revision: 6.0
Информация в данной статье относится к следующим продуктам.
  • MSN 8 Internet Service
Ключевые слова: 
kbenv kberrmsg kbprb kbmt KB160158 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке: 160158

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com