Los clientes TCP/IP no pueden conectarse a SNA Server en Windows NT 4.0

Seleccione idioma Seleccione idioma
Id. de artículo: 161778 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E161778
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

Síntomas

Los usuarios de clientes SNA Server podrían no ser capaces de conectar con el servidor SNA Server a través de sockets TCP/IP cuando se ejecutan en un equipo multitarjeta con Windows NT Server 4.0. Este problema puede ocurrir después de la instalación inicial de SNA Server o después de actualizar Windows NT Server 3.51 a Windows NT Server 4.0 en un sistema SNA Server que funcione.

En los equipos clientes de SNA Server con Windows 3.x o Windows 95 pueden producirse los mensajes de error siguientes al intentar abrir una sesión:
  • Los usuarios de la versión 3270 pueden recibir el mensaje "No SNA Servers found in configuration" (No se encontraron servidores SNA Server en la configuración). En una traza de mensaje 3270 de SNA Server, la solicitud Open (SSCP) producirá errores que tienen los códigos siguientes: err1: 0 (no se encontraron servidores) y err2: 0 (no se encontraron servidores).
  • Los usuarios de APPC pueden recibir el siguiente error ALLOCATE:
    primary_rc = 0xF004 (AP_COMM_SUBSYSTEM_NOT_LOADED)
    secondary_rc = 0xF0000001 o 0xF0000002
Un equipo cliente que ejecute Windows NT Workstation puede experimentar un retardo de 45 segundos o más antes de poder abrir una sesión a través del servidor. Este comportamiento se produce cuando se agota el tiempo de espera al intentar establecer una conexión con los sockets TCP/IP y, a continuación, se produce un intento satisfactorio de conexión a través de canalizaciones con nombre.

NOTA: un servidor con el protocolo TCP/IP conectado a más de un adaptador de red se denomina equipo "multitarjeta". Cada enlace del adaptador TCP/IP se configura con una dirección IP única conectada a diferentes subredes lógicas.

Causa

Cuando se inicializa un servidor SNA Server, la primera dirección TCP/IP devuelta por los sockets de Windows se anuncia a los equipos cliente SNA Server TCP/IP a través de su conexión "patrocinadora". Esta dirección TCP/IP puede ser la dirección de una red dispar del equipo cliente o puede tener una dirección que la puerta de enlace predeterminada del equipo cliente no sepa enrutar.

Este problema no ocurría en Windows NT Server 3.51, ya que el orden de las direcciones TCP/IP podía controlarse mediante el orden de enlace del protocolo TCP/IP en el cuadro de diálogo Enlaces, al que se tiene acceso a través de Red en el Panel de Control.

En Windows NT Server 4.0, el orden interno de las redes TCP/IP viene determinado por el orden en que se produce la inicialización de TCP/IP en los adaptadores de red. Por lo tanto, no existe ninguna forma directa de controlar el orden en que las direcciones TCP/IP se registran en el servidor SNA Server.

Solución

Para solucionar este problema, obtenga la revisión que se menciona a continuación. Esta actualización permite que el administrador especifique qué dirección IP debe anunciarse a los equipos cliente SNA en la siguiente entrada del Registro:
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SnaBase
   \Parameters\SnaTcp\ 

   Network:REG_DWORD:<número de red>
donde el valor predeterminado es 0. Si existen dos direcciones TCP/IP diferentes configuradas para este servidor, trate de establecer Red en "1".

Tenga en cuenta que la versión 3.0. de SNA Server ya admite esta entrada del Registro.

Estado

Microsoft ha confirmado que se trata de un problema de las versiones 2.0, 2.1, 2.11 y 3.0 de SNA Server. Este problema se ha corregido en el último Service Pack de SNA Server versión 2.11 para EE.UU. Para obtener información acerca de cómo obtener el Service Pack, consulte la siguiente palabra en Microsoft Knowledge Base (sin los espacios en blanco):
S E R V P A C K

Propiedades

Id. de artículo: 161778 - Última revisión: viernes, 24 de enero de 2014 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft SNA Server 2.0
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 Service Pack 4
Palabras clave: 
kbnosurvey kbarchive kbbug2.00 kbbug2.10 kbbug2.11 kbnetwork snaip snaserverservice KB161778

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com