[SNA] TCP/IP クライアントが Windows NT 4.0 上の SNA Server に接続できない

文書翻訳 文書翻訳
文書番号: 161778 - 対象製品
この記事は、以前は次の ID で公開されていました: JP161778
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

現象

TCP/IP ソケットを使うと、SNA Server クライアント ユーザーが、マルチホーム Windows NT Server 4.0 コンピュータ上で稼動している SNA Server に接続できないことがあります。この問題は初めて SNA Server をインストールした後、あるいは実環境の SNA Server システムを Windows NT Server 3.51 から Windows NT Server 4.0 へアップグレードした後に生じます。

このとき、Windows 3.x または Windows 95 上で稼動する SNA Server クライアントコンピュータがセッションを開こうとする際、以下のようなエラーが発生します。
  • 3270 ユーザーの場合、"ドメイン内に SNA Server が見つかりませんでした" というメッセージが表示されます。SNA Server 3270 メッセージ トレースでは、Open(SSCP) 要求が以下のエラー コードで失敗します。err1: 0 (サーバーが見つかりません) と err2: 0 (サーバーが見つかりません。)
  • APPC ユーザーの場合、以下のエラーが表示されます。
    primary_rc = 0xF004 (AP_COMM_SUBSYSTEM_NOT_LOADED)
    secondary_rc = 0xF0000001 or 0xF0000002
Windows NT Workstation で稼動するクライアント コンピュータでは、サーバー経由でセッションが開くまでに 45 秒以上の遅れが生じることがあります。これは TCP/IP ソケットでの接続がタイムアウトで失敗し、その後、名前付きパイプで接続が成功したことを意味します。

注意 : 複数のネットワーク アダプタに TCP/IP プロトコルがバインドされたサーバーを "マルチホーム" と呼びます。この場合、各 TCP/IP アダプタは固有の IP アドレスにバインドされ、それぞれ異なる論理サブネットに接続されます。

原因

SNA Server が初期化すると、Windows ソケットから戻ってきた最初の TCP/IP アドレスは、"スポンサー" 接続を通して SNA Server TCP/IP クライアント コンピュータに通知されます。しかし、この TCP/IP アドレスは、通知を受けたクライアント コンピュータとは異なるネットワークのアドレスであるか、クライアント コンピュータのデフォルト ゲートウェイがルーティング方法を知らないアドレスである可能性があります。

この現象は Windows NT Server 3.51 では問題ではありませんでした。[バインド] ダイアログ ボックス ([コントロールパネル] の [ネットワーク]からアクセス) を使って、TCP/IP アドレスの優先順位を、TCP/IP プロトコルのバインド順で制御することができたからです。

ところが Windows NT Server 4.0 では、TCP/IP がネットワーク アダプタ上で初期化した順番で TCP/IP ネットワークの優先順位が内部的に決定されます。このため、SNA Server への TCP/IP アドレス登録順を直接制御する手段がありません。

解決方法

この問題は、SNA Server 2.11 日本語版 Service Pack 2 を導入することで解決されます。

このアップデートを適用すれば、管理者は次のレジストリ エントリを指定することで SNA クライアント コンピュータに通知すべき IP アドレスを明示的に指定できます。
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SnaBase
   \Parameters\SnaTcp\ 
 
   Network:REG_DWORD:<ネットワーク番号>
初期値は 0 です。異なる 2 つの TCP/IP アドレスがこのサーバーに設定されている場合は、Network を "1" に設定してください。

なお、このレジストリ エントリは SNA Server 3.0 では標準的にサポートされています。

状況

弊社では、これが SNA Server 2.0、2.1、2.11、2.11 Service Pack 1 にかかわる問題であることを確認済みです。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 161778 (最終更新日 2001-06-12) をもとに作成したものです。

プロパティ

文書番号: 161778 - 最終更新日: 2014年1月30日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 2.0
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0 Service Pack 4
キーワード:?
kbnosurvey kbarchive kbnetwork kbtshoot KB161778
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com