Clientes de TCP/IP não é possível ligar ao servidor SNA no Windows NT 4.0

Traduções de Artigos Traduções de Artigos
Artigo: 161778 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Sintomas

Utilizadores do cliente SNA Server poderão não conseguir estabelecer ligação através de TCP/IP sockets SNA Server quando em execução num computador multi-homed com o Windows NT Server 4.0. Este problema poderá ocorrer depois de instalar inicialmente o SNA Server, ou depois de actualizar um trabalho SNA Server sistema do Windows NT Server 3.51 com o Windows NT Server 4.0.

Computadores de cliente do SNA Server com o Windows 3.x ou Windows 95 poderão receber os seguintes erros ao tentar abrir uma sessão:
  • Os utilizadores de 3270 poderão observar "Sem servidores SNA encontrado na configuração." Num rastreio mensagem do SNA Server 3270, o pedido Open(SSCP) falhará com os seguintes códigos de erro: err1: 0 (não existem servidores encontrados) e err2: 0 (não encontrados servidores).
  • Utilizadores APPC poderão observar o seguinte erro ALLOCATE:
    primary_rc = 0xF004 (AP_COMM_SUBSYSTEM_NOT_LOADED)
    secondary_rc = 0xF0000001 ou 0xF0000002
Um computador cliente com o Windows NT Workstation poderá observar um atraso de 45 segundos ou mais antes de obter uma sessão através do servidor. Isto é causado por um tempo limite quando tentar estabelecer ligação com o TCP/IP sockets, seguidos de uma tentativa com êxito para ligar através de pipes nomeados.

NOTA: Um servidor com o protocolo TCP/IP associado a mais do que uma placa de rede é referido como "multi-homed." Cada enlace da placa de TCP/IP está configurado com um endereço IP exclusivo ligado a sub-redes lógicas diferentes.

Causa

Quando inicia o SNA Server, o primeiro endereço TCP/IP devolvido por sockets do Windows é anunciado para computadores de cliente TCP/IP do SNA Server sobre a ligação "patrocinador". Este endereço de TCP/IP pode ser para um endereço numa rede do computador cliente diferentes ou tem um endereço de gateway predefinido do computador cliente não sabe como encaminhar.

Não foi um problema no Windows NT Server 3.51 porque a ordem dos endereços TCP/IP podiam ser controlado pela ordem de enlace do protocolo TCP/IP na caixa de diálogo ligações (acedida na rede do painel de controlo).

No Windows NT Server 4.0, a ordem interior das redes TCP/IP é determinada pela ordem em que ocorre a inicialização de TCP/IP através de placas de rede. Por conseguinte, não é possível controlar directamente a ordem que os endereços TCP/IP estão registados no servidor SNA.

Resolução

Para resolver este problema, obtenha a correcção mencionada abaixo. Esta actualização permite ao administrador especificar o endereço IP que deve ser anunciado aos computadores cliente SNA a seguinte entrada de registo:
   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\SnaBase
   \Parameters\SnaTcp\ 

   Network:REG_DWORD:<network number>
				
onde a predefinição é 0. Se existirem dois endereços TCP/IP diferentes configurados para este servidor, tente definir a rede para "1".

Tenha em atenção que esta entrada de registo já é suportada por SNA Server 3.0.

Ponto Da Situação

Microsoft confirmou que este problema existe no SNA Server versões 2.0, 2.1, 2.11 e 3.0. Este problema foi corrigido no SNA Server mais recente versão 2.11 dos Estados Unidos Service Pack. Para obter informações sobre como obter este Service Pack, consulta a seguinte palavra na Microsoft Knowledge Base (sem espaços):
S E R V P A C K

Propriedades

Artigo: 161778 - Última revisão: 6 de fevereiro de 2014 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft SNA Server 2.0
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 Service Pack 4
Palavras-chave: 
kbnosurvey kbarchive kbmt kbnetwork KB161778 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 161778

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com