[NT]SCSI デバイスが認識されないことがある

文書翻訳 文書翻訳
文書番号: 162471 - 対象製品
この記事は、以前は次の ID で公開されていました: JP162471
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

目次

現象

重要: この資料には、レジストリを編集するような情報が含まれています。
       レジストリを編集する前に、レジストリを編集したために問題が発生した場合の
       ために、レジストリの復元方法を理解しておく必要があります。
       復元方法については、Regedt32.exe の「レジストリ キーを復元する」
       というオンライン ヘルプのトピックを参照してください。
Windows 4.0 で、0 (ゼロ) 以外に Logical Unit Number (LUN) を使用しており、それがシステム起動後にオンラインになる SCSI デバイスを認識できない場合があります。

注意 : ハードウェア RAID デバイスは、通常 nonzero LUN を使用します。

原因

LUN 0 が既に検出されている場合は Scsiport.sys ドライバが non-zero LUN を走査しないため、この問題が発生します。

たとえば、ID=0、LUN=0 のシングル SCSI ディスク ドライブのシステムを持っており、コンピュータを起動したとします。次に、ID=0、LUN=1 に設定された外部ドライブの電源を入れます。Windows NT 4.0 システムは、この新しいデバイスを確認することができません。ディスク マネージャを実行することで IOCTL_SCSI_RESCAN_BUS コールを送信したとしても、Scsiport.sys ドライバ問題のために新しいデバイスは検出されません。

状況

nonzero LUNs を再走査するには、以下に示す 2 つの条件を満たす必要があります。
  • WinNT 4.0 サービスパック 3 (またはそれ以降) 版の Scsiport.sys のインストール

    および
  • LunRescan 値のディスク キーへの追加
これらの条件が満たされている場合、IOCTL_SCSI_RESCAN_BUS により nonzero LUN が検出されます。システムにディスク デバイスがインストールされていなくても、ディスク キーの値が使用されます。

この値をディスク キーに追加するには、以下の手順にしたがってください。

  1. レジストリ エディタ (Regedt32.exe) を起動し、以下のサブキーに移動します。
    \\HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Disk
  2. ディスクキーに以下の値を追加します。

    Value name: LunRescan
    Data type: REG_MULTI_SZ
この値のデータは NULL のままで、IOCTL の再走査はすべてのデバイスに適用されます。特定のデバイスを指定するには、値のストリングがデバイスの Inquiry String と一致しなければばりません。IOCTL が発行される場合は一致するストリングのみが再走査されなければなりませんが、SCSIPORT.SYS を実装すれば、再走査は特定のデバイスのみに限定されません。これは、次回のリリースで変更される可能性があります。

このキーが追加された後の再起動は必要ありません。これで、IOCTL_SCSI_RESCAN_BUS が nonzero LUN を検索することができます。

状況

弊社ではこの問題を Windows NT 4.0 日本語版の問題と認識しております。なお、この問題は Windows NT 4.0 日本語版の最新サービスパック (SP3 以降 ) で修正されております。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 162471 (最終更新日 1998-04-24) をもとに作成したものです。

プロパティ

文書番号: 162471 - 最終更新日: 2014年2月2日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
キーワード:?
kbnosurvey kbarchive kbbug ntsrvwkst kbsetup ntsetup ntdriver kbbug4.00 kbfix4.00 kbfix4.00.sp3 KB162471
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com