No se puede cambiar el idioma predeterminado de los nuevos documentos

Seleccione idioma Seleccione idioma
Id. de artículo: 163057 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E163057
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Si intenta cambiar el idioma predeterminado usando el cuadro de diálogo Definir idioma (en el menú Herramientas, seleccione Idioma y haga clic en Definir idioma) o cambiando el estilo Normal, el idioma predeterminado en Word vuelve continuamente a la opción "no revisar". El cambio del idioma predeterminado no tiene ningún efecto.

Causa

Este problema se da cuando el equipo tiene instalado un controlador de teclado antiguo.

Word selecciona el idioma predeterminado en función de la configuración actual del controlador de teclado. (El teclado actual se selecciona en el Panel de control de Windows.) Si en el estilo Normal se ha definido un idioma distinto al de la configuración del teclado, Word aplica el idioma del teclado actual en el estilo Normal como formato manual (o "directo").

Por ejemplo, si el estilo Normal tiene definido el idioma inglés y se usa un teclado alemán, el texto de los nuevos documentos tiene el formato del idioma alemán. Word realiza esta operación aplicando de forma manual el formato alemán al estilo Normal.

Solución

Para corregir este problema, instale la revisión Service Release 1 (SR- 1) de Microsoft Word 97 para Windows. La revisión Service Release 1 (SR-1) de Microsoft Word 97 para Windows corrige este problema en los sistemas que sólo tienen instalado un controlador de teclado. No lo hace, sin embargo, cuando se han instalado varios controladores de teclado en Windows.

Para solucionar este problema, defina el idioma del texto de forma manual en cada documento. Para ello, utilice uno de los métodos siguientes.

Método 1: Dar manualmente el formato del idioma deseado

Seleccione el texto al que desea dar un formato de idioma específico. Para aplicar el idioma, en el menú Herramientas seleccione Idioma y haga clic en Definir idioma.

Este cambio debe hacerlo en cada documento. Si hace clic en el botón Predeterminado no se obtiene ningún efecto apreciable en los nuevos documentos.

Método 2: Instalar y seleccionar el controlador de teclado del idioma deseado

Use el Panel de control para cambiar el idioma predeterminado de los nuevos documentos.

Para obtener más información acerca de cómo instalar y seleccionar controladores de teclado para distintos idiomas, consulte el artículo siguiente de Microsoft Knowledge Base:
E141306 Cómo habilitar la compatibilidad multilingüe en Windows 95

Método 3: Dar de forma manual el formato de idioma en la plantilla Normal

Use el formato manual de la plantilla Normal para que el texto tenga un formato de idioma específico:

  1. Abra el archivo de la plantilla Normal.dot.
  2. En el menú Edición, haga clic en Seleccionar todo.
  3. En el menú Herramientas, seleccione Idioma y haga clic en Definir idioma.
  4. Guarde y cierre el archivo de la plantilla Normal.dot.
Al crear un nuevo documento con la plantilla Normal, el idioma seleccionado en el paso 3 se aplicará al texto como formato manual.

Método 4: Presione CTRL+BARRA ESPACIADORA (restablecer formato de caracteres)

En el nuevo documento, seleccione el texto y presione CTRL+BARRA ESPACIADORA.

Esta combinación de teclas quita del texto seleccionado cualquier formato de carácter que se haya aplicado manualmente, como es el caso del idioma del teclado utilizado. El formato de los caracteres del texto, incluido el idioma, pasará a ser el que se haya definido en el estilo del texto.

Estado

Microsoft ha confirmado que se trata de un problema de Microsoft Word 97 para Windows. Este problema se ha solucionado en la revisión SR-1 de Microsoft Word 97.

Para obtener más información acerca de la revisión SR-1, consulte el siguiente artículo de Microsoft Knowledge Base:
172475 OFF97: How to Obtain and Install MS Office 97 SR-1

Más información

Cuando se da al texto el formato "no revisar", las herramientas de revisión ignoran ese texto y no lo revisan. En la práctica lo que sucede es que las palabras que deberían marcarse como errores ortográficos no aparecen como tales.

Word determina el idioma predeterminado en función del controlador de teclado que está actualmente en uso. Si el controlador actual de teclado no es válido o está obsoleto, Word seleccionará "no revisar" como idioma predeterminado de los documentos.

Si tiene instalado un controlador de teclado obsoleto, puede recibir el siguiente mensaje cuando intente comprobar la configuración del teclado en el Panel de control de Windows:
Se detectó un controlador de teclado antiguo. Panel deshabilitado.
Si usa Windows 95, puede realizar una prueba rápida para determinar si es el controlador de teclado el que ocasiona el problema. Para ello, inicie Windows en el Modo a prueba de errores.

NOTA: Si inicia Windows NT en el modo VGA no se omite el controlador de teclado.

  1. Reinicie el equipo.
  2. Cuando vea el mensaje "Iniciando Windows 95", presione F8.
  3. Seleccione el Modo a prueba de errores y, a continuación, presione ENTRAR.

    Windows se inicia y carga los controladores genéricos.
  4. Inicie Word.
  5. En el menú Herramientas, haga clic en Idioma.

    Si hay seleccionado un idioma distinto a No revisar, el problema está siendo ocasionado por el controlador de teclado que está instalado actualmente. El usuario debe ponerse en contacto con el fabricante del hardware para obtener un controlador actualizado.
Para determinar cuál es el controlador de teclado que se carga, compruebe la configuración del teclado usando uno de los métodos siguientes:

Método 1: Comprobar el Panel de control de Windows

  1. En el menú Inicio, seleccione Configuración y haga clic en Panel de control.
  2. Haga doble clic en Teclado.
  3. Haga clic en la ficha General.

    El nombre del controlador de teclado aparece en el cuadro Tipo de teclado.

Método 2: Comprobar el archivo System.ini

  1. Haga clic en Inicio, haga clic en Ejecutar y escriba 'sysedit' (sin las comillas).
  2. Haga clic en la ventana system.ini para que pase al primer plano.
  3. En la sección [boot] debe haber una línea de teclado similar a la siguiente:

    keyboard.drv = keyboard.drv
Para obtener información adicional, consulte los siguientes artículos de Microsoft Knowledge Base:
E141306 Cómo habilitar la compatibilidad multilingüe en Windows 95

Propiedades

Id. de artículo: 163057 - Última revisión: viernes, 7 de febrero de 2014 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Word 97 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbdta kbenv kbhw kbproof word97 KB163057

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com