Limit počtu souborů souběžně otevřít kořenové úložiště

Překlady článku Překlady článku
ID článku: 163202 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Aplikace pomocí volání API StgCreateDocFile() nebo StgOpenStorage() otevřít několik souborů úložiště může selhat.

Tento problém nenastává v systému Windows 95 nebo Windows NT 3.51.

Příčina

Windows NT 4.0 omezuje počet současně otevřených kořenového úložiště souborů do kolem 500 PROCESS PER. Je třeba poznamenat, že se jedná za limit procesu (například proces 1 můžete otevřít 498 kořenové úložišť, současně proces 2 můžete také otevřít 498 kořenové úložišť atd.)

Windows 95 a Windows NT 3.51 použít globální sdílené paměti haldy z 64 M; zatímco systém Windows NT 4.0 používá haldy za kořenový otevření 4 MB. Za předpokladu, že limit adresa 2 G uživatele pro procesy, Windows NT 4.0 podporuje kolem 500 kořenové otevře pro proces.

Řešení

V systému Windows NT 4.0 byl 2 MB, což otevře kolem 1000 další zmenšení velikosti za kořenový otevření haldy. Snížení velikosti haldy znamená aplikací, nebude možné otevřít tolik sub-storages nebo nesvěřené tolik transakčního změny zachovat.

Prohlášení

Společnost Microsoft potvrzuje, že se to být problém v systému Microsoft Windows NT verze 4.0. Tento problém byl opraven v nejnovější aktualizaci Service Pack pro Microsoft Windows NT 4.0 USA. Informace o získání aktualizace service pack dotazu následující slovo Microsoft Knowledge Base (bez mezery):
V P SE C KB ÚT E R

Vlastnosti

ID článku: 163202 - Poslední aktualizace: 13. února 2014 - Revize: 1.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Klíčová slova: 
kbnosurvey kbarchive kbmt kbbug kbinterop kbnetwork KB163202 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:163202

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com