PPT: Cómo crear un complemento de 97 de PowerPoint

Seleccione idioma Seleccione idioma
Id. de artículo: 163461 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo describe cómo crear un complemento para Microsoft PowerPoint con Microsoft Visual Basic para aplicaciones. La macro de ejemplo (procedimiento Sub) agrega un comando al menú Herramientas para permitirle cambiar la vista a la vista Clasificador de diapositivas si no está ya en la vista Clasificador de diapositivas.

Más información

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía tanto expresa como implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. Este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se utilizan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos que cumplan sus requisitos específicos.

Paso 1: crear el código para el complemento

  1. Inicie PowerPoint y cree una presentación en blanco.
  2. En el menú Herramientas, elija Macro y, a continuación, haga clic en Editor de Visual Basic.
  3. En el Editor de Visual Basic, vaya al menú Insertar y haga clic en Módulo.
  4. Escriba el siguiente código en la ventana módulo.

    Nota: Puede sustituir el código para el código siguiente.
          Sub ChangeView()
    
             ' Check to see whether a presentation is open.
             If Presentations.Count <> 0 Then
                If ActiveWindow.ViewType <> ppViewSlideSorter Then
                   ActiveWindow.ViewType = ppViewSlideSorter
                End If
             Else
                MsgBox "No presentation open. Open a presentation and " _
                   & "run the macro again.", vbExclamation
             End If
          End Sub
    Nota: línea que está precedida por un apóstrofo (') presenta un comentario en el código. Se proporcionan comentarios para explicar lo que hace el código en un punto determinado en el procedimiento. Este texto es opcional y puede excluirse en el código.

Paso 2: crear la Macro Auto_abrir

La macro Auto_abrir almacena el código de inicialización para el complemento y se ejecuta automáticamente cuando el complemento se carga por PowerPoint. El código siguiente agrega un comando (cambiar a clasificador de diapositivas) al menú herramientas que se ejecuta el código de complemento.
     Sub Auto_Open()

      Dim NewControl As CommandBarControl

      ' Store an object reference to a command bar.
      Dim ToolsMenu As CommandBars

      ' Figure out where to place the menu choice.
      Set ToolsMenu = Application.CommandBars

      ' Create the menu choice. The choice is created in the first
      ' position in the Tools menu.
      Set NewControl = ToolsMenu("Tools").Controls.Add _
                       (Type:=msoControlButton, _
                        Before:=1)

      ' Name the command.
      NewControl.Caption = "Change to Slide Sorter"

      ' Connect the menu choice to your macro. The OnAction property
      ' should be set to the name of your macro.
      NewControl.OnAction = "ChangeView"

   End Sub
				

Paso 3: crear la Macro Auto_Close

La macro Auto_Close se ejecuta cuando se descarga un complemento por PowerPoint. La macro Auto_Close almacena el código de limpieza. El código siguiente quita el comando agregado al menú Herramientas en la sección "Crear la Macro Auto_abrir" de este artículo.
   Sub Auto_Close()

      Dim oControl As CommandBarControl
      Dim ToolsMenu As CommandBars

      ' Get an object reference to a command bar.
      Set ToolsMenu = Application.CommandBars

      ' Loop through the commands on the tools menu.
      For Each oControl In ToolsMenu("Tools").Controls

            ' Check to see whether the comand exists.
            If oControl.Caption = "Change to Slide Sorter" Then

              ' Check to see whether action setting is set to ChangeView.
              If oControl.OnAction = "ChangeView" Then

                  ' Remove the command from the menu.
                  oControl.Delete
               End If
            End If
      Next oControl
   End Sub

				

Paso 4: crear el archivo .ppa

  1. En el menú Depurar, haga clic en compilar VBAProject.

    Si el código tiene errores de compilación, no podrá crear el complemento.

    Nota: Este paso sólo es necesario si no está activada la opción de comprobación de sintaxis automática en el Editor de Visual Basic. Para activar o desactivar esta opción, siga estos pasos:

    1. Haga clic en Opciones en el menú Herramientas y, a continuación, haga clic en la ficha Editor.
    2. Desactive o Active la casilla de verificación comprobación de sintaxis automática y, a continuación, haga clic en Aceptar.

      Esta opción está seleccionada, vaya al paso 2.
    3. Guarde la presentación.
    4. En el menú Archivo, haga clic en Cerrar y volver a Microsoft PowerPoint.
    5. En el menú Archivo, haga clic en Guardar como.
    6. Seleccione presentación (* .ppt) en la lista Tipo de guardar.
    7. Nombre de la presentación y, a continuación, haga clic en Guardar.

      El código de complemento se guarda ahora en la presentación.
    8. Crear el archivo ppa.
    9. En el menú Archivo, haga clic en Guardar como.
    10. Seleccione complemento de PowerPoint (* .ppa) en la lista Tipo de guardar.
    11. En el cuadro Nombre de archivo, escriba un nombre para el complemento y, a continuación, haga clic en Guardar.

      Normalmente, los complementos de PowerPoint se colocan en la carpeta c:\Archivos de programa\ Microsoft Office\Office. Sin embargo, puede elegir otra carpeta si lo desea.

Paso 5: carga el complemento

  1. En el menú Herramientas, haga clic en complementos.
  2. Haga clic en Agregar nuevo.
  3. En el cuadro de diálogo Agregar nuevo PowerPoint de, seleccione el archivo de complemento que creó en la sección "Paso 4 - crear el PPA archivo". Haga clic en Aceptar.
  4. En el cuadro de advertencia de la macro, haga clic en <b>Activar macros</b>.

    Nota: Si recibió un archivo de un origen desconocido, debe hacer clic en Deshabilitar Macros.

    Ahora se ejecuta la macro Auto_abrir.
Para información sobre cómo utilizar el modelo de objetos de PowerPoint para cargar complementos, haga clic en el Ayudante, escriba "Cargar la propiedad", haga clic en Buscar y, a continuación, haga clic para ver "Propiedad Loaded".

Nota: Si el Ayudante está oculto, haga clic en el botón Ayudante de Office en la barra de herramientas estándar. Si la Ayuda de Visual Basic no está instalado en su equipo, consulte el siguiente artículo en Microsoft Knowledge Base: cómo agregar o quitar un único programa de Office o en componentes

Paso 6: descargar el complemento

Utilice los pasos siguientes para descargar un complemento:

  1. En el menú Herramientas, haga clic en complementos.
  2. En la lista Complementos disponibles, seleccione el complemento que desee descargar y, después, haga clic en descargar o quitar.

    Al hacer clic en descargar, el complemento es descargado pero permanecerá en la lista Complementos disponibles. Cuando haga clic en quitar, el complemento se descarga y se quita de la lista de complementos disponibles.

    Ahora se ejecuta la macro Auto_Close.
Para información sobre cómo utilizar el modelo de objetos de PowerPoint para cargar complementos, haga clic en el Ayudante, escriba "Cargar la propiedad", haga clic en Buscar y, a continuación, haga clic para ver "Propiedad Loaded".

Nota: Si el Ayudante está oculto, haga clic en el botón Ayudante de Office en la barra de herramientas estándar. Si no está instalado Ayuda de Visual Basic en el equipo, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:
120802Cómo agregar o quitar un único programa o componente de Office

Paso 7: protección del complemento con una contraseña

Cuando guarda una presentación como un complemento, PowerPoint no protege el código fuente. Puede proteger el código con una contraseña, mediante los pasos siguientes.

Nota: Debe proteger el proyecto con una contraseña antes de guardar el complemento.
  1. En el menú Herramientas, haga clic en Propiedades VBAProject y haga clic en la ficha protección.
  2. Haga clic para seleccionar la casilla de verificación Bloquear proyecto para ver.
  3. En contraseña para ver propiedades del proyecto, escriba la contraseña que desee en los cuadros contraseña y Confirmar contraseña.
  4. Haga clic en Aceptar.

    Ahora se requiere una contraseña para ver el código fuente.

Referencias

Para obtener más información acerca de cómo obtener ayuda acerca de Visual Basic para Aplicaciones, consulte el siguiente artículo en Microsoft Knowledge Base:
163435Recursos de programación para Visual Basic para aplicaciones

Propiedades

Id. de artículo: 163461 - Última revisión: lunes, 03 de febrero de 2014 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft PowerPoint 98 para Macintosh
  • Microsoft PowerPoint 97 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbcode kbdtacode kbhowto kbmacro kbprogramming KB163461 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 163461

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com