Changing Source Code Editor in Internet Explorer

Article translations Article translations
Article ID: 163606 - View products that this article applies to.
This article was previously published under Q163606
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to configure Internet Explorer to display an Edit button on the toolbar. This allows you to view Hypertext Markup Language (HTML) source code with the editor of your choice.

MORE INFORMATION

By default, you can use the Source command on the View menu in Internet Explorer to view HTML source code in Notepad. To add an Edit button to the toolbar so that you can view HTML code in the editor you want, follow these steps:
  1. Quit Internet Explorer (if it is running).
  2. Double-click My Computer.
  3. On the View menu, click Options (or Folder Options).
  4. Click the File Types tab. In the Registered File Types box, click Internet Document (HTML), and then click Edit.

    NOTE: If you are running Internet Explorer 4.01 or Windows 98, click Microsoft HTML Document 4.0. If you are running Internet Explorer 5.0, click Microsoft HTML Document 5.0.
  5. If Edit is not listed in the Actions box, there is not an Edit button on the Internet Explorer toolbar. To add an Edit button to the toolbar, click New, type Edit in the Action box, and then type the full path to the name of the editor that you want to use in the Application Used To Perform Action box. If you are using Internet Explorer 2.0 or 3.x as your browser, you may need to type a space and %1 at the end of the command. For example, if you want to use Notepad to be your default HTML editor, type the following command:
    c:\windows\notepad.exe "%1"
    NOTE: If you do not know the path or file name for the editor you want to use, you can click Browse to locate the editor instead of manually typing it in the Application Used To Perform Action box.

    If Edit is listed in the Actions box, there is already an Edit button on The Internet Explorer toolbar. To select a default HTML editor, click Edit under Actions, click the Edit button, and then type the full path to the program you want to use as your default HTML editor.
  6. Click OK, click Close, and then click Close again.
Once you have completed these steps, Internet Explorer displays an Edit button on the toolbar and a Page (or Current Page) command on the Edit menu. Use either of these to view the source code for the current document. Also, after you have completed these steps, the Edit command is added to the context menu that appears when you right-click an HTML file.

Notes

  • If you are using Internet Explorer 2.0 or 3.x and do not type the "%1" at the end of the command, you may receive the following error message when you attempt to view source code:
    <DRIVE>:\Temporary Cannot find this file. Please verify that the correct path and file name are given.
    This error occurs when the file is contained in a folder with spaces in its long file name. Examples include the "Temporary Internet Files" folder and the "My Documents" folder.
  • The editor you choose must be able to understand long file names, or you may receive an error message similar to the following when you try to view the source code:
    Cannot find the "C:\Windows\tempor~1\Cache\<filename.htm>
  • Although the Edit button and Current Page command both open the HTML source in the editor you specified, using the Source command on the View menu still opens the HTML source code in Notepad.

Properties

Article ID: 163606 - Last Review: January 19, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 1.0
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 3.2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Windows 98 Standard Edition
Keywords: 
kbinfo KB163606
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com