Winlogon môže zlyhať, ak je tretia strana Gina.dll súbor chýba alebo je poškodený

Preklady článku Preklady článku
ID článku: 164486 - Zobraziť produkty, ktorých sa tento článok týka.
DÔLE?ité: Tento článok obsahuje informácie o upravovaní databázy registry. Pred upravovaním databázy registry, skontrolujte, či ste pochopiť, ako ho obnoviť, ak vyskytne sa problém. Informácie o tom, ako to urobiť, zobraziť "Restoring Register"tému Pomocníka v Regedit.exe alebo „obnova kľúča databázy Registry" Témy Pomocníka Regedt32.exe.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Tretej strany firiem môže nahradiť súbor Gina.dll, ktorý je dodávaný s Windows NT úpravou nasledujúci kľúč databázy registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon Hodnota = GinaDLL REG_SZ


Ak súbor uvádzaný v databáze registry chýba alebo poškodený, Winlogon zlyhá začať a modrá obrazovka chybové hlásenie vyskytuje.

Poznámka: systém Windows NT 3.51 načíta súbor Msgina.dll ak je tretia strana Gina.dll súbor nebol nájdený.

PRICINA

Windows NT 4.0 je navrhnutý tak, že nebude nahrať ak Gina.dll (alebo jeho nahradenie) je nie je prítomná.

RIESENIE

Ak chcete tento problém odstrániť, nahradiť chýbajúce alebo poškodené Gina.dll s verzia dodávaná so systému Windows NT.

Upozornenie: Nesprávne pomocou editora databázy Registry môže spôsobiť vážne problémy môžu vyžadovať preinštalovanie operačného systému. Microsoft nemôže zaručiť, že problémy vyplývajúce z nesprávneho použitia editora databázy Registry môžu byť vyriešené. Použite Editor databázy Registry na vlastné riziko.

Informácie o tom, ako upraviť databázu registry, zobrazenie "zmena kľúče a Hodnoty"témy pomocníka Editora databázy Registry (Regedit.exe) alebo"pridať a odstrániť Informácie v databáze Registry"a tém Pomocníka"Upravovať údaje databázy Registry" Program Regedt32.exe. Poznámka, že ste mali zálohovať register pred úpravou.

Ak je systém Windows NT nainštalovaný oblasti FAT, kópie softvéru súbor ktorý je umiestnený v adresári %SystemRoot%\System32\Config na disketu a prijať ho do iného počítača so systémom Windows NT a sledovať tieto pokyny:
  1. Spustite Editor databázy Registry (Regedt32.exe).
  2. Prejdite do okna HKEY_LOCAL_MACHINE.
  3. Vyberte položku kľúča HKEY_LOCAL_MACHINE.
  4. Z menu databázy Registry, kliknite na položku príkazy načítať podregister.
  5. Vyhľadajte a vyberte zlyhalo cesta k miestu inštalácie systému Windows NT, napríklad Winnt.
  6. Prejdite do adresára System32\Config a vyberte súbor softvéru.

    Poznámka: Súbor softvéru s žiadnu príponu je ten správny.
  7. Kliknite na tlačidlo OK a zadajte názov kľúča testu.
  8. Kliknite dvakrát na nový kľúč testu a sledovať túto cestu:
    Microsoft\Windows NT\Current Version\Winlogon
  9. Upraviť položku Ginadll:REG_SZ:MSGINA.KNIŽNICA DLL
  10. Z menu databázy registry, kliknite na položku uvoľniť podregister.
  11. Reštartujte do pôvodnej inštalácie systému Windows NT.

DALSIE INFORMACIE

Spoločnosť Microsoft odporúča, že nijaká tretia strana použiť zva¨zky FAT na testovanie ich verzie Gina.dll. To uľahčuje výmenu nových Gina.dll súbor.

Vlastnosti

ID článku: 164486 - Posledná kontrola: 17. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
Kľúčové slová: 
kbprb kbmt KB164486 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:164486

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com