Article ID: 164785 - Last Review: January 19, 2007 - Revision: 3.1

ACC97: Database Does Not Close and Reopen After Failed Synchronization

This article was previously published under Q164785
Advanced: Requires expert coding, interoperability, and multiuser skills.

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SYMPTOMS

After you try to synchronize with a replica that has been deleted, you receive one of the following error messages:
Microsoft Access can't open the database '<Database Name>'.

'<Database Name>' isn't a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.
   -or-
				
Microsoft Access can't open the database '<Database Name>'.

Couldn't find file '<Database Name>'.

This is followed by another message:
   Microsoft Access has deleted '<Database Name>' and removed it from the
   replica set.

   This change isn't reflected until the database is closed and reopened.

   Do you want Microsoft Access to close and reopen the database now?
				

However, when you click Yes to close and reopen the database, nothing happens.

CAUSE

Microsoft Access 97 cannot automatically close and reopen the database because the Synchronize Database dialog box is still open.

RESOLUTION

Click Cancel in the Synchronize Database dialog box, and then manually close and reopen the database.

MORE INFORMATION

Steps to Reproduce Problem


  1. Create a new blank database named dbTest.mdb.
  2. On the Tools menu, point to Replication, and then click Create Replica.
  3. Click Yes in the message box that states the database must be closed before you can create a replica.
  4. Click No in the message box that prompts you to make a backup copy of your database.
  5. In the "Location of New Replica" dialog box, select a folder and file name for the new replica, and then click OK.
  6. Delete the new replica database using Windows Explorer or File Manager.
  7. On the Tools menu, point to Replication, and then click Synchronize Now.
  8. In the Synchronize Database dialog box, select the deleted replica in the Synchronize With box, and then click OK. Note that you receive the error messages listed in the "Symptoms" section. When you click Yes to close and reopen the database, nothing happens.

REFERENCES

For information about a related issue in Microsoft Access 97, please see the following article in the Microsoft Knowledge Base:

164784  (http://support.microsoft.com/kb/164784/EN-US/ ) ACC97: Unable to Remove Deleted Replica from Synchronize List

APPLIES TO
  • Microsoft Access 97 Standard Edition
Keywords: 
kbprb kbusage KB164785
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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