Article ID: 164921 - Last Review: January 19, 2007 - Revision: 2.1 OFF97: Mso97.dll and Mso7enu.dll Errors Appear When Starting a ProgramThis article was previously published under Q164921 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
On This PageSYMPTOMS
When you start any of the programs listed at the beginning of this
article, either of the following error messages may appear:
Error Starting Program A required .DLL file, MSO97.DLL, was not found.
-or-
<Program> requires the file 'MSO7enu.DLL' to run. Run Setup again to
assure proper installation.
CAUSE
This problem may occur if the following conditions are true:
WORKAROUND
To prevent this problem from occurring, do not install a stand-alone
version of the program after you perform a "Run from Network Server"
installation on the same computer. To install a stand-alone version of
Microsoft Outlook after you perform a "Run from Network Server"
installation of other Office 97 program, perform a "Run from Network
Server" installation of Microsoft Outlook 97.
To work around this problem, use either of the following two methods. Method 1: Copy Ms*.dll Files to the Folder Indicated in the RegistryWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.Copy the .dll files that the program cannot find to the folder that the program searches. To determine which folder to copy the files to, look in the registry. The following registry key indicates the folder that an Office program search for the Mso97.dll and Mso7enu.dll files: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\8.0\BinDirPath
If you copy Mso97.dll and Mso7enu.dll to the folder referenced by this
key, you can prevent the problem from occurring. To do this, use the
following steps:
After you copy the Mso97.dll and Mso7enu.dll files to the correct folder, start the stand-alone program. Method 2: Change the PATH Statement in Autoexec.batYou can also prevent this problem from occurring by modifying the PATH statement in the Autoexec.bat file so that it refers to the folder on the network server that contains Mso97.dll and Mso7enu.dll. (Usually, these files are located in the Msoffice\Office folder on the network server.)NOTE: To use this method, you must assign a permanent drive letter to the network server and share. To do this, use the Map Network Drive button in the Windows Explorer to connect a drive letter. To modify the Autoexec.bat file, follow these steps:
NOTE: If you must modify the PATH statement in the Autoexec.bat to resolve the problem, the symptoms in this article will occur when you restart Windows in Safe Mode or restart Windows in Step-by-Step Confirmation and choose not to load the Autoexec.bat. For additional information, click the article number below to view the article in the Microsoft Knowledge Base: 190023
(http://support.microsoft.com/kb/190023/EN-US/
)
How to Edit the Autoexec.bat File in Microsoft Windows 98
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
When you install any of the programs listed at the beginning of
this article, many keys, including the BinDirPath key, are created
in your registry.
The BinDirPath key refers to the folders in which programs search for certain dynamic-link library (DLL) files, including Mso97.dll and Mso7enu.dll. In most cases, these two files are stored in the same folder as the program files that use them. However, if you perform a "Run from Network Server" installation of Microsoft Office 97, and then perform an installation of a stand-alone program, the BinDirPath key may point to a folder that does not contain Mso97.dll or Mso7enu.dll. If this occurs, you may not be able to start the stand-alone program because it cannot find Mso97.dll and Mso7enu.dll in the folder. Programs installed as part of Microsoft Office 97 start correctly because the program files are in the same folder as the Mso97.dll and Mso7enu.dll files. APPLIES TO
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