Article ID: 165309 - Last Review: November 15, 2006 - Revision: 1.1

FIX: Security Information Is Not Synchronized

This article was previously published under Q165309
Expand all | Collapse all

SYMPTOMS

If client "A" initializes COM, then client "B" starts and makes a remote COM call, an attempt by Client "A" to make a secure remote COM call fails with error RPC_E_NO_GOOD_SECURITY_PACKAGES.

CAUSE

The problem occurs because security information is not being synchronized properly if, when it is time to launch Rpcss.exe in a client, COM finds that it has already been launched.

RESOLUTION

You can work around this problem by pre-launching Rpcss.exe before launching the client process. A convenient place to do this is in the registry at HKLM\Software\Microsoft\Windows\CurrentVersion\Run (launches when the shell loads) or \RunServices (launches immediately upon machine boot, that is, before login). Add a named value (any name) and a value of "RPCSS.EXE".

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This was corrected for DCOM on Windows 95 in build number 518.

MORE INFORMATION

NOTE: There are other reasons a client application may not be able to communicate with a remote object.

For additional information, please see the following article in the Microsoft Knowledge Base:
165300  (http://support.microsoft.com/kb/165300/EN-US/ ) BUG: Remote COM Calls Fail Because RPCSS Is Not Started
You can determine whether an observed failure is caused by failure to synchronize security information by manually starting RPCSS before launching the client process that failed.

APPLIES TO
  • Microsoft OLE 4.0, when used with:
    • Microsoft Windows 95
Keywords: 
kbbug kbdcom kbfix kboswin95fix KB165309
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations