Jak zakázat službu nebo zařízení, které brání spuštění systému Windows NT

Překlady článku Překlady článku
ID článku: 165748 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Pokud službu nebo zařízení ovladač automaticky spuštěna a není kompatibilní s aktuální verzí systému Windows NT nebo Windows 2000, službu nebo zařízení ovladač nemusí umožnit Windows zůstanou booted dostatečně dlouhou dobu k vypnutí služby nebo zakázat ovladač zastaralé zařízení.

Příčina

K tomu může dojít při Windows je inovován na novou verzi ke před odebráním nebo zastavení služby nebo zařízení jiných výrobců.

Řešení

Upozornění: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávného použití Editoru registru budete moci vyřešit. Editor registru používáte na vlastní nebezpečí. Proveďte následující kroky k vyřešení tohoto problému:
  1. Paralelní kopii systému Windows nainstalovat do jiné složky na místním pevném disku.

    Poznámka: postup A Další informace na paralelní instalace klepněte na článek číslo článku databáze Microsoft Knowledge Base:
    259003Jak a proč provádět paralelní instalaci systému Windows NT 4.0
  2. Spusťte Regedt32.exe z nově instalované verze systému Windows a přejděte na následující klíč:
    HKEY_LOCAL_MACHINE
  3. V nabídce Registr klepněte na příkaz Načíst podregistr a potom otevřete následující soubor registru původní instalace systému Windows:
          %SystemRoot%\System32\Config\System
    						
    přiřadit název, než v dalším dialogovém (dialogové okno název klíče) systému (například "Test").

    Poznámka: před změněn název klíče musí být soubor otevřen.
  4. Přejít na následující klíč registru a poznamenejte si hodnotu (vybere které ControlSet00x načíst při spuštění a je jedna potřebuje změny) Current: REG_DWORD:
    HKEY_LOCAL_MACHINE\TEST\Select
  5. Proveďte následující kroky k zakázání služby:
    1. Přejít na následující klíč registru:
      HKEY_LOCAL_MACHINE\TEST\ControlSet00x\Services\<Name of suspected service>


      Kde x je hodnota Current: REG_DWORD
    2. Změnit hodnotu Start: REG_DWORD: 0x4.

      Poznámka: Další služby platné možnosti spuštění jsou:
               Automatic   0X2
               Manual      0x3
               Disabled    0x4
      							
  6. Proveďte následující kroky zakázat ovladač zařízení:
    1. Přejít na následující klíč registru:
      HKEY_LOCAL_MACHINE\TEST\ControlSet00x\Services\<Name of suspect Driver>


      Kde x je hodnota Current: REG_DWORD
    2. Změnit hodnotu Start: REG_DWORD: 0x4.

      Poznámka: Další služby platné možnosti spuštění jsou:
               Boot        0x0
               System      0x1
               Automatic   0X2
               Manual      0x3
               Disabled    0x4
      							
    3. Po provedení potřebných změn přejít na následující klíč registru a v nabídce Registr klepněte na příkaz Uvolnit podregistr:
      HKEY_LOCAL_MACHINE\TEST
    4. Ukončete Editor registru ukončete paralelní verze systému Windows a restartování původní verzi systému Windows. Služby nebo zařízení, které odpovídá klíči upravené jsou nyní zakázána.

Vlastnosti

ID článku: 165748 - Poslední aktualizace: 1. listopadu 2006 - Revize: 3.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Klíčová slova: 
kbmt kb3rdparty kbenv KB165748 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:165748

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com