Article ID: 166542 - Last Review: October 28, 2006 - Revision: 3.3

XADM: Database in Inconsistent State After Soft Recovery

This article was previously published under Q166542
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SYMPTOMS

If your system crashes after the Jet database has completed recovery from a previous crash, but before any subsequent log records are flushed, the database is in an inconsistent state. A -550 error recorded from source EDB may appear in the application log.

CAUSE

The RecoveryQuit transaction from the first recovery operation is in the last log file when another recovery is attempted.

RESOLUTION

Apply the fix described below. Jet's soft recovery was fixed to handle the existence of a RecoveryQuit transaction in the last log file. This allows the second recovery to complete.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0. This problem was corrected in the latest Microsoft Exchange Server 5.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K

APPLIES TO
  • Microsoft Exchange Server 5.0 Standard Edition
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Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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