Article ID: 166586 - Last Review: October 28, 2006 - Revision: 4.1

XCON: Incoming Attachments Lost from Messages Sent over a Wang X.400 Connector

This article was previously published under Q166586
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SYMPTOMS

When you send a message with attachments over a Wang X.400 Connector, attachments are lost. You can open the mail message using any client, but no attachments are present. Wang sends a Winmail.dat file with the attachment. The Winmail.dat file and attachments are seen as bilaterally- defined attributes in the P2 portion of an ASN.1 parsed message. An example is shown below:
   P2_Bilat_defined_prim [...attachment data here...]
   P2_Bilat_defined_prim [...IPM.Microsoft Mail.Note....]
				
The first line includes the attachment information and the second line contains the Winmail.dat attachment. The Winmail.dat attachment holds properties of the attachment such as file name and it's exact position in the message. These properties are described using Transport Neutral Encapsulation Format, or TNEF.

CAUSE

The incoming Winmail.dat file from Wang does not include a display name property, PR_DISPLAY_NAME, as part of the description for the attachment.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 4.0. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 4.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K
Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0 SP1. This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 5.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):
S E R V P A C K

APPLIES TO
  • Microsoft Exchange Server 4.0 Standard Edition
  • Microsoft Exchange Server 5.0 Service Pack 1
Keywords: 
kbqfe kbhotfixserver kb3rdparty kbbug kbfix KB166586
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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