Artigo: 166832 - Última revisão: sexta-feira, 19 de Janeiro de 2007 - Revisão: 1.3

Mensagem de erro: Não é possível localizar um ficheiro de dispositivos que pode ser necessário para executar...

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando reiniciar o computador depois de instalar o adaptador de acesso telefónico, poderá receber as seguintes mensagens de erro:
Não é possível encontrar um ficheiro de dispositivo que pode ser necessário para executar o Windows ou uma aplicação do Windows.

O registo do Windows ou o ficheiro System.INI refere-se a este dispositivo, mas já não existe o ficheiro de dispositivo...

Se pretender continuar a utilizar a aplicação associada com este ficheiro de dispositivo, tente reinstalar essa aplicação para substituir o ficheiro em falta.
Os seguintes ficheiros estão listados como estando em falta:
Vnetsup.vxd
Nwlink.vxd
Nwredir.vxd
Nscl.vxd
Vredir.vxd
NDIS.vxd
Ndis2sup.vxd
Vnetbios.vxd
NDISWAN.vxd
Duas caixas de diálogo adicional poderão aparecer a informar que não não possível encontrar os seguintes dois ficheiros:
Nwnp32.dll
Msnp32.dll
Depois de confirmar estas mensagens de erro, Windows for iniciado normalmente mas sem a funcionalidade acesso telefónico à rede.

Causa

Este problema pode ocorrer se instalar o acesso à rede Dial-up, adaptador de acesso telefónico ou rede privada virtual e, em seguida, cancelar a configuração enquanto é apresentada a caixa de diálogo Copiar ficheiros . Os ficheiros de acesso à rede Dial-up não são copiados para o disco rígido mas os nomes de ficheiro são adicionados ao registo. Quando o computador é reiniciado, os ficheiros são solicitados e não não possível encontrar.

Resolução

Nota : Se configurou previamente acesso à rede Dial-up e ter adicionado itens tais como números de telefone, as definições de TCP/IP e outros protocolos, registe as informações antes de remover o adaptador de acesso telefónico. Fazer o mesmo para informações de propriedades do adaptador de rede se uma placa de rede estiver listada na propriedades de rede. Para resolver este problema, remova e reinstale o acesso à rede Dial-up. Para o fazer, siga estes passos:
  1. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  2. No painel de controlo, faça duplo clique em Adicionar/remover programas .
  3. Clique no separador Programa de configuração do Windows e, em seguida, clique em comunicações .
  4. Clique em Detalhes e, em seguida, clique para desmarcar a caixa de verificação Acesso à rede Dial-up .

    Nota : Se receber a mensagem de erro NDISWAN.vxd, clique para desmarcar apenas a caixa de verificação Rede privada virtual .
  5. Clique em Fechar , clique em OK e clique em Aplicar .
  6. Quando lhe for pedido para reiniciar o Windows, fazê-lo.
  7. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  8. No painel de controlo, faça duplo clique em Adicionar/remover programas .
  9. Clique no separador Programa de configuração do Windows e, em seguida, clique em comunicações .
  10. Clique em Detalhes e, em seguida, clique para seleccionar a caixa de verificação Acesso à rede Dial-up .

    Nota : Se tiver desmarcado a caixa de verificação Rede privada virtual no passo 4, clique para seleccioná-la.
  11. Clique em Fechar e, em seguida, clique em OK .
  12. Se lhe for pedido para reiniciar o Windows, fazê-lo.
Se forem necessários quaisquer protocolos adicionais, adicione os protocolos, utilizando a ferramenta rede no painel de controlo.

Nota : verificar com o administrador do sistema ou fornecedor de serviços para determinar as definições necessárias para acesso à rede Dial-up e TCP/IP.

Para obter informações adicionais sobre como configurar o acesso à rede Dial-up para workwith um fornecedor de serviços Internet, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
133219  (http://support.microsoft.com/kb/133219/EN-US/ ) A ligação à Internet utilizando um fornecedor de serviços

Mais Informação

Se cancelar a instalação do adaptador de acesso telefónico enquanto é apresentada a caixa de diálogo Copiar ficheiros , a instalação prossegue e devolve a seguinte mensagem:
Agora tem de reiniciar o computador as novas definições entrem em vigor. Deseja reiniciar o computador agora?
Uma vez que os ficheiros não foram copiados para o disco rígido, receberá mensagens de erro listadas no início deste artigo. Concluir a instalação dos ficheiros conforme descrito acima resolve o problema.

Para obter informações adicionais sobre problemas de arranque semelhante, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
140010  (http://support.microsoft.com/kb/140010/EN-US/ ) Microsoft Plus! programa de configuração instala inadvertidamente cliente para NetWare
137454  (http://support.microsoft.com/kb/137454/EN-US/ ) Mensagem de erro: Não é possível localizar um dispositivo VNETSUP.vxd do ficheiro...
132008  (http://support.microsoft.com/kb/132008/EN-US/ ) Mensagem de erro: Não é possível localizar um ficheiro de dispositivos que pode ser necessário...

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 95
Palavras-chave: 
kbmt kbdialup kbenv kberrmsg kbfaq kbprb KB166832 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 166832  (http://support.microsoft.com/kb/166832/en-us/ )