ACC: Cómo importar una tabla de Word que contiene retornos de carro

Seleccione idioma Seleccione idioma
Id. de artículo: 167103 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Moderada: Requiere macro básico, codificación y las capacidades de interoperabilidad.

Expandir todo | Contraer todo

En esta página

Resumen

Al importar una tabla de Microsoft Word que contenga retornos de carro en sus celdas, la tabla no se importa correctamente porque Microsoft Access interpreta cada retorno de carro o avance de línea como un nuevo delimitador de registro. Para evitar este problema, se puede escribir el contenido de las celdas de la tabla entre comillas, de forma que se interpreten los retornos de carro como parte del texto de la celda y no como el final de un registro.

Este artículo muestra cómo exportar una tabla de Word que contenga retornos de carro a un archivo de texto delimitado por tabulaciones que se puede importar a Microsoft Access.

Más información

En este ejemplo, la tabla y su contenido se convierten a un formato delimitado por tabulaciones; a continuación, se guarda el archivo como texto y se importa a una base de datos de Microsoft Access. Las técnicas en este ejemplo se supone que sabe cómo crear una tabla en Microsoft Word y que la tabla es el objeto sólo en el documento.

Crear la tabla de Microsoft Word


  1. Inicie Microsoft Word y cree un documento nuevo en blanco.
  2. Inserte una tabla con tres columnas y cuatro filas.
  3. Introduzca los siguientes datos en la tabla, incluido el encabezado de la columna. Presione la tecla ENTRAR al final de la primera línea de cada dirección para que la ciudad, estado y código postal aparezcan en una línea independiente:
          +-------------+--------------+---------------------+
          |FirstName    |LastName      |Address              |
          +-------------+--------------+---------------------+
          |Bob          |White         |12 Rocky Rd.         |
          |             |              |Anywhere, TX  43210  |
          +-------------+--------------+---------------------+
          |Sal          |Vation        |1000 Pearly St.      |
          |             |              |Noble, NM  33333     |
          +-------------+--------------+---------------------+
          |Art          |Work          |120/98 Scenic Way    |
          |             |              |Goodview, WI  12332  |
          +-------------+--------------+---------------------+
    						
  4. Guarde el documento como Direcciones.doc y deje el documento abierto.

Dar formato al texto como texto delimitado por tabulaciones


  1. Reemplace temporalmente todas las marcas de párrafo (retornos de carro) del documento por un carácter que no haya utilizado aún en la tabla, como la tilde (~). Para ello, siga estos pasos:

    1. En el menú Edición, haga clic en reemplazar.
    2. En el cuadro de diálogo Buscar Y reemplazar, escriba los caracteres siguientes y, a continuación, haga clic en Reemplazar todo:
                Find what: ^p  (the symbol for a carriage return)
                Replace with: ~
    3. Haga clic en Aceptar cuando reciba un mensaje indica que se ha completado la búsqueda y reemplazo.
    4. Cerrar el cuadro de diálogo Buscar Y reemplazar.
  2. Convertir la tabla al formato de texto delimitado por tabuladores. Para ello, siga estos pasos:

    1. Haga clic en cualquier celda de la tabla.
    2. En el menú Tabla, haga clic en Seleccionar tabla.
    3. En el menú tabla, haga clic en "Convertir tabla a texto".
    4. En el cuadro de diálogo "Convertir tabla a texto", haga clic en tabulaciones y, a continuación, haga clic en Aceptar.
  3. Escriba un signo de comillas al principio del documento, a la izquierda de la palabra nombre. Se trata del primer calificador de texto en el que estará encerrado cada campo de la tabla.

    Nota: Si el texto de la tabla contiene las comillas, debe quitar o sustituirlos por otro carácter, como el apóstrofo, antes de continuar; de lo contrario, la tabla no se importará correctamente.
  4. Reemplace todas las marcas de párrafo del documento por una marca de párrafo entre comillas. Para ello, siga estos pasos:

    1. En el menú Edición, haga clic en reemplazar.
    2. En el cuadro de diálogo Buscar Y reemplazar, escriba los caracteres siguientes y, a continuación, haga clic en Reemplazar todo:
                Find what: ^p
                Replace with: "^p"
    3. Haga clic en Aceptar cuando reciba un mensaje indica que se ha completado la búsqueda y reemplazo.
    4. Cerrar el cuadro de diálogo Buscar Y reemplazar.
  5. Reemplace todos los caracteres de tabulación del documento por un carácter de tabulación entre comillas. Para ello, siga estos pasos:

    1. En el menú Edición, haga clic en reemplazar.
    2. En el cuadro de diálogo Buscar Y reemplazar, escriba los caracteres siguientes y, a continuación, haga clic en Reemplazar todo:
                Find what: ^t
                Replace with: "^t"
    3. Haga clic en Aceptar cuando reciba un mensaje indica que se ha completado la búsqueda y reemplazo.
    4. Cerrar el cuadro de diálogo Buscar Y reemplazar.
  6. Reemplazar todo tildes (~) con las marcas de párrafo para restaurar las marcas de párrafo original en el documento. Para ello, siga estos pasos:

    1. En el menú Edición, haga clic en reemplazar.
    2. En el cuadro de diálogo Buscar Y reemplazar, escriba los caracteres siguientes y, a continuación, haga clic en Reemplazar todo:
                Find what: ~
                Replace with: ^p
    3. Haga clic en Aceptar cuando reciba un mensaje indica que se ha completado la búsqueda y reemplazo.
    4. Cerrar el cuadro de diálogo Buscar Y reemplazar.
  7. En el menú Archivo, haga clic en Guardar como.
  8. En el cuadro de diálogo Guardar como, seleccione texto (*.txt) sólo en el guardar como tipo de cuadro y escriba direcciones.txt en el cuadro Nombre de archivo. Haga clic en Guardar.
  9. Cierre el documento y salir de Microsoft Word.

Importar la tabla a Microsoft Access


  1. Inicie Microsoft Access y abra la base de datos de ejemplo Neptuno.mdb (o nwind.mdb en la versión 2.0).
  2. En Microsoft Access 7.0 ó 97, en el menú Archivo, seleccione obtener datos externos y, a continuación, haga clic en Importar.

    En Microsoft Access 2.0, en el menú Archivo, haga clic en Importar.
  3. En Microsoft Access 7.0 ó 97, en el cuadro de diálogo Importar, seleccione archivos de texto en el cuadro Tipo de archivo y, a continuación, seleccione direcciones.txt en la carpeta apropiada. Haga clic en Importar.

    En Access 2.0, en el cuadro de diálogo Importar, seleccione el texto (delimitado por) y, a continuación, haga clic en Aceptar. En el cuadro de diálogo Seleccionar archivo, seleccione direcciones.txt en la carpeta apropiada y, a continuación, haga clic en Importar.
  4. En Microsoft Access 7.0 o 97, haga clic en siguiente en la primera pantalla del Asistente para importar texto (o el Asistente para importación de texto en Microsoft Access 7.0). Haga clic para activar la casilla "Primera fila contiene nombres de campo" en la segunda pantalla del Asistente para y, a continuación, haga clic en Finalizar para importar la tabla.

    En Access 2.0, en el cuadro de diálogo Opciones para importar texto, haga clic en casilla de verificación "Primera fila contiene nombres de campo" y, a continuación, haga clic en el botón Opciones. Seleccione {ficha} en el cuadro Separador de campo, seleccione "en el delimitador de texto y, a continuación, haga clic en Aceptar para importar la tabla.
  5. Abra la tabla Direcciones en la vista Hoja de datos.
  6. En el menú Formato, haga clic en alto de fila. Establecer el alto de fila en 25 y, a continuación, haga clic en Aceptar.
  7. Haga clic en cualquier lugar en la columna dirección y, a continuación, en el menú Formato, haga clic en ancho de columna. Establezca el ancho de columna en 50 y, a continuación, haga clic en Aceptar.

    Observe que puede ver ambas líneas de cada dirección y que cada una incluye el retorno de carro.

Referencias

Para información adicional acerca de cómo importar archivos que contienen retornos de carro, vea los artículos siguientes en Microsoft Knowledge Base:

153373ACC: Importar texto de ancho fijo con Embedded carro devoluciones

149946ACC: Asistente para importar texto no importar datos correctamente

Para obtener más información acerca de importar las tablas de Microsoft Word a Microsoft Access, consulte en contacto con el siguiente artículo en Microsoft Knowledge Base:

141700Tablas de ACC95: Cómo importar de Microsoft Word utilizando OLE automatización

Propiedades

Id. de artículo: 167103 - Última revisión: miércoles, 05 de febrero de 2014 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbhowto kbinterop KB167103 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 167103

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com