ACC: Consulta de ejemplo para imprimir una etiqueta para dos personas en una lista

Seleccione idioma Seleccione idioma
Id. de artículo: 169153 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Moderada: Requiere macro básico, codificación y las capacidades de interoperabilidad.

Expandir todo | Contraer todo

Resumen

Cuando tiene una lista de nombres para el que desea generar etiquetas postales, con frecuencia hay dos personas enumeradas en la misma dirección. En este artículo se demuestra una técnica para crear una consulta desde el que desea imprimir una sola etiqueta postal para dos personas en la misma dirección.

Nota: Si más de dos personas en la lista de correo directo en la misma dirección, sólo los nombres del registro y el apellido con esa dirección en la tabla aparecerá en la consulta.

Más información

Cuando haya una lista de direcciones con dos personas en la misma dirección, a menudo es preferible para imprimir una sola etiqueta postal para la dirección que enumera los nombres de dos personas. Para ello, deberá crear una consulta que contiene el nombre primero para imprimir en la etiqueta y, a continuación, cree una consulta que contiene el segundo nombre de la etiqueta. A continuación, puede colocar estas dos consultas juntos para mostrar la que consulta de ambos nombres para cada dirección en una tercera.

Para que este método funcione, es importante que todos la información de dirección para cada persona en la misma dirección idénticos. Por ejemplo,
   123 First Street N
				

es diferente de
   123 First St. North
				

En el siguiente ejemplo utiliza las funciones de agregado First() y Last() para crear listas de nombres de etiqueta principal y nombres de etiqueta secundaria, respectivamente.

Advertencia: Seguir los pasos descritos en este ejemplo modificará la base de datos de ejemplo Neptuno.mdb (o Neptuno.mdb en la versión 2.0 o anterior). Quizás desee una copia del archivo Neptuno.mdb (o Neptuno.mdb) y realizar estos pasos en una copia de la base de datos.
  1. Inicie Microsoft Access y abra la base de datos de ejemplo Neptuno.mdb (o Neptuno.mdb en la versión 2.0).
  2. Abra la tabla empleados en la vista Hoja de datos y agregue los tres registros siguientes para crear direcciones duplicadas. Tenga en cuenta que algunos campos de cada registro quedará en blanco. Escriba con cuidado la información exactamente como aparece a continuación:
                     Record #1            Record #2         Record #3
        -----------------------------------------------------------------------
        Last Name:   Fuller               Wilkinson         Smith
        First Name:  Mary                 Avery             John
        Birth Date:  7/2/54               4/30/77           10/20/58
        Address:     908 W. Capital Way   14 Garrett Hill   4110 Old Redmond
                                                            Rd.
        City:        Tacoma               London            Minneapolis
        Region:      WA                                     MN
        Postal Code: 98401                SW1 8JR           55435
        Country:     USA                  UK                USA
    						
  3. Cree una nueva consulta en la vista Diseño basada en la tabla empleados. Esta consulta mostrará el primer conjunto de nombres de las etiquetas postales.
  4. En el menú Ver, haga clic en totales. A continuación, completar el diseño de la consulta como sigue y guárdela como qryLabelNames1.

    Nota: En Microsoft Access 2.0 los campos [Apellidos], [nombre] y [CódigoPostal] contiene un espacio en sus nombres.
          Query: qryLabelNames1
          ------------------------------------------------------
          Type: Totals Query
    
          Field: ListName: First([FirstName] & " " & [LastName])
             Table: Employees
             Total: Expression
             Sort: Ascending
          Field: Address
             Table: Employees
             Total: Group By
             Sort: None
          Field: City
             Table: Employees
             Total: Group By
             Sort: None
          Field: Region
             Table: Employees
             Total: Group By
             Sort: None
          Field: PostalCode
             Table: Employees
             Total: Group By
             Sort: None
          Field: Country
             Table: Employees
             Total: Group By
             Sort: None
    						
  5. Seleccione la consulta qryLabelNames1 en la ventana base de datos y, después en el menú Edición, haga clic en copiar.
  6. En el menú Edición, haga clic en Pegar. En el cuadro de diálogo Pegar como, escriba qryLabelNames2 en el cuadro Nombre y, a continuación, haga clic en Aceptar.
  7. Abrir el qryLabelNames2 consulta en la vista Diseño y sólo modificar el campo nombre de lista, por lo que se utiliza la función Last() en su lugar el First() funcionar:
          Field: ListName: Last([FirstName] & " " & [LastName])
             Table: Employees
             Total: Expression
             Sort: Ascending
    						
  8. Guarde la consulta y ciérrela. Esta consulta mostrará el segundo conjunto de nombres para sus etiquetas postales.
  9. Cree una nueva consulta en vista de diseño en función de las consultas qryLabelNames1 y qryLabelNames2. Esta consulta será la base para el informe de etiqueta postal.

    Nota: La expresión en el campo denominado nombre2 contiene un carácter de subrayado (_) al final de la línea como un carácter de continuación de línea. Quite el subrayado y escriba toda la expresión como una sola línea cuando vuelva a crear este ejemplo.
          Query: qryMailingList
          ---------------------------------------------------------
          Type: Select Query
          Join: qryLabelNames1.Address <-> qryLabelNames2.Address
          Join: qryLabelNames1.PostalCode <-> qryLabelNames2.PostalCode
    
          Field: Name1: ListName
             Table: qryLabelNames1
             Sort: None
          Field: Name2: IIf([qryLabelNames1].[ListName]= _
                 [qryLabelNames2].[ListName],"",[qryLabelNames2].[ListName])
             Sort: None
          Field: Address
             Table: qryLabelNames1
             Sort: None
          Field: City
             Table: qryLabelNames1
             Sort: None
          Field: Region
             Table: qryLabelNames1
             Sort: None
          Field: PostalCode
             Table: qryLabelNames1
             Sort: None
          Field: Country
             Table: qryLabelNames1
             Sort: None
    						
Cuando ejecute esta consulta, tenga en cuenta lo siguiente:
  • Cada registro muestra un nombre de la columna nombre1, pero donde dos o más personas vive en la misma dirección, un nombre también aparece en el nombre2 columna.
  • Aunque existan dos registros con un campo de dirección de "4110 anterior Redmond Rd.", imprimirá en las etiquetas independientes porque sus códigos postales son diferentes. Esto sucede porque se unió a la dirección y los campos de código postal de la consulta qryMailingList.
Ahora puede utilizar el Asistente para etiquetas (o el Asistente para etiquetas de correo en la versión 2.0) para crear etiquetas basándose en la consulta qryMailingList.

Referencias

Para obtener más información acerca de utilizar al Asistente para etiquetas, busque el índice para "etiquetas postales" de la Ayuda o pregunte al Ayudante de Office.

Propiedades

Id. de artículo: 169153 - Última revisión: lunes, 10 de febrero de 2014 - Versión: 3.1
La información de este artículo se refiere a:
  • Microsoft Access 2.0 Standard Edition
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbhowto kbprint KB169153 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 169153

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com