Dr. Watson Dialog Box Stops Responding

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Article ID: 170057 - View products that this article applies to.
This article was previously published under Q170057
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SYMPTOMS

When an application fails, the Dr. Watson dialog box is displayed and waits, indicating that it is building a log file, but the OK and Cancel buttons remain unavailable. Also, the log file, %systemroot%\Drwtsn32.log, is never written to.

CAUSE

On RISC platforms, the exception record contains the address of the instruction that actually caused the exception. For OS/2 historical reasons, however, x86 exception records contain the address of the instruction that immediately follows the instruction that caused the exception. As a result, when Drwtsn32.exe attached to the failed process on a RISC platform, it retrieved the wrong address and the debugger process stopped responding.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 170057 - Last Review: October 7, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kbbug kbfix KB170057

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