PRB : Programmes antivirus peuvent provoquer le problème de connexion de canaux nommés

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Numéro d'article: 170338 - Voir les produits auxquels s'applique cet article
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Important Cet article contient des informations expliquant comment inférieur des paramètres de sécurité ou la désactivation de fonctions de sécurité sur un ordinateur. Vous pouvez apporter ces modifications pour contourner un problème spécifique. Avant d'effectuer ces modifications, nous vous recommandons d'évaluer les risques associés à l'implémentation de cette solution de contournement dans votre environnement particulier. Si vous implémentez cette solution de contournement, veillez à prendre toutes les mesures nécessaires pour protéger votre système.
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Symptômes

Logiciel antiviru exécuté sur les ordinateurs clients peut provoquer l'arrêt de connexions de canaux nommés à Microsoft SQL Server échoue. L'application cliente peut cesser de répondre, prendre un certain temps ou parfois erreur 231, "Occupé (E) connexion". Dans le journal des erreurs SQL Server, erreur 17832 "Impossible de lire les paquets de connexion d'accès» peut être enregistré. Les connexions à SQL Server à l'aide d'un autre protocole réseau fonctionnent normalement.

Cause

Lorsque l'application cliente demande à ouvrir un canal, et si le logiciel antiviru est configuré pour analyser tous les fichiers, le logiciel anti-virus traite le canal de communication comme un fichier et tente d'analyser. Il en résulte ouverture que le canal est un mode «refuser tout» qui empêche le logiciel client de lire ou d'écrire sur le canal alors que connecté le serveur. Une fois que le canal est ouvert dans ce mode, le client est incapable d'envoyer le paquet de connexion au serveur. Il en résulte déclencher erreur 17832 "Impossible de lire les paquets de connexion» dans le journal des erreurs SQL Server.

Autres connexions de canaux nommés à partir du même client échouent car le canal est déjà ouvert dans un mode «refuser tout» qui empêche l'utilisation du même canal de communication par ces connexions. Ce scénario se traduit par réception erreur 231 "Tuyau occupé" ou "Occupé (E) connexion".

Contournement

Avertissement Cette solution de contournement peut rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malintentionnés ou de logiciels nuisibles tels que les virus. Nous déconseillons cette solution de contournement mais que vous fournissons cette information afin que vous pouvez implémenter cette solution de contournement à votre convenance. Utilisez cette solution de contournement à vos risques et périls.

Important Ces étapes peuvent augmenter les risques de sécurité. Rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malintentionnés ou de logiciels nuisibles tels que les virus. Nous recommandons le processus décrit dans cet article pour activer les programmes de fonctionner comme ils sont conçus pour ou pour implémenter les fonctionnalités du programme spécifique. Avant d'effectuer ces modifications, nous vous recommandons d'évaluer les risques associés à l'implémentation de ce processus dans votre environnement particulier. Si vous choisissez d'implémenter ce processus, prenez toutes les mesures nécessaires pour protéger votre système. Nous vous recommandons d'utiliser cette procédure que si vous avez vraiment besoin de ce processus.

Pour contourner ce problème, essayez l'une des opérations suivantes :
  • Configurez le logiciel antiviru pour analyser uniquement les fichiers de programme.
  • Supprimer le logiciel antiviru et évaluer la connexion de canaux nommés pour SQL Server.
  • Contactez le fournisseur antiviru pour des suggestions sur la configuration du logiciel.

Propriétés

Numéro d'article: 170338 - Dernière mise à jour: mercredi 5 février 2014 - Version: 4.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft SQL Server 6.0 Standard
  • Microsoft SQL Server 6.5 Édition Standard
Mots-clés : 
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Traduction automatique
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La version anglaise de cet article est la suivante: 170338
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