OL97:使用收件箱修复工具恢复邮件存储区

文章翻译 文章翻译
文章编号: 171371 - 查看本文应用于的产品
本文已归档。它按“原样”提供,并且不再更新。
展开全部 | 关闭全部

本文内容

概要

本文提供有关使用收件箱修复工具 (Scanpst.exe) 从损坏的个人文件夹 (.pst) 文件中恢复文件夹和项目的技巧。

更多信息

收件箱修复工具用于帮助修复与 .pst 文件和脱机文件夹 (.ost) 文件有关的问题。Microsoft Windows 95 附带了收件箱修复工具,Microsoft Outlook 97 CD-ROM 和 Microsoft Office 97 CD-ROM 上也都有这种工具。

有关安装和运行收件箱修复工具的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
168648 OL97:如何查找和运行收件箱修复工具
注意: 以下过程中的示例使用收件箱修复工具来处理 .pst 文件。这些过程还适用于 .ost 文件。要查找 .ost 文件,请单击选择要扫描的文件中的脱机文件夹 (*.ost)

收件箱修复工具的功能

在运行收件箱修复工具处理 .pst 文件时:
  • 收件箱修复工具分析 .pst 文件文件夹结构和项目标题,然后尝试恢复所有的文件夹和项目。
  • 如果收件箱修复工具能够恢复 .pst 文件,它就能够找到问题并修复它能修复的一切问题。
  • 收件箱修复工具尝试将所有文件转成 .pst 文件。(例如,如果将可执行文件重命名为“Something.pst”,收件箱修复工具就将该文件转成了可安装的 .pst 文件。)

如何处理恢复的 .pst 文件

在运行收件箱修复工具后:
  1. 启动 Outlook。使用包含您尝试修复的 .pst 文件的配置文件。
  2. 视图菜单上,单击文件夹列表以打开“文件夹列表”视图。在文件夹列表中,应该显示已恢复的下列文件夹:

    • 恢复的个人文件夹
    • 日历
    • 联系人
    • 已删除的邮件
    • 收件箱
    • 日记
    • 便笺
    • 发件箱
    • 已发送的邮件
    • 任务

    这些文件夹通常是空的,因为它们是重新创建的 .pst 文件的一部分。还应该显示一个 Lost and Found(失而复得)文件夹。该文件夹包含收件箱修复工具恢复的文件夹和项目。缺少的任何项目就是无法恢复的项目。

恢复已修复的项目

将 Lost and Found 文件夹中的全部项目移至配置文件中的新 .pst 文件中:
  1. 在配置文件中创建一个新的 .pst 文件:
    1. 启动 Outlook。使用包含您恢复的个人文件夹的配置文件。
    2. 工具 菜单上,单击服务
    3. 服务 选项卡上,单击添加 打开在配置文件中添加服务对话框。
    4. 可用的信息服务列表中,单击个人文件夹,然后单击确定
    5. 创建/打开个人文件夹文件对话框中,选择一个文件夹并为这个新的 .pst 文件键入一个文件名(默认名称为“个人文件夹”),然后单击打开
    6. 单击确定 关闭所有的对话框。
  2. 将恢复的项目从 Lost and Found 文件夹拖到新 .pst 文件中的相应位置。
  3. 在移动完所有的项目后,可以从配置文件(包含 Lost and Found 文件夹)中删除恢复的个人文件夹。

从备份个人文件夹文件中恢复项目

注意:如果在运行收件箱修复工具之前无法打开原始的 .pst 文件,则以下过程可能无效。如果在运行收件箱修复工具之前可以打开原始的 .pst 文件,则有可能使用以下过程能够从受到破坏的 .pst 文件恢复其他项目,但是这种可能性很小。

在运行收件箱修复工具时,默认情况下将启用创建原始 .pst 文件备份的选项。此选项在硬盘上创建一个文件名.bak 文件,它是原始文件名.pst 文件的备份副本,但带有不同的扩展名。此 .bak 文件与原始 .pst 文件位于相同的文件夹中。

尝试从 .bak 文件恢复收件箱修复工具无法恢复的项目:
  1. 创建 .bak 文件的一个副本,给该文件指定一个新名称,并使用扩展名 .pst。对于此示例,将文件命名为“Newname.pst”。
  2. 启动 Outlook。使用包含本文“恢复已修复的项目”一节中创建的 .pst 文件的配置文件。
  3. 通过使用 Outlook 导入和导出向导尝试导入备份 .pst 文件(在此示例中为 Newname.pst 文件):
    1. 文件 菜单上,单击导入和导出。 在该向导中,单击从个人文件夹文件导入 (*.pst),然后单击下一步
    2. 导入文件中,单击备份 .pst 文件(在本示例中,单击Newname.pst)。在选项中,单击不导入重复项目,然后单击下一步
    3. 从下面位置选择要导入的文件夹中,单击备份 .pst 文件的名称,然后单击包含子文件夹。单击导入文件夹到相同文件夹,然后单击在本文“恢复已修复的项目”一节中创建的新 .pst 文件。
    4. 单击完成
切记,备份文件是原来损坏的 .pst 文件,而您可能无法恢复比收件箱修复工具在 Lost and Found 文件夹中恢复的项目更多的项目。如果无法将备份 .pst 文件(在此示例中为 Newname.pst 文件)导入到 Outlook,则 Lost and Found 文件夹中不存在的任何信息都会丢失。

属性

文章编号: 171371 - 最后修改: 2013年10月7日 - 修订: 1.0
这篇文章中的信息适用于:
  • Microsoft Outlook 97 标准版
关键字:?
kbnosurvey kbarchive kbfaq kbinfo KB171371
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com