Ripristinare le associazioni di file .lnk

Identificativo articolo: 172053 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

Sintomi

Quando si seleziona programmi dal menu di avvio o i tasti di scelta rapida che non accade nulla viene visualizzata la finestra di dialogo "Apri con" o l'esecuzione di un programma specifico.

Cause

L'associazione con estensione lnk è mancante, errata o danneggiata. Poiché tutti i collegamenti e voci di Menu del programma sono file con estensione lnk. Selezionando uno o Visualizza finestra di dialogo "Apri con", un oggetto specifico applicazione, ad esempio Notepad.exe o Wordpad.exe o non esegue alcuna operazione.

Risoluzione

È possibile risolvere il problema ripristinando la chiave del Registro di sistema da un altro computer funzionante o sostituire manualmente la chiave del Registro di sistema.

Avviso: utilizzo non corretto dell'Editor del Registro di sistema può causare gravi, a livello di sistema problemi che potrebbero richiedere la reinstallazione di Windows NT per correggerli. Microsoft non garantisce che qualsiasi problema derivante dall'utilizzo di Editor del Registro di sistema possano essere risolti. Utilizzare questo strumento a proprio rischio.

Per ripristinare la chiave del Registro di sistema da un altro computer, attenersi alla seguente procedura Procedura:
  1. Avviare l'editor del Registro di sistema (Regedt32.exe) e selezionare la seguente sottochiave:
       HKEY_CLASSES_ROOT\.lnk
    						
  2. Dal menu Modifica, fare clic su Elimina.
  3. In un altro computer Windows NT 4.0, avviare l'Editor del Registro di sistema (Regedt32.exe) e selezionare la chiave del Registro di sistema HKEY_CLASSES_ROOT\.lnk.
  4. Scegliere Salva chiave dal menu Registro di sistema.
  5. Copiare il file nel computer di stato riscontrato il problema o in un disco floppy disco.
  6. Nel computer in cui è stato riscontrato il problema, ricreare la chiave del Registro di sistema da selezionando HKEY_CLASSES_ROOT e quindi scegliere Aggiungi chiave dal menu Modifica. Digitare .lnk per il nome della chiave.
  7. Selezionare la nuova chiave, fare clic su Ripristina dal menu Registro di sistema e selezionare il file da altri computer o disco floppy.
  8. Chiudere l'Editor del Registro di sistema e riavviare il computer. Una voce di menu del programma di test o di scelta rapida.
Per immettere manualmente le informazioni, effettuare le seguenti operazioni:
  1. Avviare l'Editor del Registro di sistema (Regedt32.exe), selezionare la chiave HKEY_CLASSES_ROOT sottochiave e quindi fare clic su Aggiungi chiave dal menu Modifica.
  2. Nella casella digitare nome di chiave ". lnk" (senza virgolette), quindi Fare clic su OK. Si noti che è opportuno lasciare la casella di classe vuota.
  3. Nella finestra di dialogo Aggiungi valore fare clic su OK per lasciare il nome valore vuoto, e scegliere nell'elenco tipo di dati REG_SZ.
  4. Nella finestra di dialogo Editor di stringa digitare "lnkfile" (senza virgolette), e Fare clic su OK.
  5. Selezionare la chiave lnk che appena ricreato in HKEY_CLASSES_ROOT sottochiave. Dal menu Modifica, fare clic su Aggiungi chiave e quindi digitare "ShellNew" (senza virgolette). Si noti che è opportuno lasciare la casella di classe vuoto.
  6. Scegliere Aggiungi valore dal menu Modifica, digitare "command" (senza virgolette segni) nella casella Nome dati selezionare REG_SZ nella casella Nome dati, e digitare "RunDLL32 AppWiz.Cpl,NewLinkHere % 1" (senza virgolette Contrassegna) come valore stringa.
  7. Chiudere l'Editor del Registro di sistema e riavviare il computer.

Proprietà

Identificativo articolo: 172053 - Ultima modifica: domenica 28 aprile 2013 - Revisione: 3.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Chiavi: 
kbfile kbhowto kbmt KB172053 KbMtit
Traduzione automatica articoli
IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l?obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 172053
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti