Artigo: 172223 - Última revisão: sexta-feira, 23 de Fevereiro de 2007 - Revisão: 2.2

Não é possível executar atalhos do menu ' Iniciar ' ou do ambiente de trabalho

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando faça duplo clique sobre um atalho ou seleccionar um item do menu ' Iniciar ', não acontece nada. Quando tentar executar qualquer programa ou atalho a partir do painel de controlo, poderão ser apresentadas as seguintes mensagens de erro:
O acesso ao dispositivo especificado, o caminho ou o ficheiro é negado.
- ou -
Este ficheiro não tem um programa associado para efectuar esta acção. Crie uma associação no meu computador clicando em ver e, em seguida, clicando em Opções.
Além disso, quando clica em Opções no menu Ver no meu computador, clique no separador tipos de ficheiro e, em seguida, seleccione a aplicação, o "Abrir com:" o campo ' fica em branco (em vez de apresentar (executável)).

Causa

As abrir e/ou Open\Command chaves na subchave do registo HKEY_CLASSES_ROOT\Exefile\Shell foram danificados, modificado, ou estão em falta.

Resolução

Pode utilizar o disco de reparação de emergência para restaurar a secção de software.

Como contornar

Para e/manualmente verificar ou restaurar abrir a chave é necessário editar o registo. Para editar o registo, execute os seguintes passos:

aviso : a utilização incorrecta do Editor de registo pode provocar graves do sistema, problemas que poderão forçar a reinstalação do Windows NT. Microsoft não garante que os problemas resultantes da utilização do Editor de registo podem ser resolvidos. Utilize esta ferramenta por sua conta e risco.
  1. Execute o Editor de registo, (Regedt32.exe) e verifique se que existem as seguintes entradas de registo.
       HKEY_CLASSES_ROOT\Exefile\Shell\Open
    
          Default Value = EditFlags:REG_BINARY:00 00 00 00
    
       HKEY_CLASSES_ROOT\Exefile\Shell\Open\Command
    
          Default Value = <No Name>:REG_SZ:"%1"%*
    						

    Se estas chaves não existirem, modifique o registo como descrito nos passos abaixo. Se as chaves existem, verifique se as informações contidas no-los estão correctas.
  2. Seleccione a seguinte chave:
          HKEY_CLASSES_ROOT\Exefile\Shell
    						
  3. No menu Editar, clique em Adicionar chave.
  4. Na caixa Nome da chave, escreva abrir e, em seguida, clique em OK.
  5. Seleccione a nova chave de abrir.
  6. No menu Editar, clique em Adicionar valor.
  7. Na caixa Nome do valor, escreva EditFlags. Seleccione REG_BINARY para dados tipo. Clique em OK.
  8. Na caixa cadeia, escreva 00000000. Seleccione hexadecimal, como o formato de dados e, em seguida, clique em OK.
  9. No menu Editar, clique em Adicionar chave.
  10. Na caixa Nome da chave, escreva o comando e, em seguida, clique em OK.
  11. Seleccione a nova chave de comandos.
  12. No menu Editar, clique em Adicionar valor.
  13. Deixe a caixa Nome do valor em branco. Seleccione REG_SZ para o tipo de dados e, em seguida, clique em OK.
  14. Na caixa cadeia, escreva "% 1" % *, entre aspas e, em seguida, clique em OK.
  15. Saia do Editor de registo.
Todas as aplicações atalho e programa funcionalidades devem agora ser restaurada estado predefinido.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbmt kbenv KB172223 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 172223  (http://support.microsoft.com/kb/172223/en-us/ )