ID do artigo: 172223 - Última revisão: sexta-feira, 23 de fevereiro de 2007 - Revisão: 2.2

Não é possível executar atalhos do Menu Iniciar ou na área de trabalho

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Quando você clicar duas vezes em um atalho ou selecione um item do menu Iniciar, nada acontece. Quando você tenta executar qualquer programa ou atalho do painel de controle, as seguintes mensagens de erro podem aparecer:
O acesso ao dispositivo especificado, caminho ou arquivo foi negado.
- ou -
Este arquivo não tem um programa associado a ele para executar esta ação. Crie uma associação em Meu computador clicando em Exibir e, em seguida, clicando em Opções.
Além disso, quando você clica em Opções no menu Exibir, em Meu computador, clique a guia tipos de arquivo e, em seguida, selecione o aplicativo, o "Abrir com:" campo estiver em branco (em vez de exibir (executável)).

Causa

A chave de abrir e/ou Open\Command na subchave HKEY_CLASSES_ROOT\Exefile\Shell do registro tenha sido corrompido, modificadas, ou está faltando.

Resolução

Você pode usar o disco de reparação de emergência para restaurar a seção de software.

Como Contornar

Para manualmente Verifique e/ou restaurar o abrir chave você precisará editar o registro. Para editar o registro, execute as seguintes etapas:

Aviso : usar o Editor do Registro incorretamente pode causar problemas sérios no sistema que podem exigir que você reinstale o Windows NT para corrigi-los. Microsoft não garante que problemas resultantes do uso do Editor do Registro possam ser solucionados. Use esta ferramenta de sua responsabilidade.
  1. Execute o Editor do Registro, (Regedt32.exe) e verifique se que existem as seguintes entradas do Registro.
       HKEY_CLASSES_ROOT\Exefile\Shell\Open
    
          Default Value = EditFlags:REG_BINARY:00 00 00 00
    
       HKEY_CLASSES_ROOT\Exefile\Shell\Open\Command
    
          Default Value = <No Name>:REG_SZ:"%1"%*
    						

    Se essas chaves não existirem, modificar o registro conforme descrito nas etapas abaixo. Se as chaves existem, verifique se que as informações contidas no-los estão corretas.
  2. Selecione a seguinte chave:
          HKEY_CLASSES_ROOT\Exefile\Shell
    						
  3. No menu Editar, clique em Adicionar chave.
  4. Na caixa Nome da chave, digite abrir e, em seguida, clique em OK.
  5. Selecione a nova chave de abrir.
  6. No menu Editar, clique em Adicionar valor.
  7. Na caixa Nome do valor, digite EditFlags. Selecione REG_BINARY para dados de tipo. Clique em OK.
  8. Na caixa String, digite 00000000. Escolha hexadecimal como o formato de dados e, em seguida, clique em OK.
  9. No menu Editar, clique em Adicionar chave.
  10. Na caixa Nome da chave, digite o comando e, em seguida, clique em OK.
  11. Selecione a nova chave de comando.
  12. No menu Editar, clique em Adicionar valor.
  13. Deixe a caixa Nome do valor em branco. Selecione REG_SZ para tipo de dados e, em seguida, clique em OK.
  14. Na caixa seqüência, digite "% 1" % 1, entre aspas e em seguida, clique em OK.
  15. Feche o Editor do Registro.
Toda funcionalidade de atalho e programa aplicativo agora deve ser restaurada para seu estado padrão.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbmt kbenv KB172223 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 172223  (http://support.microsoft.com/kb/172223/en-us/ )