Extraction Failed / Service Pack Setup Error When Loading SP3

Article translations Article translations
Article ID: 172235 - View products that this article applies to.
This article was previously published under Q172235
Expand all | Collapse all

On This Page

SYMPTOMS

When you load Service Pack 3 you may receive one of the following two pop- up error messages:
Extraction Error:

There is not enough space on the disk.
-or-
Service Pack Setup Error:

Not enough available hard drive space to run Service Pack Setup. (30 MB required, or 60 MB if also creating an uninstall directory).
Your only option is to click OK. The Service Pack update process will halt.

CAUSE

The Service Pack executable file (nt4sp3_i.exe) is a self-extracting file that extracts itself to the TMP environment variable location. By default, this is set to %SystemDrive%\Temp. If the drive containing this path is near capacity, you will get the Extraction Error as the file is expanding to the temporary directory.

Upon successful extraction, Update.exe is launched and will update the Windows NT directory that is determined by the WINDIR environment variable. By default, this is set to %SystemRoot%. If the drive containing the %SystemRoot% is low on space you will get the Service Pack Setup Error.

RESOLUTION

Extraction Error

Either free up approximately 60 megabytes of disk space (53.8 MB expanded) on the system drive or change the environment variable TMP to another drive that has enough storage space.

To change the environment variable, perform the following steps:
  1. Click the Start button, point to Settings, and click Control Panel.
  2. Double-click the System icon, and then click the Environment tab.
  3. Select TMP from the User Variables list, and then type <newdriveletter>:\Temp in the Value box.
  4. Click OK, restart your computer, and then try to apply the service pack.

Service Pack Setup Error

Free up either 30 or 60 megabytes of disk space depending on whether or you not you choose to create an uninstall directory.

Properties

Article ID: 172235 - Last Review: October 31, 2006 - Revision: 1.1
APPLIES TO
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kberrmsg kbprb kbsetup KB172235

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com