Client Cannot Resolve MX Record via Microsoft DNS Server

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Article ID: 173676 - View products that this article applies to.
This article was previously published under Q173676
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Symptoms

When you use a Microsoft Windows NT version 4.0 Domain Name Service (DNS) server, your clients may not be able to successfully resolve mail server names to IP addresses.

Cause

The DNS client is sending a recursive query to the Microsoft DNS server, which is forwarding that query to a BIND-based DNS server. Some BIND-based DNS servers return a Start of Authority (SOA) record with a Responsible Authoritative Mailbox field instead of a Mail eXchange (MX) record. If the authoritative DNS server for the domain in which the mail server resides is one of these BIND-based DNS servers, the Microsoft DNS server will not return that record to the client.

Resolution

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack

Status

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Properties

Article ID: 173676 - Last Review: October 26, 2013 - Revision: 2.0
Applies to
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive kb3rdparty kbbug kbfix kbnetwork KB173676

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