Reinícios Windows continuamente com ecrã azul

Traduções de Artigos Traduções de Artigos
Artigo: 174630 - Ver produtos para os quais este artigo se aplica.
Importante
Este artigo aplica-se para o Windows 2000. Suporte para o Windows 2000 termina em 13 de Julho de 2010. O Windows 2000 End-of-Support Solution Center é um ponto de partida para planear a estratégia de migração a partir do Windows 2000. Para mais informações consulte a Microsoft Support Lifecycle Policy.
Expandir tudo | Reduzir tudo

Sintomas

Quando iniciar o Windows, o computador poderá apresentar brevemente o ecrã de arranque azul e, em seguida, reinicie continuamente.

Causa

Este comportamento pode ocorrer caso se verifiquem as seguintes condições:
  • Um erro fatal do sistema (STOP erro) faz com que o computador parar.
  • A opção Reiniciar automaticamente está activada em recuperação no separador Startup/Shutdown nas propriedades do sistema.

    Nota: no Windows Server 2000, a opção Reiniciar automaticamente está activada na caixa de diálogo arranque e recuperação. Esta caixa de diálogo é apresentada depois de clicar no botão arranque e recuperação no separador Avançadas nas propriedades do sistema.
  • O ficheiro de paginação do Windows é mais pequeno do que a quantidade de memória física instalada no computador ou não existe espaço livre suficiente no disco rígido de sistema para escrever o ficheiro de informações de estado de erro (Memory.dmp).

Resolução

Importante Esta secção, método ou tarefa contém passos que a saber como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo incorrectamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
322756Como efectuar uma cópia de segurança e restaurar o registo no Windows

Nota: para contornar este problema, necessitar de uma instalação paralela do Windows.

Para efectuar as alterações necessárias, siga estes passos:
  1. Instale o Windows numa pasta diferente.
  2. Execute o Regedt32.exe a partir da nova instalação do Windows e, em seguida, vá para a chave HKEY_LOCAL_MACHINE.
  3. No menu registo, clique em Carregar ramo de registo e, em seguida, abra o ficheiro de sistema na localização de instalação original do Windows. Por predefinição, esta instalação está localizada em % SystemRoot%\System32\Config\System.
  4. Introduza um nome arbitrário quando receber um pedido um nome de chave na janela Carregar secção. Isto carrega o ramo HKEY_LOCAL_MACHINE original como uma subchave da chave actual.
  5. Altere o valor de dados no valor AutoReboot como 0 (zero), em vez de 1 na seguinte chave:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl
  6. Fechar a subchave HKEY_LOCAL_MACHINE e descarregar o ramo de registo.
Isto desactiva a opção reiniciar automaticamente o original do Windows instalação. Depois de seguir estes passos, poderá conseguir reunir informações a partir de uma mensagem de erro de STOP e resolver o problema que impede o computador de iniciar.

Outra solução poderá ser necessária se o tamanho mínimo do ficheiro de paginação é definido para um valor menor do que a quantidade de memória física. Windows requer um ficheiro de paginação na unidade de sistema suficientemente grande para conter todos os de memória física mais 1 megabyte (MB), para escrever informações de depuração. Pode modificar o valor de PagingFiles da instalação original para que o ficheiro de informação pode ser criado pela mensagem de erro STOP. Espaço livre suficiente no disco tem de estar disponível na unidade de sistema para o ficheiro de paginação.

Siga estes passos para alterar o valor de PagingFiles no ficheiro de sistema na localização da instalação original do Windows:
  1. Siga os passos 1 a 4 da solução anterior.
  2. Altere o valor de dados do valor PagingFiles para permitir que um valor mínimo da quantidade de memória física mais 1 MB, mas não superior a quantidade de espaço livre no disco rígido. O nome de chave é:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management
    Por exemplo: "drive: \pagefile.sys nnnnnn" em que drive é a letra da disco rígido do sistema e nnn é um número para o tamanho mínimo e máximo do ficheiro de paginação.
  3. Verifique na seguinte chave para verificar se o valor de CrashDumpEnabled é definido para um valor de dados de 1:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl
  4. Fechar a subchave HKEY_LOCAL_MACHINE e descarregar o ramo de registo.
  5. Tentativa iniciar a instalação original do Windows e deve aparecer a mensagem de erro STOP. A informação de informação é armazenada no ficheiro de paginação.
  6. Reinicie o computador e seleccione a instalação paralela do Windows. Isto permite que o ficheiro de informação ser criado e poderá ser possível utilizar as informações para resolver o problema que faz com que a mensagem de erro STOP na instalação original.

    Nota: O ficheiro de informação é guardado no ficheiro % SystemRoot%\Memory.dmp, em que % SystemRoot % é a pasta de sistema da instalação paralela.

Mais Informação

Windows poderá detectar um problema durante o arranque que resulta numa mensagem de erro STOP. Dependendo da configuração do sistema, o ecrã azul não poderá ser apresentado durante tempo suficiente para registar informações de erro. Utilizar as soluções listadas acima, pode alterar o processo de arranque, de modo a que podem ser recolhidas informações importantes sobre a mensagem de erro STOP.

Para obter informações adicionais sobre como resolver mensagens de erro STOP, clique nos números de artigo existentes abaixo para visualizar os artigos na base de dados de conhecimento da Microsoft:
123750Depuração ecrãs STOP de configuração do Windows NT
129845Preparação de ecrã azul antes Contacting Microsoft
Para obter informações adicionais sobre uma instalação paralela do Microsoft Small Business Server, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
252777Como efectuar uma instalação paralela no Small Business Server

Propriedades

Artigo: 174630 - Última revisão: 26 de fevereiro de 2007 - Revisão: 3.6
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbmt kbenv kberrmsg kbprb KB174630 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 174630

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com