Article ID: 175020 - Last Review: October 15, 2002 - Revision: 1.2

BUG: Remote COM Server Shuts Down After 6 Minutes

This article was previously published under Q175020
Expand all | Collapse all

SYMPTOMS

When a COM client on a Windows NT machine runs under an identity that cannot be authenticated on the remote machine, a COM server started by the client will shut down in approximately six minutes.

CAUSE

This problem is caused by a bug in the ping component of the NT OXID resolver process (Rpcss.exe). Even though the activation is unsecure, the ping client in the resolver process attempts secure pings. This problem does not happen with the DCOM95 resolver process.

RESOLUTION

At present there is no way to resolve this problem except to run the client under a user account that can be validated on the server. This could either be a Windows NT domain account that is known on the server or a local machine account that exists on the server (if the server is on a Windows NT machine). In case of the latter, the ASCII user name and password of the account on the client and the server must match exactly.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Windows NT Service Pack 4.

MORE INFORMATION

The hot fix described in this article does not apply to the following scenarios:
  • The client and server are in different domains.
  • The client passes user credentials via the CoCreateInstanceEx API. The server can authenticate the credentials of the userid passed via the API, but it cannot authenticate the owner of the client process. For example, the client process runs as X, the client passes Y's credentials using the COAUTHINFO structure. X cannot be authenticated on the server, but Y can be authenticated on the server. The server is secure and allows Y to launch or have access. The client gets an interface pointer but the server will run down in 6 minutes.
For additional information, if you are experiencing problems similar to the above scenarios, click the article number below to view the article in the Microsoft Knowledge Base:
224837  (http://support.microsoft.com/kb/224837/EN-US/ ) DCOM Clients Ping Server After Client Program Has Shut Down
The problem only occurs when the COM client is on a Windows NT machine. COM clients on DCOM95 machines will not have this problem.

APPLIES TO
  • Microsoft Win32 Software Development Kit (SDK) for Windows NT 4.0
Keywords: 
kbapi kbbug KB175020
 

Article Translations