Message d'erreur : Impossible d'établir une connexion avec le Serveur

Traductions disponibles Traductions disponibles
Numéro d'article: 175039 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F175039
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous tentez de vous connecter à un site Web après avoir installé Internet Explorer, le message d'erreur suivant s'affiche :
Impossible d'établir une connexion avec le serveur.
Même si vous ne pouvez pas accéder à Internet, vous pouvez accéder à un site Web du réseau intranet.

Cause

Ce message d'erreur peut apparaître si le fichier Wsock32n.dll n'est pas mis à jour pendant l'installation de Microsoft Internet Explorer 4.0. Cela peut arriver si vous passez de Internet Explorer 3.02 à Internet Explorer 4.0 et que vous vous connectez à Internet à l'aide d'un serveur proxy SOCKS.

Résolution

Pour résoudre ce problème, utilisez l'une des méthodes suivantes :

Évoluez vers Internet Explorer 4.01

Procurez-vous Microsoft Internet Explorer 4.01. Pour cela, visitez le site Web Microsoft suivant :
http://www.microsoft.com/france/ie/

Remplacez le fichier Wsock32n.dll

Extrayez et remplacez le fichier Wsock32n.dll pour Windows 95 :
  1. Redémarrez Windows 95, appuyez sur la touche F8 lorsque le message " Démarrage de Windows 95 " apparaît, puis choisissez Invite MS-DOS en :Mode Sans Échec dans le menu Démarrage.
  2. Renommez le fichier Wsock32n.dll dans le dossier Windows\System en Wsock32n.old. Pour cela, tapez la ligne suivante et appuyez sur ENTRÉE
    ren <lecteur>:\<windows>\system\wsock32n.dll wsock32n.old
    où <lecteur> est la lettre du lecteur sur lequel se trouve le dossier Windows et <windows> le nom du dossier d'installation de Windows. Par exemple :
    ren c:\windows\system\wsock32n.dll wsock32n.old
    REMARQUE : Cette procédure suppose que vous n'avez pas de fichier nommé Wsock32n.old. Si vous en avez un, adoptez une extension qui n'est pas encore utilisée.
  3. Tapez la ligne suivante, puis appuyez sur ENTRÉE
    extract <lecteur>:<chemin>ie4_s4.cab /l <lecteur2>:<chemin2>
    où <lecteur> est la lettre du lecteur sur lequel se trouvent les fichiers d'installation de Internet Explorer 4.0, <chemin> est le chemin d'accès du dossier dans lequel se trouvent les fichiers d'installation de Internet Explorer 4.0, <lecteur2> est le nom du lecteur vers lequel extraire le fichier Ie4_4.cab et <chemin2> est le chemin du dossier vers lequel extraire le fichier Ie4_4.cab. Par exemple :
    extract c:\intern~1.0se\ie4_s4.cab /l c:\intern~1.0se
  4. Tapez la ligne suivante, puis appuyez sur ENTRÉE
    extract <lecteur>:<chemin>wsock32n.dll /l <lecteur2>:\<windows>\system
    où <lecteur> est la lettre du lecteur sur lequel se trouve le fichier IE4_4.cab, <chemin> est le chemin du dossier dans lequel se trouve le fichier IE4_4.cab, <lecteur2> est le lecteur sur lequel Windows est installé et <chemin2> l'emplacement du dossier Windows\System. Par exemple :
    extract c:\intern~1.0se\ie4_4.cab wsock32n.dll /l c:\windows\system
  5. Redémarrez votre ordinateur.
Extrayez et remplacez le fichier Wsock32n.dll pour Windows NT :
  1. Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Invite MS-DOS.
  2. A l'invite de commande, tapez les commandes suivantes, en appuyant sur ENTRÉE
    ren <lecteur>:\<windows>\system32\wsock32n.dll wsock32n.old
    où <lecteur> est la lettre du lecteur sur lequel se trouve le dossier Windows et <windows> le nom du dossier d'installation de Windows. Par exemple :
    ren c:\windows\system32\wsock32n.dll wsock32n.old
    REMARQUE : Cette procédure suppose que vous n'avez pas de fichier nommé Wsock32n.old. Si vous en avez un, adoptez une extension qui n'est pas encore utilisée.
  3. Tapez la ligne suivante, puis appuyez sur ENTRÉE
    extract <lecteur>:<chemin>ie4nt_s4.cab /l <lecteur2>:<chemin2>
    où <lecteur> est la lettre du lecteur sur lequel se trouvent les fichiers d'installation de Internet Explorer 4.0, <chemin> est le chemin du dossier dans lequel se trouvent les fichiers d'installation de Internet Explorer 4.0, <lecteur2> est le nom du lecteur vers lequel extraire le fichier Ie4_4.cab et <chemin2> le chemin du dossier vers lequel extraire le fichier Ie4_4.cab. Par exemple :
    extract c:\intern~1.0se\ie4nt_s4.cab /l c:\intern~1.0se
  4. Tapez la ligne suivante, puis appuyez sur ENTRÉE
    extract <lecteur>:<chemin>wsock32n.dll /l <lecteur2>:\<windows>\system32
    où <lecteur> est la lettre du lecteur sur lequel se trouve le fichier IE4_4.cab, <chemin> est le chemin du dossier dans lequel se trouve le fichier IE4_4.cab, <lecteur2> est le lecteur sur lequel Windows est installé et <chemin2> est l'emplacement du dossier Windows\System. Par exemple :
    extract c:\intern~1.0se\ie4_3.cab wsock32n.dll /l c:\windows\system32
  5. Cliquez sur Démarrer, Arrêter, "Fermer toutes les programmes et ouvrir une session sous un utilisateur différent", puis sur Oui.

Statut

Ce problème est corrigé dans Internet Explorer 4.01.

Plus d'informations

Le fichier Wsock32n.dll installé par Internet Explorer 4.0 présente la même version que le fichier installé avec Internet Explorer 3.02 ; il n'est donc pas mis à jour. La version du fichier Wsock32n.dll inclus dans Internet Explorer 4.0 est 5.1.02, et sa taille est 26 160 octets.

Pour plus d'informations sur l'utilisation de l'outil d'extraction, consultez l'article ci-dessous de la Base de Connaissances Microsoft :
129605 Procédure pour extraire des fichiers Windows d'origine compressés
Pour plus d'informations sur les serveurs proxy, consultez l'article ci-dessous de la Base de Connaissances Microsoft :
135982 Procédure pour configurer Internet Explorer en vue de l'utilisation d'un serveur proxy

Propriétés

Numéro d'article: 175039 - Dernière mise à jour: mercredi 18 février 2004 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Édition 128 bits
  • Microsoft Internet Explorer 4.0 Édition 128 bits
Mots-clés : 
kberrmsg msient msiew95 KB175039
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.
Exclusion de responsabilité concernant les contenus obsolètes dans la Base de connaissances
Cet article concerne des produits pour lesquels Microsoft n'offre plus de support. Il est par conséquent fourni « en l'état » et ne sera plus mis à jour.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com