Article ID: 175705 - Last Review: January 22, 2007 - Revision: 3.2

ACC: "Out Of Memory" Error After Printing Subform on Windows NT

This article was previously published under Q175705

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SYMPTOMS

You may receive an "Out of Memory" error message in Microsoft Access 95 or 97 when you print a selection from a form. The error will continue to pop up every minute or so until the program is re-run.

CAUSE

This error occurs when one Microsoft Access process releases a Windows Graphics resource (GDI object) while a separate process still references that same Windows resource. When the second Access process tries to reference the Windows resource, the error described in the "Symptoms" section occurs.

RESOLUTION

To resolve this problem for Microsoft Access 97, obtain Microsoft Office 97 Service Release 2 (SR-2).

For additional information about SR-2, please see the following article in the Microsoft Knowledge Base:
151261  (http://support.microsoft.com/kb/151261/EN-US/ ) OFF97: How to Obtain and Install MS Office 97 SR-2

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access versions 7.0 and 97. This problem was corrected in Microsoft Office 97 Service Release 2 (SR-2).

MORE INFORMATION

Steps to Reproduce Behavior


  1. Open the sample database Northwind.mdb.
  2. Open the Orders form.
  3. Click the Print Invoice button or Select Print and choose Selection.
  4. Click on the Grid Object. The text may appear distorted.
  5. If it is not, repeat step 3 again.
After a period of time you will receive the error described in the SYMPTOMS section.

APPLIES TO
  • Microsoft Access 95 Standard Edition
  • Microsoft Access 97 Standard Edition
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbprint KB175705
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

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