Article ID: 175775 - Last Review: April 30, 2012 - Revision: 7.0

Nothing happens when you click a link in Internet Explorer

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This article was previously published under Q175775
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SYMPTOMS

When you click a hyperlink on a webpage or in an email message, nothing happens. Internet Explorer does not open the webpage. 

Note This information applies to Internet Explorer 9, Internet Explorer 8, and Internet Explorer 7.

CAUSE

This behavior may occur for one or more of the following reasons:
  • A corrupted browser choice setting may cause Windows to misinterpret which browser is set as the default browser on your computer.
  • Settings were changed after a software installation that cause webpages not to work correctly.
  • A previously installed browser or add-on may be interfering with other software on your computer.
  • Registry key were changed or became corrupted.

RESOLUTION

This section is intended for a beginning to intermediate computer user. If these methods do not resolve the problem, you can try the methods in the “Advanced Troubleshooting” section.

To resolve the problem, use the following methods in the order in which they are presented.


Method 1: Check your default web browser setting

In Microsoft Windows, you can select which web browser to use by default. To make Internet Explorer your default web browser, follow these steps:

  1. To open Internet Explorer, click Start, and then click Internet Explorer.
  2. If you are prompted whether you want Internet Explorer to be your default browser, click Yes. This is all that you have to do.
    If a message does not appear, go to the next step.
  3. Click the Tools button, and then click Internet Options.
  4. Click the Programs tab, and then click Make default.
  5. Click OK, and then close Internet Explorer.

    Note Your changes will take effect the next time that you start Internet Explorer.
Check whether the problem is resolved. If the problem is resolved, you are finished with this article. If the problem is not resolved, try the next method.

 

Method 2: Change the file types that Internet Explorer opens by default

For Windows 7 and Windows Vista

  1. Close any Internet Explorer windows that are open.
  2. Click Start, and then click Control Panel.
  3. Click Programs, and then click Set your default programs.
  4. On the Programs menu, click Internet Explorer, and then click Choose defaults for this program.
  5. Make sure that the check boxes for .htm, .html, and .url are selected, and then click Save.
  6. Click OK.

    Note Your changes will take effect the next time that you start Internet Explorer.
For Windows XP
  1. To open Windows Explorer, right-click Start, and then click My Computer.
  2. On the Tools menu, click Folder Options, and then click the File Types tab.
  3. Locate and select the HTM file type.
  4. Make sure that Internet Explorer is selected as the Opens with program. If Internet Explorer is not selected, click Change, select Internet Explorer as the recommended program, and then click OK.
  5. Repeat steps 3 and 4 for the following file types:

    HTML
    ITS
    MHT
    MTHML
    XML
    XSL
Check whether the problem is resolved. If the problem is resolved, you are finished with this article, If the problem is not resolved, go to the next method.


Method 3: Use the Internet Explorer (No Add-ons) mode

Although browser add-ons can improve your online experience, they can occasionally interfere or conflict with other software on your computer. However, be aware that some webpages, or Internet Explorer itself, might not be displayed correctly if an add-on is disabled. First, start Internet Explorer with add-ons temporarily disabled to see whether the problem is resolved. (Add-ons will be disabled only until you restart Internet Explorer in the usual way). To do this, follow these steps:
  • Click Start, type Internet Explorer in the Search box, and then click Internet Explorer (No Add-ons).

    Note For Windows XP, click Start, right-click the Internet Explorer icon, and then click Browse without add-ons.
If Internet Explorer No Add-ons resolves the problem, follow these steps to identify the browser add-on that is causing the problem:
  1. To start Internet Explorer, click Start, and then click Internet Explorer.
  2. Click the Tools button, and then click Manage add-ons.
  3. Click an add-on in the Name list, and then click Disable. Test Internet Explorer.
  4. Repeat step 3 until you identify the add-on that is causing the problem.
Check whether the problem is resolved. If the problem is resolved, you are finished with this article. If the problem is not resolved, try the next method.

Method 4: Reset Internet Explorer settings

If the problem is caused by damaged or incompatible Internet Explorer settings or add-ons, you can usually resolve the problem by resetting Internet Explorer settings to their default settings. 

Resetting Internet Explorer’s settings is not reversible. After a reset, all previous settings are lost and cannot be recovered. When you restore Internet Explorer’s default settings, some webpages that rely on previously stored cookies, form data, passwords, or previously installed browser add-ons might not work correctly. However, resetting Internet Explorer to its default settings does not delete your favorites, feeds, or several other personal settings. 

To Reset Internet Explorer Settings, follow these steps:
  1. Close all open Internet Explorer windows.
  2. Click Start, type inetcpl.cpl in the Search box and then click inetcpl.cpl in the programs list. 
    The Internet Options dialog box appears.

    Note for Windows XP, click Start, click Run, type inetcpl.cpl in the Open box, and then click OK.
  3. Click the Advanced tab.
  4. Under Reset Internet Explorer Settings, click Reset. Then click Reset again.
  5. When Internet Explorer finishes resetting the settings, click Close in the Reset Internet Explorer Settings dialog box.
  6. Start Internet Explorer again.
    Your changes will take effect the next time you open Internet Explorer. 

    Note Your changes will take effect the next time that you start Internet Explorer.

Method 5: Reregister the necessary Internet Explorer DLL files 

Note This information applies to Windows XP

To reregister the DLL files, follow these steps:
  1. Click Start, click All Programs, click Accessories, right-click cmd, and then select Run as administrator. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  2. Type regsvr32 urlmon.dll in the Open box, and then click OK.
  3. Click OK when you receive the confirmation.
  4. Repeat steps 2 and 3 for the following commands: 

    regsvr32 mshtml.dll
    regsvr32 shdocvw.dll
    regsvr32 browseui.dll
    regsvr32 msjava.dll
Check whether the problem is resolved. If the problem is resolved, you are finished with this article. If the problem is not fixed, go to the next section.

Advanced troubleshooting

This section is intended for more advanced computer users.

Method 1: Create a new user account

For more information about user profiles, see "What are user profiles. (http://windows.microsoft.com/en-US/windows-vista/What-are-user-profiles) "

For method details, visit the following Microsoft websites:

Windows 7: Fix a corrupted user profile (http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile)
Windows Vista: Fix a corrupted user profile (http://windows.microsoft.com/en-US/windows-vista/Fix-a-corrupted-user-profile)
Windows XP: How to create and configure user accounts in Windows XP (http://support.microsoft.com/kb/279783)

Method 2: Use System Restore

System restore uses "restore points" to return your system files and settings to an earlier point in time without affecting your personal files. Restore points are created automatically every week and just before significant system events, such as the installation of a program, a device, or a driver. 

Before you start System Restore, save any open files and close all programs. After you confirm your restore point, System Restore restarts your computer. To perform a System Restore, follow these steps:

For Windows 7 and Windows Vista
  1. Click Start, click All Programs, click Accessories, click System Tools, and then click System Restore. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  2. Click Next on the System Restore page.
  3. Select the system restore date or description to which you want to restore the system.

    Note If you don’t see the particulate date that you are looking for, select Show more dates, and then select the target date
  4. In the confirmation window, click Finish.
Your computer will restart. When the process is complete, you will receive a confirmation message.

For Windows XP

  1. Log on to Windows by using an account that has administrative permissions.
  2. Click Start, click All Programs, click Accessories, click System Tools, and then click System Restore.
  3. On the Welcome to System Restore page, click to select the Restore my computer to an earlier time option, and then click Next.
  4. On the Select a Restore point page, click the most recent system restore point in the On this list, click a restore point list, and then click Next.
  5. On the Confirm Restore Point Selection page, click Next. System Restore restores the previous windows XP configuration and then restarts the computer.
  6. Log on to the computer as an Administrator. Then, click OK on the system Restore Restoration Complete page.
Your computer will restart. When the process is complete, you will receive a confirmation message.

If you use System Restore to resolve a problem but the problem remains or other problems are introduced, you can undo the restore operation. After you undo the restore, you can try using a different restore point. To undo a System Restore operation, follow these steps:
  1. Click Start, click All Programs, click Accessories, click System Tools, and then click System Restore.
  2. Click Undo System Restore, and then click Next.
  3. Review your choices and then click Finish.
Your computer will restart. When the process is completed, you will receive a confirmation.

Additional Support

Check whether the problem is resolved. If the problem is resolved, you are finished with this article. If the problem is not resolved, you can also use Microsoft Customer Support Services to find other solutions. Microsoft Customer Support Services include the following:

Search the Microsoft Knowledge Base (http://support.microsoft.com/search/?adv=1) : Find technical support information and self-help tools for Microsoft products.
Solution Centers (http://support.microsoft.com/select/?target=hub) : View product-specific frequently asked questions and support highlights.
Microsoft Answers (http://answers.microsoft.com/en-us/windows/default.aspx#tab=1) : Contact counterparts, peers, and Microsoft Most Valuable Professionals (MVPs).
Other support options (http://support.microsoft.com/contactus#tab0) : Ask a question, contact Microsoft Customer Support Services, or provide feedback.

If you continue to experience problems with Internet Explorer or if you want to ask a question, contact Microsoft Customer Support Services, or provide feedback, visit the following Microsoft website:
http://support.microsoft.com/contactus#tab0 (http://support.microsoft.com/contactus#tab0)

APPLIES TO
  • Windows Internet Explorer 9
  • Windows Internet Explorer 8
  • Windows Internet Explorer 7
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