Rien ne se produit lorsque vous cliquez sur un lien dans Internet Explorer.

Avertissement

L’application de bureau Internet Explorer 11, mise hors service et dont le support a pris fin, a été désactivée définitivement via une mise à jour Microsoft Edge sur certaines versions de Windows 10. Pour plus d’informations, consultez le forum aux questions sur la mise hors service de l’application de bureau Internet Explorer 11.

Cet article vous aide à résoudre le problème pour lequel la page web ne peut pas être ouverte lorsque vous cliquez sur un lien hypertexte dans Internet Explorer.

Version du produit d’origine : Internet Explorer 9
Numéro de l’article d’origine dans la base de connaissances : 175775

Symptômes

Quand vous cliquez sur un lien hypertexte sur une page web ou dans un e-mail, rien ne se produit. Internet Explorer n’ouvre pas la page web.

Remarque

Cela s’applique à Internet Explorer 9, Internet Explorer 8 ou Internet Explorer 7.

Cause

Ce problème se produit pour une ou plusieurs des raisons suivantes :

  • Le paramètre dans lequel vous choisissez le navigateur web que vous souhaitez utiliser est endommagé. Cela peut entraîner Windows à mal interpréter le navigateur défini comme navigateur par défaut sur votre ordinateur.
  • Une fois le logiciel installé, les paramètres ont été modifiés, ce qui peut entraîner le mauvais fonctionnement des liens vers les pages web.
  • Un navigateur ou un complément précédemment installé peut interférer avec d’autres logiciels sur votre ordinateur.
  • Les clés de Registre ont été modifiées ou endommagées.

Résolution

Cette section s’adresse aux utilisateurs débutants ou d’un niveau intermédiaire en informatique. Si les autres méthodes ne permettent pas de résoudre le problème, vous pouvez essayer les méthodes de la section Résolution des problèmes avancée. Pour résoudre ce problème, appliquez les méthodes suivantes en respectant l’ordre dans lequel elles sont présentées.

Méthode 1 : vérifier le paramètre de votre navigateur web par défaut.

Dans Microsoft Windows, vous pouvez sélectionner le navigateur web que vous souhaitez utiliser. Pour établir Internet Explorer en tant que navigateur web par défaut, procédez comme suit :

  1. Dans Internet Explorer, cliquez sur Démarrer, puis sur Internet Explorer.
  2. Si vous êtes invité à confirmer que vous souhaitez qu’Internet Explorer soit votre navigateur par défaut, cliquez sur Oui.
  3. Dans le menu Outils, cliquez sur Options Internet.
  4. Cliquez sur Programmes>Par défaut>OK, puis fermez Internet Explorer.

Remarque

Les modifications prennent effet à la prochaine ouverture d’Internet Explorer.

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cet article. Si le problème persiste, essayez la méthode suivante.

Méthode 2 : modifier les types de fichiers qu’Internet Explorer ouvre par défaut.

Sous Windows 7 et Windows Vista.

  1. Fermez toutes les fenêtres d’Internet Explorer.
  2. Cliquez sur Démarrer, puis sur Panneau de configuration.
  3. Cliquez sur Programmes, puis sur Définir les programmes par défaut.
  4. Dans le menu Programmes, cliquez sur Internet Explorer, puis sur Choisir les valeurs par défaut pour ce programme.
  5. Vérifiez que les cases à cocher pour .htm, .html et urls sont sélectionnées, puis cliquez sur Enregistrer.
  6. Cliquez sur OK.

Remarque

Les modifications prennent effet à la prochaine ouverture d’Internet Explorer.

Pour Windows XP

  1. Pour ouvrir Windows Explorateur, cliquez avec le bouton droit sur Démarrer, puis sur Mon ordinateur.

  2. Dans le menu Outils, cliquez sur Options des dossiers, puis sur l’onglet Types de fichiers.

  3. Recherchez et sélectionnez le type de fichier HTM.

  4. Assurez-vous qu’Internet Explorer est sélectionné comme programme Ouvrir avec. Si Internet Explorer n’est pas sélectionné, cliquez sur Modifier, sélectionnez Internet Explorer comme programme recommandé, puis cliquez sur OK.

  5. Répétez les étapes 3 et 4 pour les types de fichiers suivants :

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cet article. Si le problème persiste, essayez la méthode suivante.

Méthode 3 : utiliser le mode Aucun module complémentaire d’Internet Explorer.

Bien que les compléments puissent améliorer votre expérience en ligne, ils peuvent parfois interférer ou entrer en conflit avec un autre programme sur votre ordinateur. Toutefois, sachez que certaines pages web, ou Internet Explorer lui-même, peuvent ne pas être affichées correctement si un complément est désactivé. Tout d’abord, démarrez Internet Explorer avec des compléments temporairement désactivés pour voir si le problème est résolu. (Les compléments sont désactivés uniquement jusqu’à ce que vous redémarrez Internet Explorer de la manière habituelle). Pour cela, procédez comme suit :

  • Cliquez sur Démarrer, tapez Internet Explorer dans la zone Recherche, puis cliquez sur Internet Explorer (aucun module complémentaire).

    Remarque

    Pour Windows XP, cliquez sur Démarrer, cliquez avec le bouton droit sur l’icône Internet Explorer, puis sur Parcourir sans modules complémentaires.

Si le mode Aucun module complémentaire d’Internet Explorer résout le problème, procédez comme suit pour identifier le complément de navigateur à l’origine du problème :

  1. Pour démarrer Internet Explorer, cliquez sur Démarrer, puis sur Internet Explorer.
  2. Cliquez sur le bouton Outils, puis sur Gérer les modules complémentaires.
  3. Cliquez sur un complément, puis sur Désactiver. Testez Internet Explorer.
  4. Répétez l’étape 3 jusqu’à ce que vous identifiiez le complément à l’origine du problème.

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cet article. Si le problème persiste, essayez la méthode suivante.

Méthode 4 : réinitialiser les paramètres dʼInternet Explorer

Si le problème est dû à des paramètres ou compléments Internet Explorer endommagés ou incompatibles, vous pouvez généralement résoudre le problème en réinitialisant les paramètres Internet Explorer aux paramètres par défaut.

Lorsque vous réinitialisez les paramètres d’Internet Explorer, tous les paramètres précédents sont perdus et ne peuvent pas être récupérés. Lorsque vous restaurez les paramètres par défaut d’Internet Explorer, certaines pages web basées sur des cookies, des données de formulaire, des mots de passe ou des compléments de navigateur installés précédemment peuvent ne pas fonctionner correctement. Toutefois, le rétablissement des paramètres par défaut d’Internet Explorer ne supprime pas vos favoris, ni vos flux, ni d’autres paramètres personnalisés.

Pour réinitialiser Internet Explorer, procédez comme suit :

  1. Fermez toutes les fenêtres d’Internet Explorer.

  2. Cliquez sur Démarrer, tapez inetcpl.cpl dans la zone de recherche, puis cliquez sur inetcpl.cpl dans la liste Programmes. La boîte de dialogue Options Internet s’affiche.

    Remarque

    Cliquez sur Démarrer, sur Exécuter, tapez inetcpl.cpl dans la zone Ouvrir, puis cliquez sur OK.

  3. Cliquez sur l’onglet Avancé.

  4. Sous Réinitialiser les paramètres d’Internet Explorer, cliquez sur Réinitialiser. Cliquez ensuite à nouveau sur Réinitialiser.

  5. Une fois qu’Internet Explorer a terminé de réinitialiser les paramètres, cliquez sur Fermer dans la boîte de dialogue Réinitialiser les paramètres d’Internet Explorer.

  6. Redémarrez Internet Explorer. Les modifications prennent effet à la prochaine ouverture d’Internet Explorer.

Méthode 5 : réinscrire les fichiers DLL Internet Explorer nécessaires.

Remarque

Ces informations s’appliquent à Windows XP.

Pour réinscrire les fichiers DLL, effectuez les étapes suivantes :

  1. Cliquez sur Démarrer, sur Tous les programmes, sur Accessoires, cliquez avec le bouton droit sur cmd, puis cliquez sur Exécuter en tant qu’administrateur. Si vous êtes invité à entrer un mot de passe administrateur ou une confirmation, saisissez votre mot de passe ou fournissez la confirmation.

  2. Tapez regsvr32 urlmon.dll dans la zone Ouvrir, puis cliquez sur OK.

  3. Cliquez sur OK lorsque vous recevez la confirmation.

  4. Répétez les étapes 2 et 3 pour les commandes suivantes :

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cet article. Si le problème persiste, passez à la section suivante.

Dépannage avancé

Cette section est destinée aux utilisateurs expérimentés.

Méthode 1 : créer un compte utilisateur.

Pour plus d’informations sur les profils utilisateurs, consultez À propos des profils utilisateur.

Pour les détails de la méthode, allez sur les sites Internet Microsoft suivants :

Méthode 2 : utiliser la restauration du système.

La restauration du système utilise des points de restauration pour renvoyer vos fichiers et paramètres système à un point antérieur dans le temps sans affecter vos fichiers personnels. Les points de restauration sont créés automatiquement chaque semaine et juste avant des événements système significatifs, tels que l’installation d’un programme, d’un appareil ou d’un pilote.

Avant de commencer la restauration du système, enregistrez les fichiers ouverts et fermez tous les programmes. Une fois que vous avez confirmé votre point de restauration, la restauration du système redémarre votre ordinateur. Pour effectuer une restauration du système, procédez comme suit :

Sous Windows 7 et Windows Vista

  1. Cliquez sur Démarrer, puis sur Tous les programmes, sur Accessoires, sur Outils système, puis cliquez sur Restauration du système. Si vous êtes invité à entrer un mot de passe administrateur ou une confirmation, saisissez votre mot de passe ou fournissez la confirmation.

  2. Cliquez sur Suivant dans la page Restauration du système.

  3. Sélectionnez la date de restauration du système ou la description souhaitée.

    Remarque

    Si vous ne voyez pas la date spécifique que vous recherchez, sélectionnez Afficher d’autres dates, puis sélectionnez la date souhaitée.

  4. Dans la fenêtre de confirmation, cliquez sur Terminer. Votre ordinateur redémarre. Une fois le processus terminé, vous recevrez un message de confirmation.

Pour Windows XP

  1. Connectez-vous à Windows avec un compte doté des autorisations d’administrateur.
  2. Cliquez sur Démarrer, puis sur Tous les programmes, sur Accessoires, sur Outils système, puis cliquez sur Restauration du système.
  3. Sur la page Bienvenue dans la restauration du système, cliquez sur l’option Restaurer mon ordinateur à une heure antérieure, puis cliquez sur Suivant.
  4. Sur la page Sélectionner un point de restauration, cliquez sur le point de restauration du système le plus récent de la liste, puis sur un point de restauration, puis cliquez sur Suivant.
  5. Sur la page Confirmer la sélection du point de restauration, cliquez sur Suivant. L’outil Restauration du système restaure la configuration Windows XP antérieure, puis redémarre l’ordinateur.
  6. Ouvrez une session sur l’ordinateur en tant qu’administrateur. Cliquez ensuite sur OK sur la page Restauration terminée de l’outil Restauration du système. Votre ordinateur redémarre. Une fois le processus terminé, vous recevrez un message de confirmation.

Si vous utilisez la restauration du système, mais que le problème persiste ou que d’autres problèmes se produisent, vous pouvez annuler l’opération de restauration. Après avoir annulé l’opération, vous pouvez essayer d’utiliser un autre point de restauration. Pour annuler une opération de restauration du système, procédez comme suit :

  1. Cliquez sur Démarrer, puis sur Tous les programmes, sur Accessoires, sur Outils système, puis cliquez sur Restauration du système.
  2. Cliquez sur Annuler la restauration du système, puis sur Suivant.
  3. Vérifiez vos choix, puis cliquez sur Terminer.

Votre ordinateur redémarre. Une fois le processus terminé, vous recevrez une confirmation.

Ressources supplémentaires

Vérifiez si le problème est résolu. Si c’est le cas, vous n’avez plus besoin de cet article. Si le problème n’est pas résolu, vous pouvez également utiliser les services de support client Microsoft pour trouver d’autres solutions. Les services de support Microsoft incluent les méthodes suivantes :