Internet Explorer에서 링크를 클릭하면 아무 작업도 수행하지 않습니다.

경고

사용과 지원이 중단된 Internet Explorer 11 데스크톱 애플리케이션이 Microsoft Edge 업데이트를 통해 특정 버전의 Windows 10에서 영구적으로 비활성화될 예정입니다. 자세한 내용은 Internet Explorer 11 데스크톱 앱 지원 중단 FAQ를 참조하세요.

이 문서는 Internet Explorer에서 하이퍼링크를 클릭할 때 웹 페이지를 열 수 없는 문제를 해결하는 데 도움이 됩니다.

원래 제품 버전: Internet Explorer 9
원본 KB 번호: 175775

증상

웹 페이지 또는 전자 메일 메시지에서 하이퍼링크를 클릭하면 아무 일도 발생하지 않습니다. Internet Explorer에서 웹 페이지를 열지 않습니다.

참고

해당 정보는 Internet Explorer 9, Internet Explorer 8 및 Internet Explorer 7에 적용됩니다.

원인

이 문제는 다음과 같은 이유 중 하나 이상으로 인해 발생합니다.

  • 사용하려는 웹 브라우저를 선택하는 설정이 손상되었습니다. 이로 인해 Windows가 컴퓨터에서 기본 브라우저로 설정된 브라우저를 잘못 해석할 수 있습니다.
  • 소프트웨어를 설치한 후 설정이 변경되어 웹 페이지에 대한 링크가 잘못 작동할 수 있습니다.
  • 이전에 설치된 브라우저 또는 추가 기능이 컴퓨터의 다른 소프트웨어를 방해할 수 있습니다.
  • 레지스트리 키가 변경되었거나 손상되었습니다.

해결 방법

이 섹션은 초급 및 중급 컴퓨터 사용자를 대상으로 합니다. 이러한 메서드가 문제를 해결하지 못하는 경우 고급 문제 해결 섹션에서 메서드를 사용해 볼 수 있습니다. 이 문제를 해결하려면 다음 메서드를 아래에 나타난 순서대로 따르세요.

방법 1: 기본 웹 브라우저 설정 확인

Microsoft Windows에서 사용할 웹 브라우저를 선택할 수 있습니다. Internet Explorer를 기본 웹 브라우저로 설정하려면 다음 단계를 따르세요.

  1. Internet Explorer를 열려면 시작을 클릭한 다음 Internet Explorer를 클릭합니다.
  2. Internet Explorer를 기본 브라우저로 사용할 것인지 확인하라는 메시지가 표시되면 를 클릭합니다.
  3. 도구 메뉴에서 인터넷 옵션을 클릭합니다.
  4. 프로그램에서>기본으로 설정>확인을 차례로 클릭하고 Internet Explorer를 닫습니다.

참고

변경 내용은 다음에 Internet Explorer를 시작할 때 적용됩니다.

문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 문서를 더 이상 읽을 필요가 없습니다. 문제가 해결되지 않으면 다음 방법을 사용하세요.

방법 2: Internet Explorer가 기본적으로 여는 파일 형식 변경

Windows 7 및 Windows Vista.

  1. 모든 Internet Explorer 창을 닫습니다.
  2. 시작을 클릭하고 제어판을 클릭합니다.
  3. 프로그램을 클릭한 다음 기본 프로그램 설정을 클릭합니다.
  4. 프로그램 메뉴에서 Internet Explorer를 클릭한 다음 이 프로그램의 기본값 선택을 클릭합니다.
  5. .htm,.htmlurls에 대한 확인란이 선택되어 있는지 확인한 다음 저장을 클릭합니다.
  6. 확인을 클릭합니다.

참고

변경 내용은 다음에 Internet Explorer를 시작할 때 적용됩니다.

Windows XP용

  1. Windows 탐색기를 열려면 시작을 마우스 오른쪽 단추로 클릭한 다음 내 컴퓨터를 클릭합니다.

  2. 도구 메뉴에서 폴더 옵션을 클릭한 다음 파일 형식 탭을 클릭합니다.

  3. HTM 파일 형식을 찾아 선택합니다.

  4. Internet Explorer가 프로그램을 사용하여 열기로 선택되어 있는지 확인합니다. Internet Explorer가 선택되지 않은 경우 변경을 클릭하고 권장 프로그램으로Internet Explorer를 선택한 다음 확인을 클릭합니다.

  5. 다음 파일 형식에 대해 3-4단계를 반복합니다.

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 문서를 더 이상 읽을 필요가 없습니다. 문제가 해결되지 않으면 다음 방법으로 이동하세요.

방법 3: Internet Explorer 추가 기능 없음 모드 사용

브라우저 추가 기능은 온라인 경험을 개선할 수 있지만 때때로 컴퓨터의 다른 소프트웨어와 충돌할 수 있습니다. 그러나 추가 기능을 사용하지 않도록 설정하면 일부 웹 페이지 또는 Internet Explorer 자체가 올바르게 표시되지 않을 수 있습니다. 먼저 추가 기능을 일시적으로 사용하지 않도록 설정한 채로 Internet Explorer를 시작하여 문제가 해결되었는지 확인합니다. (일반적인 방식으로 Internet Explorer를 다시 시작할 때까지 추가 기능은 사용하지 않도록 설정됩니다.) 이렇게 하려면 다음과 같이 하십시오.

  • 시작을 클릭하고 검색 상자에 Internet Explorer를 입력한 다음 Internet Explorer(추가 기능 없음)를 클릭합니다.

    참고

    Windows XP의 경우 시작을 클릭하고 Internet Explorer 아이콘을 마우스 오른쪽 단추로 클릭한 다음 추가 기능 없이 찾아보기를 클릭합니다.

Internet Explorer 추가 기능 없음 모드가 문제를 해결하는 경우 다음 단계에 따라 문제를 일으키는 브라우저 추가 기능을 식별합니다.

  1. Internet Explorer를 시작하고 시작을 클릭한 다음 Internet Explorer를 클릭합니다.
  2. 도구 단추를 클릭한 다음 추가 기능 관리를 클릭합니다.
  3. 이름 목록에서 추가 기능을 클릭한 다음 사용 안 함을 클릭합니다. Internet Explorer를 테스트합니다.
  4. 문제를 일으키는 추가 기능을 식별할 때까지 3단계를 반복합니다.

문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 문서를 더 이상 읽을 필요가 없습니다. 문제가 해결되지 않으면 다음 방법을 사용하세요.

방법 4: Internet Explorer 설정 초기화

문제가 손상되거나 호환되지 않는 Internet Explorer 설정 또는 추가 기능으로 인해 발생하는 경우 일반적으로 Internet Explorer 설정을 기본 설정으로 다시 설정하여 문제를 해결할 수 있습니다.

Internet Explorer 설정을 다시 설정하면 이전의 모든 설정이 손실되며 복구할 수 없습니다. Internet Explorer의 기본 설정을 복원하면 저장된 쿠키, 양식 데이터, 암호 또는 이전에 설치된 브라우저 추가 기능을 사용하는 일부 웹 페이지가 제대로 작동하지 않을 수 있습니다. Internet Explorer를 기본 설정으로 초기화해도 즐겨찾기, 피드 및 기타 몇 가지 개인 설정은 삭제되지 않습니다.

Internet Explorer를 다시 설정하려면 다음 단계를 따릅니다.

  1. 모든 Internet Explorer 창을 닫습니다.

  2. 시작을 클릭하고 검색 상자에 inetcpl.cpl을 입력한 다음 프로그램 목록에서 inetcpl.cpl를 클릭합니다. 인터넷 옵션 대화 상자가 나타납니다.

    참고

    Windows XP에서는 시작, 실행을 차례로 클릭한 후 열기 상자에 inetcpl.cpl을 입력하고 확인을 누릅니다.

  3. 고급 탭을 클릭합니다.

  4. Internet Explorer 설정 초기화에서 초기화를 클릭합니다. 그런 다음 초기화를 다시 클릭합니다.

  5. Internet Explorer가 초기화를 마치면 Internet Explorer 설정 초기화 대화 상자에서 닫기를 클릭합니다.

  6. Internet Explorer를 다시 시작합니다. 변경 사항은 다음에 Internet Explorer를 열 때 적용됩니다.

방법 5: 필요한 Internet Explorer DLL 파일 다시 등록

참고

이 정보는 Windows XP에 적용됩니다.

DLL 파일을 다시 등록하려면 다음 단계를 따르세요.

  1. 시작, 모든 프로그램, 보조프로그램을 차례로 클릭하고 cmd를 마우스 오른쪽 단추로 클릭한 다음 관리자 권한으로 실행을 클릭합니다. 관리자 암호 또는 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.

  2. 열기 상자에 regsvr32 urlmon.dll을 입력한 다음 확인을 선택합니다.

  3. 확인 메시지가 나타나면 확인를 클릭합니다.

  4. 다음 명령에 대해 2단계와 3단계를 반복합니다.

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 문서를 더 이상 읽을 필요가 없습니다. 문제가 해결되지 않으면 다음 섹션으로 이동합니다.

고급 문제 해결 방법

이 절은 보다 수준 높은 고급 컴퓨터 사용자를 대상으로 합니다.

방법 1: 새로운 사용자 계정 만들기

사용자 프로필에 대한 자세한 내용은 사용자 프로필 정보를 참조하세요.

자세한 내용은 다음 Microsoft 웹 사이트로 이동하세요.

방법 2: 시스템 복원 사용

시스템 복원은 복원 지점을 사용하여 개인 파일에 영향을 주지 않고 시스템 파일 및 설정을 이전 시점으로 돌려 놓습니다. 복원 지점은 프로그램, 디바이스 또는 드라이버 설치와 같은 중요한 시스템 이벤트 직전과 매주 자동으로 생성됩니다.

시스템 복원을 시작하기 전에 열려 있는 파일을 저장하고 모든 프로그램을 닫습니다. 복원 지점을 확인하면 시스템 복원이 컴퓨터를 다시 시작합니다. 시스템 복원을 진행하려면 다음 단계를 따릅니다.

Windows 7 및 Windows Vista

  1. 시작을 클릭하고 모든 프로그램, 보조프로그램, 시스템 도구를 차례로 클릭한 다음 시스템 복원을 클릭합니다. 관리자 암호 또는 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 확인합니다.

  2. 시스템 복원 페이지에서 다음을 클릭합니다.

  3. 원하는 시스템 복원 날짜 또는 설명을 선택합니다.

    참고

    찾고 있는 특정 날짜가 표시되지 않으면 더 많은 날짜 표시를 선택한 다음 원하는 날짜를 선택합니다.

  4. 확인 창에서 완료를 클릭합니다. 컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인 메시지가 표시됩니다.

Windows XP용

  1. 관리 권한을 가진 계정으로 Windows에 로그인합니다.
  2. 시작을 클릭하고 모든 프로그램, 보조프로그램, 시스템 도구를 차례로 클릭한 다음 시스템 복원을 클릭합니다.
  3. 시스템 복원 시작 페이지에서 내 컴퓨터를 이전 시간으로 복원 옵션을 선택한 후 다음을 클릭합니다.
  4. 복원 지점 선택 페이지에서 가장 최근의 시스템 복원 지점을 클릭합니다. 이 목록에서 복원 지점 목록을 클릭하고 다음을 클릭합니다.
  5. 복원 지점 선택 확인 페이지에서 다음을 클릭합니다. 시스템 복원은 이전 Windows XP 구성을 복원한 다음 컴퓨터를 다시 시작합니다.
  6. 컴퓨터에 관리자로 로그인합니다. 그런 다음 시스템 복원 복원 완료 페이지에서 확인을 클릭합니다. 컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인 메시지가 표시됩니다.

시스템 복원을 사용했지만 여전히 문제가 발생하거나 다른 문제가 발생하는 경우 복원 작업을 실행 취소할 수 있습니다. 작업을 실행 취소한 후 다른 복원 지점을 사용해 볼 수 있습니다. 시스템 복원 작업을 실행 취소하려면 다음 단계를 따릅니다.

  1. 시작을 클릭하고 모든 프로그램, 보조프로그램, 시스템 도구를 차례로 클릭한 다음 시스템 복원을 클릭합니다.
  2. 시스템 복원 실행 취소를 클릭한 다음 다음을 클릭합니다.
  3. 선택을 검토한 다음 완료를 클릭합니다.

컴퓨터가 다시 시작됩니다. 프로세스가 완료되면 확인 메시지가 표시됩니다.

추가 리소스

문제가 해결되었는지 확인합니다. 문제가 해결된 경우 이 문서를 더 이상 읽을 필요가 없습니다. 문제가 해결되지 않은 경우 Microsoft 고객 지원 서비스를 사용하여 다른 솔루션을 찾을 수도 있습니다. Microsoft 지원 서비스에는 다음 방법이 포함됩니다.

  • Microsoft 기술 자료 검색: Microsoft 제품의 기술 지원 정보와 자가 진단 도구를 검색할 수 있습니다.
  • 솔루션 센터: 제품별,자주 묻는 질문과 대답 및 지원 사항을 봅니다.
  • Microsoft 커뮤니티: 해당 사용자, 동료 및 MICROSOFT MVP(Most Valuable Professionals)에 문의하세요.
  • 기타 지원 옵션: 질문을 하거나 Microsoft 기술 지원 서비스에 문의하거나 의견을 제공하세요.