No se puede conectar a Windows mediante Servicios para Windows CE

Seleccione idioma Seleccione idioma
Cerrar Cerrar
Id. de artículo: 176047 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E176047
Expandir todo | Contraer todo

En esta página

Síntomas

Si utiliza Servicios para Microsoft Windows CE (o el Explorador de H/PC de Microsoft para Windows CE versión 1.0) en Windows NT, quizás no pueda establecer una conexión con su PC de mano (H/PC). Puede recibir uno de los mensajes de error siguientes en el H/PC:

El servicio remoto no se inició

No es posible iniciar algunos servicios críticos
También puede recibir el siguiente mensaje de error en su PC de escritorio en el que se ejecuta Windows NT:
Error al iniciar el servicio remoto

Causa

Este comportamiento puede aparecer si la dirección del Protocolo de control de transporte/Protocolo Internet (TCP/IP) para el H/PC no está en la Tabla de direcciones local (LAT) del servidor proxy de Winsock.

Solución

Para resolverlo, siga estos pasos:

  1. En su PC de escritorio, inicie el Administrador de servicios Internet (ISM).
  2. Configure el servicio Winsock.
  3. Seleccione Servicio, a continuación, Tabla de direcciones locales y agregue las direcciones del H/PC (de manera predeterminada, son 192.168.55.100 y 192.168.55.101).
  4. Detenga y vuelva a iniciar los servicios WWW y Winsock.
  5. Haga clic en Inicio, seleccione Configuración, Panel de control y haga doble clic en Cliente WSP. Haga clic en Actualizar ahora y después en Aceptar.
  6. Reinicie el equipo cliente.
Para evitar este comportamiento, quite el cliente proxy Winsock de su PC de escritorio.

Más información

Los dispositivos móviles se comunican con el H/PC y P/PC mediante TCP. Durante la instalación de Servicios para Windows CE se instalan el Servicio de acceso remoto (RAS) de Microsoft Windows NT o la compatibilidad con el Acceso telefónico a redes (DUN) de Windows 95 ó 98, y se les asigna el intervalo de direcciones IP (Protocolo Internet) estáticas entre 192.168.55.100 y 192.168.55.102.

Cuando el H/PC o P/PC está acoplado, se conecta al servidor RAS o al cliente DUN y se le asigna la dirección IP 192.168.55.101. A continuación, el H/PC o P/PC establece una conexión TCP con Dispositivos móviles para iniciar la sesión. Después, ActiveSync establece una conexión TCP con el H/PC o P/PC para realizar la transferencia de datos real.

Si se instala el cliente proxy Winsock y no se especifica el intervalo de direcciones IP entre 192.168.55.100 y 192.168.55.102 en la LAT local, Servicios para Windows CE no puede establecer la conexión de nuevo con el H/PC o P/PC. En su lugar, prepara una conexión de canal de control con el servidor proxy Winsock e intenta alcanzar el H/PC o P/PC en la red externa del servidor proxy. Este comportamiento es una característica del diseño del proxy WinSock.

Para permitir que ActiveSync se comunique con el H/PC o P/PC mediante el servidor de RAS local, simplemente agregue el intervalo de direcciones IP 192.168.55.100 a 192.168.55.102 al LAT local en el equipo cliente.

Crear un archivo LAT (Tabla de direcciones locales) cliente

Cuando ejecuta el programa de instalación del cliente, se instala en la carpeta Mspclnt del equipo cliente un archivo con el nombre Msplat.txt. El archivo Msplat.txt contiene la LAT que define las direcciones IP de su red interna. Para que la información de los archivos LAT esté actualizada, el archivo Msplat.txt se actualiza periódicamente desde el servidor. Cada vez que un programa Winsock de ese cliente intenta establecer una conexión a una dirección IP, se utiliza la LAT para determinar si la dirección IP es externa o está en la red interna. Si la dirección es interna, la conexión se realiza directamente. Si la dirección es externa, la conexión se establece utilizando el servicio proxy Winsock en Microsoft Proxy Server.

En algunas situaciones, es posible que la tabla de LAT descargada por el servidor no defina completamente algunas direcciones de la red interna a las que un cliente particular podría necesitar tener acceso. Como el archivo Msplat.txt de cada cliente se sobrescribe de forma periódica por una versión actualizada descargada desde el servidor, cualquier cambio que haga en el cliente se perderá cada vez que el servidor actualice el archivo.

Para evitar este comportamiento, use un editor de texto para crear un archivo LAT personalizado para el cliente, llamado Locallat.txt, y póngalo en la carpeta Mspclnt del cliente. Puede agregar intervalos de direcciones IP adicionales para que el cliente las reconozca como parte de la red interna. El cliente usa los archivos Msplat.txt y Locallat.txt para determinar qué direcciones IP forman parte de la red interna y cuáles están en Internet.

En el archivo Locallat.txt debe incluir parejas de direcciones IP. Cada pareja de direcciones define un intervalo de direcciones IP o una única dirección IP. El siguiente ejemplo muestra un archivo Locallat.txt que tiene dos entradas. Las entradas de la columna izquierda son un intervalo de direcciones IP y las de la columna derecha corresponden a una única dirección IP.
+-------------------------------+
| 10.51.0.0     | 10.52.144.103 | 
+-------------------------------+
| 10.51.255.255 | 10.52.144.103 | 
+-------------------------------+
NOTA: la segunda entrada es una dirección IP y no una máscara de subred. Para obtener más información acerca de la LAT, consulte el tema "Acerca de la LAT" en la sección "Instalar el software de servidor" de la documentación de Microsoft Proxy Server.

Propiedades

Id. de artículo: 176047 - Última revisión: martes, 13 de enero de 2004 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Windows NT 4.0
  • Microsoft Windows CE 2.0 for the Handheld PC
  • Microsoft Windows CE 3.0 para Handheld PC Professional Edition
  • Microsoft Windows CE Services 2.0
  • Microsoft Windows CE Services 2.1
  • Microsoft Windows CE Services 2.2
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Palabras clave: 
kbenv kbnetwork kbprb KB176047

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com