WD98: Troubleshooting Damaged Documents in Word 98 for Macintosh

Article translations Article translations
Article ID: 176050 - View products that this article applies to.
This article was previously published under Q176050
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Summary

This article provides troubleshooting procedures you can use to identify, recover, or prevent damage in Microsoft Word for the Macintosh documents.

Damaged document files can cause any program to exhibit unusual behavior. Such behavior occurs because the program attempts to make decisions about what to do next, based on incorrect information in the damaged document.

More information

Identifying a Damaged Document

Damaged documents often exhibit behavior that is not part of the program design (for example, infinite repagination, incorrect document layout and formatting, unreadable characters on the screen, error messages during processing, system hangs or crashes when you load or view the file, or any other unusual behavior that cannot be attributed to the normal operation of the program). These behaviors can be caused by factors other than document damage. To rule out other factors, follow these troubleshooting steps:
  • Check for similar behavior in other documents.
  • Check for similar behavior in other programs.
  • Take the file in question to another computer and attempt to duplicate the behavior.
  • Use a different printer driver and attempt to duplicate the behavior.
  • Rename any templates attached to the document and attempt to duplicate the behavior.
  • Start the computer again with extensions off to disable any third-party programs that are running (such as terminate-and-stay-resident programs [TSRs], font managers, and screen savers), and then attempt to duplicate the behavior.
If the problem occurs only with a single document after performing these steps, your document is probably damaged.

Correcting a Damaged Document

There are several techniques you can use to try to correct a damaged document. Which method you use depends on the nature and severity of the damage and the nature of the behavior exhibited. Although many of these methods succeed regularly, not every damaged document can be recovered. Keeping a backup copy of a document is the best way to ensure its recovery.

Convert the File to Another Format

Convert the file to another format, and then convert it back to its native format.

This is the easiest and most complete document recovery method; always try it first. Save the file in Rich Text Format (RTF) file format; this format preserves the formatting in your Microsoft Word for the Macintosh document. After you save the file in RTF format, reopen the document in Word, and convert it from RTF. If this method succeeds, the file damage is removed during conversion.

To save the file as RTF, follow these steps:
  1. On the File menu, click Save As.
  2. In the Save File as Type list, select Rich Text Format
If the damage persists after you save the file in RTF file format, try saving the file in the following file formats:
  • Other word processing formats
  • Text Only
NOTE: Saving a file in Text Only format frequently corrects the document damage problem; however, all document formatting is lost including graphics and field codes in Word 98 Macintosh Edition. This method requires more reformatting; therefore, use it only after other file formats fail to correct the problem.

For information about loss of Visual Basic for Applications code in Word 98 articles that are converted to other file formats, click the article number below to view the article in the Microsoft Knowledge Base:
184153 WD98: VBA Code Lost After Converting to Another Document Format

Use the AutoRecover Feature in Word

The AutoRecover feature in Word will attempt to automatically recover text from a document that was open when Word stopped responding. When you restart Word after it stops responding (hangs), a dialog box will be displayed with the following message:
Word encountered file damage while opening FILE NAME. Part of this document may be recoverable. Attempt Recovery Now?
NOTE: This recovery may take some time depending on the size of the document and the amount of damage in the document.

After the document has been recovered, immediately use the Save As command on the File menu to save the document with a new file name. This will ensure that the original document will be available for other recovery attempts. This automatic recovery method strips all formatting, graphics, and objects from the document. Other methods, listed below, may allow you to recover more of your original formatting and so on from the damaged document.

For more information about the AutoRecover feature, see the "Prevent loss of Word and Recover Lost Documents" topic in Word Help.

Open the Damaged Word Document in Draft Mode

Open the damaged Word document in draft mode. Sometimes (not always, due to the nature of damaged documents) you can open a document successfully in draft mode when it will not open in other views. After you open the file, you may be able to recover or repair the file.

To switch to draft mode in Word, follow these steps:
  1. On the View menu, click Normal.
  2. On the Tools menu, click Preferences.
  3. Click the View tab.
  4. Click to select the Draft Font check box.

Copy Everything Except the Last Paragraph Mark to a New Document

Word associates a wide variety of formatting with the last paragraph mark, especially section and style formatting. If you copy everything except the last paragraph mark to a new document, the damage may be left behind in the original document. In the new document, reapply the section or style formatting.

NOTE: You can select everything except the last paragraph mark by pressing COMMAND+END, and then COMMAND+SHIFT+HOME.

Copy the Undamaged Portions of the Document to a New Document

Sometimes you can determine the location of file damage in your document. In this case, copy everything except the damaged portion to a new file, and follow these steps to reconstruct your document:
  1. Copy the undamaged portions of your document and paste them into a new file (you may not want to select the final paragraph mark of this selection because that paragraph mark may hold some incorrect information).
  2. Save a copy of the damaged document in Text-Only format.
  3. Open the Text-Only file.
  4. Copy the text from this file and paste it into the file that contains the undamaged portion of your document.
  5. Reformat the sections of the document you pasted in step 4, and then save the recovered document.

Insert the File into a Blank Document

If you cannot open a file to copy all text except the final paragraph mark, you may be able to insert the file into a new document (which will give a new final paragraph mark to the file you are correcting). To do this, follow these steps:
  1. Create a new document based on the Normal template.
  2. On the Insert menu, click File. Select the damaged document and click OK.

Use the Paste Link Command to Open the Document via a Link

This method uses a "dummy" document to create a link and then switches the link between the "dummy" document and the damaged document.

Follow these steps to use a Paste Link operation to open a damaged document:
  1. Close all open documents in Word, and then open a new blank document.
  2. Type Test.
  3. Select the word Test. On the Edit menu, click Copy.
  4. On the File menu, click New and open a new blank document.
  5. On the Edit menu, click Paste Special. In the Paste Special dialog box, click Paste Link. In the As box, click Formatted Text (RTF), and then click OK.
  6. On the Edit menu, click Links.
  7. In the Links dialog box, click Change Source. In the Open dialog box, locate and select the document that you want to recover. Click Open and then click OK.
  8. When the document opens, click Save As on the File menu. Type a new name for the document, and then click Save.
  9. With the document open, click Links on the Edit menu.
  10. In the Links dialog box, click Break Links. In the dialog box that appears, click Yes to break the link.

NOTE: After the link is broken, you should save the document before you close it or modify it.

Open the File Using "Recover Text From Any File"

As a last resort, this special converter can be used to manually open damaged documents. Using this converter removes all formatting, graphics, and embedded objects from the file. It strips everything from the file except readable text (ASCII characters). Because of the way Word document files are organized and saved, the text may be disjointed or duplicated. With even the simplest files, there will be lots of reformatting required. With smaller files it is often desirable to open a new second document and copy and paste text from the recovered document to the new document because there is so much unwanted text recovered.

To use the "Recover Text From Any File" converter to open a document, follow these steps:
  1. On the File menu, click Open.
  2. In the List Files of Type list, click Recover Text from Any File.
  3. Locate the folder that contains the damaged file and select the file.
  4. Click Open.

    NOTE: The recovery process may take some time depending on the size of the document and the type of damage. As soon as the recovery is complete, click Open on the File menu and change List Files of Type back to Word Documents or Readable Files.

    TIP: Save the recovered file with a new name at this point. This will keep you from accidentally overwriting the original document and will ensure that the original document will still be available for other recovery attempts.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
87856 WD97: Troubleshooting Damaged Documents in Word for Windows

Properties

Article ID: 176050 - Last Review: October 26, 2013 - Revision: 3.0
Applies to
  • Microsoft Word 98 for Macintosh
Keywords: 
kbnosurvey kbarchive kbhowto KB176050

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com