WD98: Odstraňování poškozené dokumenty Word 98 pro Macintosh

Překlady článku Překlady článku
ID článku: 176050 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Tento článek obsahuje postupy odstranění potíží, můžete použít k identifikaci, obnovit nebo zabránit poškození v aplikaci Word pro Macintosh dokumenty.

Poškozené soubory dokumentů mohou způsobit neobvyklé chování jakéhokoli programu. Takové chování dochází, protože program se pokusí rozhodování o dalším postupu na základě nesprávné informace poškozený dokument.

Další informace

Identifikace poškozeného dokumentu

Poškozených dokumentů se často projevuje chování, které není součástí návrhu programu (například infinite přestránkování, nesprávné dokumentu rozložení a formátování, nečitelné znaky na obrazovce, chybové zprávy během zpracování, zablokuje systém nebo selhání při načtení nebo zobrazení souboru nebo jakékoli jiné neobvyklé chování, které nelze považovat za normální operace program). Tyto chování mohou být způsobeny jinými faktory než poškozením dokumentu. Chcete-li vyloučit jiné faktory, postupujte takto řešení potíží:
  • Zkontrolujte podobné chování v jiných dokumentech.
  • Zkontrolujte podobné chování v jiných aplikacích.
  • Převzít dotyčný soubor do jiného počítače a pokuste se chování duplikovat.
  • Použijte jiný ovladač tiskárny a pokuste se chování duplikovat.
  • Přejmenujte všechny šablony připojené k dokumentu a pokuste se chování duplikovat.
  • Spusťte počítač znovu s příponami zakázat všechny programy jiných výrobců systémem (například terminate-and-stay-resident programy [TSR], správci písem a spořiče obrazovky) a pokuste chování duplikovat.
Pokud problém nastane, pouze s jediného dokumentu po provedení těchto kroků, dokument pravděpodobně poškozen.

Oprava poškozeného dokumentu

Můžete se pokusit opravit poškozený dokument několika způsoby. Jaký způsob použijete, závisí na charakteru a závažnosti poškození a povaze chování exhibited. I když je řada z těchto metod obvykle úspěšná, nelze obnovit každý poškozený dokument. Udržování záložní kopii dokumentu je nejlepším způsobem, jak zajistit jeho obnovení.

Převést soubor do jiného formátu

Převést soubor do jiného formátu a převést jej zpět do nativní formát.

Toto je dokument nejjednodušší a nejúplnější metodu obnovení; vždy vyzkoušejte nejprve. Uložte soubor ve formátu RTF (RICH Text Format); Tento formát zachovává formátování v aplikaci Word pro Macintosh dokumentu. Po uložení souboru ve formátu RTF v aplikaci Word znovu otevřete a převést z RTF. Pokud tato metoda úspěšná, poškození souboru odebrána během převodu.

Uložte soubor jako RTF, postupujte takto:
  1. V nabídce soubor klepněte na příkaz Uložit jako.
  2. Vyberte v seznamu Souboru typuRTF
Jestliže poškození potrvá po uložení souboru ve formátu souboru RTF, zkuste uložit soubor v následujících formátech:
  • Jiné formáty zpracování textu
  • Text pouze
Poznámka: uložení souboru ve formátu pouze text často opraví problém poškození dokumentu; veškeré formátování dokumentu je však ztraceny, včetně grafiky a pole kódy Word 98 Macintosh Edition. Tato metoda vyžaduje další přeformátování; jej proto použít pouze po jiných formátů souborů nezdaří opravit problém.

Informace o ztrátě jazyka pro kód aplikace v článcích Word 98 jsou převedeny do jiných formátů souborů klepněte na článek číslo článku databáze Microsoft Knowledge Base:
184153WD98: Ztracené po převodu na jiný formát dokumentu kódu VBA

Pomocí obnovení v aplikaci Word

Funkce automatického obnovení v aplikaci Word pokusí automaticky obnovit text z dokumentu, který byl při Word přestal reagovat. Po restartování aplikace Word po přestane reagovat (zablokuje se) dialogové okno zobrazí s následující zpráva:
Při otevírání FILE NAME bylo zjištěno poškození souboru. Část tohoto dokumentu jsou možná obnovitelné. Pokus o obnovení nyní?
Poznámka: Tato zotavení může trvat delší dobu v závislosti na velikosti dokumentu a částka poškození v dokumentu.

Po obnovila dokumentu okamžitě pomocí příkazu Uložit jako v nabídce soubor uložte dokument pod novým názvem souboru. Tím bude zajištěno, že bude k dispozici pro další pokusy o obnovení původní dokument. Tato metoda automatické zotavení Odříznout všechny formátování, grafiky a objekty z dokumentu. Jiné metody uvedeny níže, může povolit více původní formátování atd z poškozený dokument obnovit.

Další informace o funkci automatického obnovení naleznete v tématu "Zabránit ztrátě Word a obnovení ztracené dokumenty" v nápovědě aplikace Word.

Otevření dokumentu aplikace Word poškození v režimu Koncept

Otevřete poškozený dokument aplikace Word v konceptovém režimu. Někdy (ne vždy kvůli povahy poškozených dokumentů) můžete otevřít dokument úspěšně v režimu konceptu při neotevře v jiných zobrazeních. Po otevření souboru bude možné obnovit nebo opravit soubor.

Chcete-li přepnout do režimu konceptu v aplikaci Word, postupujte takto:
  1. V nabídce Zobrazit klepněte na možnost Normální.
  2. V nabídce Nástroje klepněte na příkaz Předvolby.
  3. Klepněte na kartu zobrazení.
  4. Klepnutím zaškrtněte políčko Písmo konceptu.

Kopírování veškerého obsahu kromě posledního znaku konce odstavce do nového dokumentu

Word přidružuje širokou škálu formátování poslední značku odstavce zejména oddílu a formátování stylu. Jestliže zkopírujete veškerý obsah kromě posledního znaku konce odstavce do nového dokumentu, může být poškození ponecháno v původním dokumentu. V novém dokumentu znovu použijte oddílu nebo formátování stylu.

Poznámka: můžete vybrat vše kromě poslední značku odstavce stisknutím kláves COMMAND + END a COMMAND + SHIFT + HOME.

Kopírování nepoškozených částí dokumentu do nového dokumentu

Někdy můžete určit umístění poškození souboru přímo v dokumentu. V tomto případě zkopírujte vše kromě poškozené části nový soubor a postupujte následujícím způsobem k rekonstrukci dokumentu:
  1. Zkopírujte nepoškozeného částí dokumentu a vložit do nového souboru (pravděpodobně není chcete vybrat značku konečného odstavce tento výběr, protože dané odstavce může pojmout některé nesprávné informace).
  2. Uložit kopii poškozeného dokumentu ve formátu pouze text.
  3. Otevřete soubor pouze text.
  4. Zkopírujte text z tohoto souboru a vložte do souboru, který obsahuje nepoškozenou část dokumentu.
  5. Přeformátovat oddíly dokumentu jste vložili v kroku 4 a uložit obnovený dokument.

Vložit soubor do prázdného dokumentu

Pokud nelze otevřít soubor zkopírovat veškerý text s výjimkou poslední znak konce odstavce, pravděpodobně vložení souboru do nového dokumentu (která bude umožňovat nové konečné odstavce opravované souboru). Postupujte takto:
  1. Vytvořit nový dokument založený na šabloně Normal.
  2. V nabídce Vložit klepněte na soubor. Vyberte poškozený dokument a klepněte na tlačítko OK.

Otevření dokumentu prostřednictvím odkaz použijte příkaz Vložit propojení

Tato metoda používá k vytvoření propojení "fiktivní" dokumentu a přepne propojení mezi "fiktivní" dokumentu a poškozený dokument.

Takto operace Vložit propojení použít k otevření poškozeného dokumentu:
  1. Zavřete všechny otevřené dokumenty v aplikaci Word a otevřete nový prázdný dokument.
  2. Typ Test.
  3. Vyberte slovo Test. V nabídce Úpravy klepněte na tlačítko Kopírovat.
  4. V nabídce soubor klepněte na příkaz Nový a otevřete nový prázdný dokument.
  5. V nabídce Úpravy klepněte na příkaz Vložit jinak. V dialogovém okně Vložit jinak klepněte na příkaz Vložit propojení. V poli Typ klepněte na položku Formátovaný Text (RTF) a klepněte na tlačítko OK.
  6. V nabídce Úpravy příkaz propojení.
  7. V dialogovém okně propojení klepněte na tlačítko Změnit zdroj. V dialogovém okně Otevřít vyhledejte a vyberte dokument, který chcete obnovit. Klepněte na tlačítko Otevřít a potom klepněte na tlačítko OK.
  8. Po otevření dokumentu klepněte v nabídce soubor na příkaz Uložit jako. Zadejte nový název dokumentu a potom klepněte na tlačítko Uložit.
  9. Otevření dokumentu v nabídce Úpravy klepněte na příkaz propojení.
  10. V dialogovém okně propojení klepněte na příkaz Zrušit propojení. V dialogovém okně, které se zobrazí klepněte na tlačítko Ano přerušit propojení.

Poznámka: Po propojení přerušeno, měli byste uložit dokument před jej zavřít nebo ji upravit.

Otevřít soubor použití "Obnovení textu z libovolného souboru"

Jako poslední možnost lze tento zvláštní převaděč ručně otevírání poškozených dokumentů. Pomocí tohoto převaděče odebere všechny formátování, grafiky a vložené objekty ze souboru. Odříznout vše ze souboru s výjimkou čitelného textu (znaky ASCII). Z důvodu způsobu jsou uspořádány a uloženy soubory dokumentů aplikace Word může být text disjointed nebo duplikovány. S dokonce nejjednodušší soubory bude mnoho přeformátování požadována. S menší soubory je často žádoucí otevřete nový druhý dokument a zkopírovat a vložit text ze obnovený dokument nového dokumentu, protože je tedy mnohem nežádoucí text obnovit.

Použít převaděč "Obnovení textu z libovolného souboru" otevření dokumentu, postupujte takto:
  1. V nabídce soubor klepněte na tlačítko Otevřít.
  2. V seznamu Zobrazit soubory typu klepněte Obnovení textu z libovolného souboru.
  3. Vyhledejte složku obsahující poškozený soubor a vyberte soubor.
  4. Klepněte na tlačítko Otevřít.

    Poznámka: obnovení proces může trvat delší dobu v závislosti na velikosti dokumentu a typ poškození. Ihned po dokončení obnovení je v nabídce soubor klepněte na tlačítko Otevřít a Zobrazit soubory typu změnit zpět na Dokumenty Word nebo Vyjádření soubory.

    TIP: v tomto okamžiku uložit obnovený soubor s novým názvem. Tato zabránit v náhodnému přepsání původního dokumentu a zajistíte, že původní dokument bude stále k dispozici pro další pokusy o zotavení.
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
87856WD97: Odstraňování poškozené dokumenty Word pro Windows

Vlastnosti

ID článku: 176050 - Poslední aktualizace: 29. ledna 2014 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Word 98 pro počítače Macintosh
Klíčová slova: 
kbnosurvey kbarchive kbmt kbfaq kbhowto KB176050 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:176050

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com