WD98: Troubleshooting dañado documentos en Word 98 para Macintosh

Seleccione idioma Seleccione idioma
Id. de artículo: 176050 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo proporcionan procedimientos de solución de problemas que puede usar para identificar, recuperar o evitar daños en Microsoft Word para los documentos de Macintosh.

Los archivos de documentos dañados pueden causar que cualquier programa muestre un comportamiento inusual. Este comportamiento se produce porque el programa intenta tomar decisiones sobre qué hacer a continuación, basándose en el documento dañado información incorrecta.

Más información

Identificar un documento dañado

Documentos dañados a menudo exhiben un comportamiento que no forma parte del diseño del programa (por ejemplo, repaginación infinita, diseño de documento incorrecto y formato, caracteres ilegibles en la pantalla, mensajes de error durante el procesamiento, bloqueos del sistema o se bloquea cuando intenta carga o ver el archivo o cualquier otro comportamiento inusual que no atribuible al funcionamiento normal del programa). Estos comportamientos pueden deberse a factores distintos de un documento dañado. Para descartar otros factores, siga estos pasos:
  • Compruebe si se produce un comportamiento parecido en otros documentos.
  • Compruebe si se produce un comportamiento parecido en otros programas.
  • Llevar el archivo en cuestión a otro equipo e intentar duplicar el comportamiento.
  • Utilice un controlador de impresora diferente e intente repetir el comportamiento.
  • Cambiar el nombre cualquier plantilla adjuntada al documento e intentar duplicar el comportamiento.
  • Inicie el equipo nuevo con las extensiones para deshabilitar los programas de terceros están ejecutando (como programas terminate-and-stay-resident [TSR], administradores de fuentes y los protectores de pantalla) y, a continuación, intente duplicar el comportamiento.
Si el problema se produce sólo con un solo documento después de realizar estos pasos, probablemente está dañado el documento.

Corregir un documento dañado

Hay varias técnicas que puede utilizar para intentar corregir un documento dañado. El método que use depende de la naturaleza y gravedad del daño y la naturaleza del comportamiento demostrado. Aunque muchos de estos métodos correctamente con regularidad, no todos los documentos dañados pueden recuperarse. Mantener una copia de un documento es la mejor forma para garantizar su recuperación.

Convertir el archivo a otro formato

Convierta el archivo a otro formato y, a continuación, volver a convertir su formato nativo.

Este es el método de recuperación de documentos fácil y más completa; siempre pruebe primero. Guarde el archivo en formato de archivo de texto enriquecido (RTF); este formato conserva el formato en su Microsoft Word para el documento de Macintosh. Después de guardar el archivo en formato RTF, vuelva a abrir el documento de Word y convertirlo de RTF. Si este método se realiza correctamente, se quita el daño del archivo durante la conversión.

Para guardar el archivo como RTF, siga estos pasos:
  1. En el menú archivo , haga clic en Guardar como .
  2. en la lista Guardar archivo como tipo , seleccione texto enriquecido
Si el daño persiste después de guardar el archivo en formato de archivo RTF, intente guardar el archivo en los siguientes formatos de archivo:
  • Otros formatos de procesamiento de textos
  • Sólo texto
Nota : guardar un archivo en formato de sólo texto con frecuencia corrige el problema de daños de documento; sin embargo, todo el formato documento es pierde incluidos códigos de campo y de gráficos en Word 98 Macintosh Edition. Este método requiere dar más formato; por lo tanto, utilícelo sólo cuando otros formatos de archivo no consigan corregir el problema.

Para obtener información sobre la pérdida de Visual Basic para aplicaciones el código de artículos de Word 98 se convierten en otros formatos de archivo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
184153WD98: Código VBA pierden tras convertir a otro formato de documento

Utilizar la función Autorrecuperación de Word

La característica de Autorrecuperación de Word intentará recuperar automáticamente el texto de un documento que estaba abierto cuando Word ha dejado de responder. Cuando reinicie Word después de deje de responder (se bloquea), se mostrará un cuadro de diálogo con el siguiente mensaje:
Word encontró daños en archivos al abrir el FILE NAME. Parte de este documento podría recuperarse. ¿Desea intentar la recuperación ahora?
Nota : esta recuperación puede tardar en función del tamaño del documento y la cantidad de daños en el documento.

Después de que se ha recuperado el documento, inmediatamente utilizar el comando Guardar como en el menú archivo para guardar el documento con un nuevo nombre de archivo. Esto asegurará que el documento original estarán disponible para otros intentos de recuperación. Este método de recuperación automática quita todo el formato, gráficos y objetos del documento. Otros métodos, que se enumeran a continuación, pueden permitirle recuperar más de su formato original y así sucesivamente del documento dañado.

Para obtener más información acerca de la característica Autorrecuperación, vea el tema "Impedir la pérdida de Word y recuperar documentos pierden" en la Ayuda de Word.

Abrir documento de Word dañado en modo de borrador

Abra el documento de Word dañado en modo borrador. A veces (no siempre, debido a la naturaleza de documentos dañados) puede abrir un documento correctamente en modo borrador cuando no se abre en otras vistas. Después de abrir el archivo, quizás pueda recuperar o reparar el archivo.

Para cambiar a modo de borrador en Word, siga estos pasos:
  1. En el menú Ver , haga clic en normal .
  2. En el menú Herramientas , haga clic en Preferencias .
  3. Haga clic en la ficha Ver .
  4. Haga clic para seleccionar la casilla de verificación Fuente de borrador .

Copiar todo excepto la última marca de párrafo en un documento nuevo

Word asocia una amplia variedad de formatos con la última marca de párrafo, especialmente el formato de secciones y estilos. Si copia todo, excepto la última marca de párrafo, en un nuevo documento, es posible que el daño se quede en el documento original. En el nuevo documento, vuelva a aplicar el formato de secciones y estilos.

Nota : puede seleccionar todo excepto la última marca de párrafo presionando CTRL + fin y, a continuación, CTRL + MAYÚS + inicio.

copiar las partes no dañadas del documento en un nuevo documento

En ocasiones puede determinar la ubicación del daño del archivo en el documento. En este caso, copie todo excepto la parte dañada a un archivo nuevo y siga estos pasos para reconstruir el documento:
  1. Copiar las partes no dañadas del documento y pegarlos en un archivo nuevo (que es posible que no desea seleccionar la marca de párrafo final de esta selección porque dicha marca de párrafo puede contener información incorrecta).
  2. Guardar una copia del documento dañado en formato sólo texto.
  3. Abra el archivo de sólo texto.
  4. Copie el texto de este archivo y pegue en el archivo que contiene la parte ilesa del documento.
  5. Volver a formatear las secciones del documento que pegó en el paso 4 y, a continuación, guarde el documento recuperado.

Insertar el archivo en un documento en blanco

Si no puede abrir un archivo para copiar texto todo excepto la marca de párrafo final, puede insertar el archivo en un documento nuevo (lo que proporcionará una nueva marca de párrafo final en el archivo que está corrigiendo). Para ello, siga estos pasos:
  1. Crear un documento nuevo basado en la plantilla Normal.
  2. En el menú Insertar , haga clic en archivo . Seleccione el documento dañado y haga clic en Aceptar .

Utilice el comando de Pegar vínculo para abrir el documento a través de un vínculo

Este método utiliza un documento "ficticio" para crear un vínculo y, a continuación, cambia el vínculo entre el documento "ficticio" y el documento dañado.

Siga estos pasos para usar una operación de Pegar vínculo para abrir un documento dañado:
  1. Cerrar todos los documentos abiertos en Word y, a continuación, abra un nuevo documento en blanco.
  2. Tipo de prueba .
  3. Seleccione la palabra prueba . En el menú Edición , haga clic en Copiar .
  4. En el menú archivo , haga clic en nuevo y abra un nuevo documento en blanco.
  5. En el menú Edición , haga clic en Pegado especial . En el cuadro de diálogo Pegado especial , haga clic en Pegar vínculo . En el cuadro como , haga clic en Texto con formato (RTF) y, a continuación, haga clic en Aceptar .
  6. En el menú Edición , haga clic en vínculos .
  7. En el cuadro de diálogo vínculos , haga clic en Cambiar origen . En el cuadro de diálogo Abrir , busque y seleccione el documento que desea recuperar. Haga clic en Abrir y haga clic en Aceptar .
  8. Cuando se abre el documento, haga clic en Guardar como en el menú archivo . Escriba un nombre nuevo para el documento y, a continuación, haga clic en Guardar .
  9. Con el documento abierto, haga clic en vínculos en el menú Edición .
  10. En el cuadro de diálogo vínculos , haga clic en Interrumpir vínculos . En el cuadro de diálogo que aparece, haga clic en para romper el vínculo.

Nota : después de que se rompe el vínculo, debe guardar el documento antes de cerrarla o modificarlo.

Abrir el archivo con "Recuperar texto de cualquier archivo"

Como último recurso, puede utilizarse este convertidor especial para abrir manualmente documentos dañados. Con este convertidor quita todo el formato, gráficos y objetos incrustados del archivo. Elimina todo, desde el archivo excepto texto legible (caracteres ASCII). Debido de los archivos de documento de Word se organizan y se guardan, el texto puede ser inconexos o duplicado. Incluso los archivos más sencilla, habrá mucha volver a dar formato requerido. Con archivos más pequeños suele ser deseable para abrir un nuevo documento de segundo y la copia y pega texto desde el documento recuperado en el documento nuevo porque no hay mucho texto no deseado recuperado.

Para utilizar el convertidor "Recuperar texto de cualquier archivo" para abrir un documento, siga estos pasos:
  1. En el menú archivo , haga clic en Abrir .
  2. En la lista Mostrar archivos de tipo , haga clic en Recuperar texto de cualquier archivo.
  3. Busque la carpeta que contiene el archivo dañado y seleccione el archivo.
  4. Haga clic en Abrir .

    Nota : el proceso de recuperación puede tardar un poco en función del tamaño del documento y el tipo de daño. Tan pronto como la recuperación se complete, haga clic en Abrir en el menú archivo y cambie la Lista Tipo de a Documentos de Word o de Lectura de archivos .

    TIP : guardar el archivo recuperado con un nombre nuevo en este momento. Esto evitará que se sobrescriba accidentalmente el documento original y se Asegúrese de que el documento original seguirá estando disponible para otros intentos de recuperación.
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
87856WD97: Troubleshooting dañado documentos en Word para Windows

Propiedades

Id. de artículo: 176050 - Última revisión: jueves, 23 de enero de 2014 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Word 98 para Macintosh
Palabras clave: 
kbnosurvey kbarchive kbmt kbfaq kbhowto KB176050 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 176050

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com