WD98 : Dépannage des documents endommagés dans Word 98 pour Macintosh

Traductions disponibles Traductions disponibles
Numéro d'article: 176050 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F176050
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article présente des procédures de dépannage qui vous permettent d'identifier, de récupérer et d'éviter un problème dans Microsoft Word pour les documents Macintosh.

Des fichiers de documents endommagés peuvent provoquer un comportement anormal dans un programme. Un tel comportement s'explique par le fait que le programme tente de prendre une décision sur l'action à mener ensuite, en se basant sur des informations incorrectes présentes dans le document endommagé.

Plus d'informations

Identification d'un document endommagé

Les documents endommagés présentent souvent un comportement qui n'est pas dicté par la conception du produit (par exemple, une repagination infinie, une mise en page et une mise en forme incorrectes du document, des caractères illisibles à l'écran, des messages d'erreur pendant le traitement, le système se bloque ou tombe en panne au moment de charger ou d'afficher le fichier, ou tout autre comportement inhabituel ne pouvant pas être attribué au fonctionnement normal du programme). Ces comportements peuvent avoir pour origine des facteurs autres qu'un document endommagé. Pour exclure ces autres facteurs, suivez les procédures de dépannage indiquées ci-après :
  • Recherchez un comportement similaire dans d'autres documents.
  • Recherchez un comportement similaire dans d'autres programmes.
  • Copiez le fichier en question sur un autre ordinateur et essayez de reproduire le comportement suspect.
  • Utilisez un pilote d'imprimante différent et essayez de reproduire le comportement en question.
  • Renommez les modèles attachés au document et essayez de reproduire le comportement suspect.
  • Redémarrez l'ordinateur en désactivant les extensions pour ne pas exécuter les programmes de fournisseurs tiers (comme les programmes TSR résidant en mémoire, les programmes de gestion de polices et les écrans de veille), puis essayez de reproduire le comportement.
Si le problème n'apparaît qu'avec un seul document après avoir exécuté ces étapes, il est fort probable que votre document est endommagé.

Correction d'un document endommagé

Plusieurs techniques sont disponibles pour tenter de corriger un document endommagé. La méthode à utiliser dépend de la nature et de l'importance du problème, ainsi que de la nature du comportement affiché. Bien que plusieurs de ces méthodes donnent des résultats satisfaisants, tous les documents endommagés ne peuvent pas forcément être récupérés. Le meilleur moyen de garantir la récupération d'un document est d'en conserver une copie de sauvegarde.

Conversion du fichier dans un autre format

Convertissez le fichier dans un autre format, puis convertissez-le à nouveau dans son format d'origine.

Cette procédure représente la manière la plus simple et la plus complète de récupérer un document ; elle doit toujours être tentée avant toute autre méthode. Enregistrez le fichier au format RTF (Rich Text Format) ; ce format conserve la mise en forme de votre document Microsoft Word pour Macintosh. Une fois le fichier enregistré au format RTF, rouvrez le document dans Word et convertissez-le à partir du format RTF. Si cette méthode réussit, la conversion permet alors de supprimer le problème du fichier.

Pour enregistrer le fichier au format RTF, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Enregistrer sous.
  2. Dans la liste Type du fichier , sélectionnez Texte mis en forme.
Si le problème persiste après avoir enregistré le fichier au format RTF, essayez d'enregistrer le fichier dans les formats de fichier suivants :
  • Formats d'autres traitements de texte
  • Texte seulement
REMARQUE : L'enregistrement d'un fichier au format Texte seulement suffit souvent à corriger le problème du document endommagé ; toutefois, vous perdez toute la mise en forme du document, notamment les éléments graphiques et les codes de champ dans Word 98 Édition Macintosh. Cette méthode nécessite une remise en forme, et ne doit donc être utilisée que si les autres formats de fichier proposés n'ont pas pu résoudre le problème.

Pour plus d'informations sur la perte du code VBA (Visual Basic pour Applications) dans des articles Word 98 qui sont convertis dans d'autres formats de fichier, cliquez sur le numéro d'article ci-après pour afficher l'article de la Base de connaissance Microsoft :
184153 WD98 : Perte du code VBA après conversion en un autre format de document

Utilisation de la fonction de récupération automatique de Word

La fonction de récupération automatique de Word tentera de récupérer automatiquement un texte à partir d'un document qui était ouvert lorsque Word a cessé de répondre. Lorsque vous redémarrez Word après qu'il a cessé de répondre (blocage), une boîte de dialogue affiche le message suivant :
Erreur de corruption de fichier rencontrée lors de l'ouverture de NOM DU FICHIER. Une partie de ce document peut être récupérée. Souhaitez-vous effectuer la récupération ?
REMARQUE : Cette récupération peut nécessiter un certain temps selon la taille du document et l'étendue des dommages subis par celui-ci.

Une fois le document récupéré, enregistrez immédiatement le document sous un nouveau nom de fichier en utilisant la commande Enregistrer sous du menu Fichier. Le document d'origine sera ainsi disponible pour d'autres tentatives de récupération. Cette méthode de récupération automatique supprime l'ensemble des mises en forme, des graphiques et des objets du document. D'autres méthodes, citées ci-après, peuvent vous permettre de récupérer une plus grande partie de votre mise en forme, etc., d'origine à partir du fichier endommagé.

Pour plus d'informations sur la fonction de récupération automatique, reportez-vous à la rubrique d'aide de Word indiquant comment éviter la perte de documents Word et comment récupérer des documents perdus.

Ouverture du document Word endommagé en mode brouillon

Ouvrez le document Word endommagé en mode brouillon. Parfois (mais pas toujours, en raison de la nature des documents endommagés), il est possible d'ouvrir sans problème un document en mode brouillon lorsqu'il ne s'ouvre pas dans d'autres affichages. Une fois le fichier ouvert, vous êtes alors en mesure de le récupérer ou de le réparer.

Pour passer en mode brouillon dans Word, procédez comme suit :
  1. Cliquez sur Normal dans le menu Affichage.
  2. Dans le menu Outils, cliquez sur Préférences.
  3. Cliquez sur l'onglet Affichage.
  4. Activez la case à cocher Police brouillon.

Copie de l'ensemble du document excepté la dernière marque de paragraphe vers un nouveau document

Word associe un grand nombre d'options de mise en forme à la dernière marque de paragraphe, notamment la mise en forme de style et de section. Si vous copiez tout à l'exception de la dernière marque de paragraphe vers un nouveau document, il est possible que le problème ne soit pas reproduit dans ce dernier. Dans le nouveau document, réappliquez la mise en forme de section ou de style.

REMARQUE : Pour sélectionner tout le document sans la dernière marque de paragraphe, appuyez sur COMMANDE+FIN, puis sur COMMANDE+MAJ+ORIGINE.

Copie des parties intactes du document dans un nouveau document

Il est parfois possible de déterminer l'emplacement exact du problème dans un document endommagé. Dans ce cas, copiez dans un nouveau fichier tout le document à l'exception de la partie endommagée, puis procédez comme suit pour reconstruire votre document :
  1. Copiez les parties intactes de votre document et collez-les dans un nouveau fichier (vous ne souhaitez peut-être pas garder la marque de paragraphe finale de cette sélection, car il est possible que celle-ci contienne des informations incorrectes).
  2. Enregistrez une copie du document endommagé au format Texte seulement.
  3. Ouvrez le fichier texte.
  4. Copiez le texte de ce fichier et collez-le dans le fichier contenant la partie intacte de votre document d'origine.
  5. Rétablissez la mise en forme des sections du document dans lequel vous avez collé le texte à l'étape 4, puis enregistrez le document récupéré.

Insertion du fichier dans un document vide

Si vous ne pouvez pas ouvrir un fichier pour y copier tout le texte à l'exception de la marque de paragraphe finale, vous pouvez peut-être insérer le fichier dans un nouveau document (ce qui donnera une nouvelle marque de paragraphe finale au fichier que vous corrigez). Pour ce faire, procédez comme suit :
  1. Créez un document basé sur le modèle Normal.
  2. Dans le menu Insertion, cliquez sur Fichier. Sélectionnez le document endommagé, cliquez sur OK.

Utilisation de la commande Coller avec liaison pour ouvrir le document par l'intermédiaire d'une liaison

Cette méthode utilise un document "factice" pour créer une liaison, puis commute la liaison entre le document "factice" et le document endommagé.

Les étapes suivantes présentent l'utilisation d'une opération Coller avec liaison pour ouvrir un document endommagé :
  1. Fermez tous les documents ouverts dans Word, puis ouvrez un nouveau document vide.
  2. Tapez Test.
  3. Sélectionnez le mot Test. Dans le menu Edition, cliquez sur Copier.
  4. Dans le menu Fichier, cliquez sur Nouveau, puis ouvrez un nouveau document vide.
  5. Dans le menu Edition, cliquez sur Collage spécial. Dans la boîte de dialogue Collage spécial, cliquez sur Coller avec liaison. Dans la zone En tant que, cliquez sur Texte mis en forme (RTF), puis sur OK.
  6. Dans le menu Edition, cliquez sur Liaisons.
  7. Dans la boîte de dialogue Liaisons, cliquez sur Modifier la source. Dans la boîte de dialogue Ouvrir, recherchez et sélectionnez le document que vous voulez récupérer. Cliquez sur Ouvrir, puis sur OK.
  8. Une fois le document ouvert, dans le menu Fichier, cliquez sur Enregistrer sous. Tapez un nouveau nom pour le document, puis cliquez sur OK.
  9. Le document étant ouvert, dans le menu Edition, cliquez sur Liaisons.
  10. Dans la boîte de dialogue Liaisons, cliquez sur Rompre les liaisons. Dans la boîte de dialogue qui apparaît, cliquez sur Oui pour rompre la liaison.

REMARQUE : Une fois la liaison rompue, il est conseillé d'enregistrer le document avant de le fermer ou de le modifier.

Ouverture du fichier à l'aide du convertisseur de récupération de texte de tout fichier

En dernier recours, ce convertisseur spécial vous permet d'ouvrir manuellement des documents endommagés. L'utilisation de ce convertisseur supprime l'ensemble des mises en forme, graphiques et objets incorporés du fichier. Il retire tout du fichier à l'exception du texte lisible (en caractères ASCII). Du fait de la façon dont les documents Word sont organisés et enregistrés, le texte peut apparaître disjoint ou dupliqué. Même avec les fichiers les plus simples, il faudra prévoir un important travail de remise en forme du document. Avec les fichiers peu volumineux, il est souvent préférable d'ouvrir un deuxième document nouveau et de copier-coller le texte du document récupéré dans ce nouveau document parce qu'il y beaucoup de texte récupéré non voulu.

Pour ouvrir un document Word à l'aide du convertisseur de récupération de texte de tout fichier, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Ouvrir.
  2. Dans la liste Types de fichiers , cliquez sur Récupérer le texte de tout type de fichier.
  3. Localisez le dossier qui contient le fichier endommagé, puis sélectionnez le fichier.
  4. Cliquez sur Ouvrir.

    REMARQUE : Ce processus de récupération peut nécessiter un certain temps selon la taille du document et le type de problème rencontré. Une fois la récupération terminée, dans le menu Fichier, cliquez sur Ouvrir, puis redéfinissez Types de fichiers avec la valeur Documents Word ou Fichiers lisibles.

    CONSEIL : À ce stade, enregistrez le fichier récupéré sous un nouveau nom. Vous éviterez ainsi de remplacer accidentellement le document d'origine qui sera ainsi toujours disponible pour de nouvelles tentatives de récupération.
Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
87856 WD97 : Récupération de documents endommagés dans Word pour Windows

Propriétés

Numéro d'article: 176050 - Dernière mise à jour: mercredi 5 février 2014 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Word 98 for Macintosh
Mots-clés : 
kbnosurvey kbarchive kbdta kbfaq kbhowto macword macword98 KB176050
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com