WD98: Risoluzione dei problemi con i documenti corrotti in Word 98 per Macintosh

Traduzione articoli Traduzione articoli
Identificativo articolo: 176050 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato precedentemente pubblicato con il codice di riferimento I176050
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo vengono descritte le procedure di risoluzione dei problemi che Ŕ possibile utilizzare per identificare, correggere o prevenire la corruzione dei documenti di Microsoft Word per Macintosh.

I file corrotti determinano comportamenti anomali nei programmi. Tali comportamenti si verificano perchÚ il programma tenta di prendere delle decisioni basandosi su informazioni non corrette contenute nel documento corrotto.

Informazioni

Identificazione di un documento corrotto

I documenti corrotti determinano spesso un comportamento anomalo da parte del programma, ad esempio operazioni di impaginazione senza fine, formattazione e layout di documento non corretti, caratteri illeggibili, messaggi di errore visualizzati durante l'elaborazione, blocco o arresto del sistema durante il caricamento o la visualizzazione del file o qualsiasi altro comportamento inusuale che non sia attribuibile al normale funzionamento del programma. Tali comportamenti possono tuttavia essere riconducibili anche ad altri fattori e non solo a documenti corrotti. Per determinare il fattore scatenante, attenersi alla seguente procedura di risoluzione del problemi:
  • Controllare se tali comportamenti si verificano anche con altri documenti.
  • Controllare se comportamenti simili si verificano anche in altri programmi.
  • Utilizzare il file in questione in un altro computer e tentare di riprodurre il comportamento.
  • Utilizzare un diverso driver di stampante e tentare di riprodurre il comportamento.
  • Rinominare qualsiasi modello allegato al documento e tentare di riprodurre il comportamento.
  • Riavviare il computer con le estensioni disabilitate in modo da disabilitare qualsiasi programma di terze parti in esecuzione, ad esempio programmi TSR, gestori di caratteri e screen saver, quindi tentare di riprodurre il comportamento.
Se dopo aver eseguito queste verifiche il problema si verifica con un solo documento, molto probabilmente il documento Ŕ corrotto.

CORREZIONE DI UN DOCUMENTO CORROTTO

Esistono varie tecniche disponibili per correggere un documento. Il metodo utilizzato dipende dalla natura e dalla gravitÓ dell'errore e dal tipo di comportamento anomalo. Sebbene molti di questi metodi vengano utilizzati regolarmente con successo, non tutti i documenti corrotti possono essere recuperati. Conservare una copia di backup di ogni documento Ŕ il modo migliore di evitare di perdere informazioni.

Conversione di un file in un altro formato

Convertire il file in un altro formato, quindi riconvertirlo nel formato nativo.

Questo Ŕ il modo migliore e pi¨ completo per ripristinare un documento ed Ŕ quello che si consiglia di utilizzare sempre per primo. Salvare il file in formato RTF (Rich Text Format), questo formato conserva infatti la formattazione del documento di Microsoft Word per Macintosh. Di seguito riaprire il documento in Word e convertirlo dal formato RTF. Se questo metodo ha successo, l'errore viene rimosso dal file durante il processo di conversione.

Per salvare il file in formato RTF, attenersi alla seguente procedura:
  1. Scegliere Salva con nome dal menu File.
  2. Nell'elenco Salva file come selezionare Rich Text Format.
Se il problema persiste dopo aver salvato il file in formato RTF, provare a salvare il file in uno dei seguenti formati:
  • Altri formati di elaborazione testi
  • Solo testo
NOTA: salvare un file in formato Solo testo consente solitamente di risolvere problemi di corruzione dei documenti, ma determina anche la perdita di qualsiasi informazione di formattazione del documento, comprese tutte le immagini e i codici di campo in Word 98 per Macintosh. Questo metodo richiede un notevole lavoro di riformattazione e in quanto tale Ŕ consigliabile ricorrervi solo dopo che tutti gli altri formati di file non hanno consentito di correggere il problema.

Per informazioni sulla perdita di codici di Visual Basic Applications Edition in documenti di Word 98 convertiti in altri formati di file, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito (informazioni in lingua inglese):
184153 WD98: VBA Code Lost After Converting to Another Document Format

Utilizzo della funzione Salvataggio automatico in Word

La funzione Salvataggio automatico in Word tenta di salvare automaticamente il testo di un documento aperto quando Word si Ŕ bloccato. Quando si riavviare Word in seguito al blocco del programma, viene visualizzata una finestra di messaggio con il seguente messaggio:
File danneggiato durante l'apertura di NOME FILE . Parte del documento potrebbe essere recuperata. Provare a recuperare ora?
NOTA: questo salvataggio pu˛ richiedere del tempo a seconda della dimensione del documento e della gravitÓ del problema.

Una volta recuperato il file, scegliere immediatamente Salva con nome dal menu File per salvare il documento con un nuovo nome. In questo modo il documento originale sarÓ disponibile per altri tentativi di recupero dei dati. Con questo metodo di salvataggio automatico vengono eliminati la formattazione, le immagini e gli oggetti dal documento. Altri metodi elencati di seguito consentono di recuperare gran parte della formattazione originale, delle immagini e degli oggetti dal documento danneggiato.

Per ulteriori informazioni sulla funzione di Salvataggio automatico, vedere gli argomenti "Evitare la perdita di documenti di Word" e "Recupero di documenti perduti" nella Guida in linea di Word.

Apertura di documenti di Word danneggiati in modalitÓ Bozza

Aprire il documento di Word danneggiato in modalitÓ Bozza. Talvolta, a seconda della natura dei documenti danneggiati, Ŕ possibile provare ad aprire un documento in modalitÓ Bozza quando non Ŕ possibile aprirlo in altre modalitÓ. Una volta aperto il file, potrebbe essere possibile recuperarlo o correggerlo.

Per passare alla modalitÓ Bozza, attenersi alla procedura seguente:
  1. Scegliere Normale dal menu Visualizza.
  2. Scegliere Opzioni dal menu Strumenti.
  3. Fare clic sulla scheda Visualizza.
  4. Fare clic per selezionare la casella di controllo Caratteri bozza.

Copiare tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento

Word associa tutta una serie di informazioni di formattazione all'ultimo segno di paragrafo del documento, specialmente per quanto riguarda formattazioni di sezione e di stile. Copiando tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento, Ŕ possibile che venga tralasciata la parte corrotta del documento originale. In seguito sarÓ necessario riapplicare la formattazione di sezione e di stile al nuovo documento.

NOTA: Ŕ possibile selezione tutto il contenuto di un documento a eccezione dell'ultimo segno di paragrafo premendo INVIO+FINE e quindi INVIO+MAIUSC+HOME.

Copiare le porzioni corrotte del documento in un nuovo documento

Talvolta Ŕ possibile determinare la porzione corrotta di un documento. In questi casi si consiglia di copiare in un nuovo file tutto il contenuto del documento a eccezione della porzione corrotta attenendosi quindi alla procedura seguente per ricostruire il documento:
  1. Copiare le parti non corrotte del documento e incollarle in un nuovo file. Si consiglia anche di tralasciare l'ultimo segno di paragrafo in quanto potrebbe contenere altre informazioni di formattazione errate.
  2. Salvare una copia del documento corrotto in formato Solo testo.
  3. Aprire il file in formato Solo testo.
  4. Copiare il testo dal questo file e incollarlo nel file contenente la parte non corrotta del documento.
  5. Riformattare le sezioni del documento incollate al passaggio 4 e quindi salvare il documento.

Inserimento del file in un documento vuoto

Se non Ŕ possibile aprire un file per copiarne tutto il testo a eccezione dell'ultimo segno di paragrafo, si consiglia di inserire il file in un nuovo documento, che servirÓ a fornire un segno di paragrafo finale al file da correggere. Per eseguire questa operazione, attenersi alla seguente procedura:
  1. Creare un nuovo documento basato sul modello Normal.
  2. Scegliere File dal menu Inserisci. Selezionare il documento corrotto e scegliere OK.

Apertura del file utilizzando il convertitore Recupera testo da qualsiasi file

Come ultima risorsa, Ŕ possibile utilizzare questo speciale convertitore per aprire manualmente i documenti corrotti. Questo convertitore rimuove infatti tutte le informazioni di formattazione, le immagini e gli oggetti incorporati dal file a eccezione del testo leggibile (caratteri ASCII). Infatti dato il modo in cui vengono organizzati e salvati i documenti di Word, il testo pu˛ essere disunito o duplicato. SarÓ tuttavia necessario svolgere un notevole lavoro di riformattazione anche per i file di dimensioni pi¨ contenute. Con i file pi¨ piccoli Ŕ spesso consigliabile aprire un secondo documento e copiare il testo dal documento recuperato al nuovo documento.

Per utilizzare il convertitore Recupera testo da qualsiasi file per aprire un documento, attenersi alla seguente procedura:
  1. Scegliere Apri dal menu File.
  2. Nell'elenco Tipo file fare clic su Recupera testo da qualsiasi file.
  3. Trovare la cartella che contiene il file corrotto e selezionarlo.
  4. Fare clic su Apri.

    NOTA: il processo di recupero pu˛ richiedere del tempo a seconda della dimensione del documento e dalla gravitÓ del problema. Una volta che il recupero Ŕ completo, scegliere Apri dal menu File e nell'elenco Tipo file selezionare nuovamente Documenti di Word o File leggibili.

    SUGGERIMENTO: a questo punto salvare il file recuperato con un nuovo nome. In questo modo si eviterÓ di sovrascrivere accidentalmente il documento originale che sarÓ disponibile per altri tentativi di recupero.
Per ulteriori informazioni, fare clic sui numeri degli articoli della Knowledge Base riportati di seguito (informazioni in lingua inglese):
145390 WD6X: Troubleshooting Corrupted Documents, Word 6 For Macintosh
87856 WD97: Troubleshooting Damaged Documents in Word for Windows

ProprietÓ

Identificativo articolo: 176050 - Ultima modifica: lunedý 3 febbraio 2014 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Word 98 per Macintosh
Chiavi:á
kbnosurvey kbarchive kbdta macword macword98 KB176050
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com