WD98: Resolução de problemas relacionados com documentos danificados no Word 98 para Macintosh

Traduções de Artigos Traduções de Artigos
Artigo: 176050 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sumário

Este artigo fornece procedimentos de resolução de problemas que pode utilizar para identificar, recuperar ou impedir danos no Microsoft Word para documentos Macintosh.

Ficheiros de documento danificado podem levar qualquer programa a apresentar um comportamento estranho. Este comportamento ocorre porque o programa tenta tomar decisões sobre o que fazer a seguir, baseado nas informações incorrectas no documento danificado.

Mais Informação

Identificar um documento danificado

Documentos danificados apresentam frequentemente um comportamento que não faz parte da concepção do programa (por exemplo, repaginação infinita, esquema do documento incorrecta e formatação, caracteres ilegíveis no ecrã, mensagens de erro durante o processamento, não reage de sistema ou falha ao carregar ou visualizar o ficheiro ou qualquer outro comportamento estranho que não pode ser atribuído ao funcionamento normal do programa). Estes comportamentos podem ser causados por factores diferente de danos no documento. Para excluir outros factores, siga estes passos de resolução de problemas:
  • Verificar um comportamento semelhante noutros documentos.
  • Verificar um comportamento semelhante noutros programas.
  • Copie o ficheiro em questão para outro computador e tente duplicar o comportamento.
  • Utilizar um controlador de impressora diferente e tente duplicar o comportamento.
  • Mudar o nome quaisquer modelos anexados ao documento e tente duplicar o comportamento.
  • Inicie o computador novamente com extensões para desactivar quaisquer programas de terceiros em execução (como, por exemplo, programas de terminate-and-stay-resident [TSR], gestores de tipos de letra e protecções de ecrã) e, em seguida, tente duplicar o comportamento.
Se o problema ocorrer apenas com um único documento depois de efectuar estes passos, o documento está provavelmente danificado.

Corrigir um documento danificado

Existem várias técnicas que pode utilizar para tentar corrigir um documento danificado. O método que utilizar depende da natureza e da gravidade dos danos bem como da natureza do comportamento apresentado. Apesar de muitos destes métodos tiver êxito regularmente, nem todos os documentos danificados podem ser recuperados. Manter uma cópia de segurança de um documento é a melhor forma de garantir a recuperação.

Converter o ficheiro para outro formato

Converter o ficheiro para outro formato e, em seguida, converta-o para o formato nativo.

Este é o método de recuperação de documentos mais fácil e mais completo; tente sempre-lo primeiro. Guarde o ficheiro no formato de ficheiro Rich Text Format (RTF); este formato preserva a formatação do Microsoft Word para o documento Macintosh. Depois de guardar o ficheiro no formato RTF, reabrir o documento no Word e convertê-la a partir do formato RTF. Se este método tiver êxito, os danos do ficheiro é removido durante a conversão.

Para guardar o ficheiro como RTF, siga estes passos:
  1. No menu ficheiro , clique em Guardar como .
  2. Na lista Guardar ficheiro como tipo , seleccione Rich Text Format (RTF)
Se o problema persistir depois de guardar o ficheiro no formato de ficheiro RTF, tente guardar o ficheiro nos seguintes formatos de ficheiro:
  • Outros formatos de processamento de texto
  • Só texto
Nota : guardar um ficheiro no formato só texto frequentemente corrige o problema de danos no documento; no entanto, toda a formatação documento é perdidas incluindo códigos de campo e de gráficos no Word 98 Macintosh Edition. Este método requer mais reformatar; assim, utilizá-lo apenas depois de outros formatos de ficheiro não conseguem corrigir o problema.

Para obter informações sobre a perda do Visual Basic para código de aplicações no Word 98 artigos que são convertidos para outros formatos de ficheiro, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
184153WD98: Código do VBA perdeu-se depois de converter para outro formato de documento

Utilizar a funcionalidade de recuperação automática do Word

A funcionalidade de recuperação automática do Word tentará automaticamente recuperar texto de um documento que estava aberto quando o Word deixou de responder. Quando reiniciar o Word depois de este deixa de responder (não reage), será apresentada uma caixa de diálogo com a seguinte mensagem:
O Word detectou danos no ficheiro ao abrir o FILE NAME. Parte deste documento pode ser recuperado. Tentativa de recuperação agora?
Nota : esta recuperação poderá demorar algum tempo dependendo do tamanho do documento e a quantidade de danos no documento.

Depois do documento foi recuperado, imediatamente utilize o comando Guardar como no menu ficheiro para guardar o documento com um novo nome de ficheiro. Isto irá assegurar que o documento original estará disponível para outras tentativas de recuperação. Este método de recuperação automática remove tudo formatação, gráficos e objectos do documento. Outros métodos listados abaixo, podem permitir a recuperar mais a e assim por diante de formatação original do documento danificado.

Para mais informações sobre a funcionalidade de recuperação automática, consulte o tópico "Impedir a perda do Word e recuperar documentos perdidos" na ajuda do Word.

Abra o documento do Word danificado no modo de rascunho

Abra o documento do Word danificado no modo de rascunho. Por vezes (nem sempre, devido à natureza de documentos danificados) pode abrir um documento com êxito no modo de rascunho quando não irá abrir nas outras vistas. Depois de abrir o ficheiro, poderá conseguir recuperar ou reparar o ficheiro.

Para mudar para modo de rascunho no Word, siga estes passos:
  1. No menu Ver , clique em Normal .
  2. No menu Ferramentas , clique em Preferências .
  3. Clique no separador Ver .
  4. Clique para seleccionar a caixa de verificação do Tipo de letra de rascunho .

Copiar tudo, excepto a última marca de parágrafo para um documento novo

O Word associa uma vasta gama de formatação à última marca de parágrafo, especialmente a formatação do estilo de secções e. Se copiar tudo excepto a última marca de parágrafo para um novo documento, os danos seja resolvido no documento original. No novo documento, aplique novamente a secção ou de formatação de estilo.

Nota : pode seleccionar tudo excepto a última marca de parágrafo premindo COMMAND + END e, em seguida, COMMAND + SHIFT + HOME.

Copiar as partes não danificadas do documento para um documento novo

Por vezes, é possível determinar a localização do ficheiro danos no documento. Neste caso, copie tudo excepto a parte danificada para um novo ficheiro e siga estes passos para reconstruir o documento:
  1. Copiar as que partes do documento e colá-los num novo ficheiro (não convém seleccione a marca de parágrafo final desta selecção porque essa marca de parágrafo pode conter algumas informações incorrectas).
  2. Guarde uma cópia do documento danificado no formato só de texto.
  3. Abra o ficheiro só de texto.
  4. Copie o texto a partir deste ficheiro e cole-o no ficheiro que contém parte do documento não danificado.
  5. Reformatar as secções do documento que colou no passo 4 e, em seguida, guarde o documento recuperado.

Inserir o ficheiro de um documento em branco

Se não é possível abrir um ficheiro para copiar todo o texto, excepto a marca de parágrafo final, poderá inserir um novo documento (que vai dar uma nova marca de parágrafo final para o ficheiro que está a corrigir). Para o fazer, siga estes passos:
  1. Crie um novo documento baseado no modelo normal.
  2. No menu Inserir , clique em ficheiro . Seleccione o documento danificado e clique em OK .

Utilize o comando ' Colar ligação ' para abrir o documento através de uma ligação

Este método utiliza um documento "fictício" para criar uma ligação e, em seguida, muda a ligação entre o documento "fictício" e o documento danificado.

Siga estes passos para utilizar uma operação de Colar ligação para abrir um documento danificado:
  1. Feche todos os documentos abertos no Word e, em seguida, abra um novo documento em branco.
  2. Tipo de teste .
  3. Seleccione a palavra teste . No menu Editar , clique em Copiar .
  4. No menu ficheiro , clique em Novo e abra um novo documento em branco.
  5. No menu Editar , clique em Colar especial . Na caixa de diálogo Colar especial , clique em Colar ligação . Na caixa como , clique em Texto formatado (RTF) e, em seguida, clique em OK .
  6. No menu Editar , clique em ligações .
  7. Na caixa de diálogo ligações , clique em Alterar origem . Na caixa de diálogo Abrir , localize e seleccione o documento que pretende recuperar. Clique em Abrir e clique em OK .
  8. Quando o documento for aberto, clique em Guardar como no menu ficheiro . Escreva um novo nome para o documento e, em seguida, clique em Guardar .
  9. Com o documento aberto, clique em ' ligações ' no menu Editar .
  10. Na caixa de diálogo ligações , clique em Interromper ligações . Na caixa de diálogo que aparece, clique em Sim para quebrar a ligação.

Nota : depois da ligação for interrompida, deve guardar o documento antes de fechá-la ou modificá-lo.

Abrir o ficheiro utilizando o 'Recuperar texto de qualquer ficheiro'

Como último recurso, este conversor especial pode ser utilizado para abrir manualmente documentos danificados. Utilizar este conversor remove tudo formatação, gráficos e objectos incorporados no ficheiro. Remove tudo do ficheiro excepto texto legível (caracteres ASCII). Devido à forma como são organizados e guardados ficheiros de documento do Word, o texto pode ser disjointed ou duplicado. Com mesmo os ficheiros mais simples, haverá muita reformatar necessário. Com ficheiros mais pequenos é frequentemente desejável para abrir um novo documento segundo e copiar e colar texto do documento recuperado para o novo documento porque não existe muito texto não pretendido recuperado.

Para utilizar o conversor de "Recuperar texto de qualquer ficheiro" para abrir um documento, siga estes passos:
  1. No menu ficheiro , clique em Abrir .
  2. Na lista Ficheiros do tipo , clique em Recuperar texto de qualquer ficheiro.
  3. Localize a pasta que contém o ficheiro danificado e seleccione o ficheiro.
  4. Clique em Abrir .

    Nota : O processo de recuperação poderá demorar algum tempo dependendo do tamanho do documento e o tipo de danos. Assim que a recuperação estiver concluída, clique em Abrir no menu ficheiro e altere Ficheiros do tipo para Documentos do Word ou Ficheiros de acesso de leitura .

    sugestão : guardar o ficheiro recuperado com um novo nome neste momento. Isto irá impedir substituição acidental do documento original e garante que o documento original ainda estará disponível para outras tentativas de recuperação.
Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
87856WD97: Resolução de problemas relacionados com documentos danificados no Word para Windows

Propriedades

Artigo: 176050 - Última revisão: 3 de fevereiro de 2014 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft Word 98 para Macintosh
Palavras-chave: 
kbnosurvey kbarchive kbmt kbfaq kbhowto KB176050 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 176050

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com