Artikel-ID: 176239 - Geändert am: Samstag, 28. Oktober 2006 - Version: 4.1

XADM: Datenbank Won't; Circular Logging gelöschte Protokolldatei zu früh starten

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Problembeschreibung

Mit aktivierter Umlaufprotokollierung gespeichert, die Datenbank möglicherweise nicht nach dem ein nicht ordnungsgemäßes Beenden neu gestartet und ein Fehler "JET_errFileNotFound möglicherweise numerisch in keines der folgenden Formulare angezeigt werden:
  • -1811
  • 4294965485
  • 0xfffff8ed
Im Ereignisprotokoll Anwendung enthalten Ereignisse 1120 und 5000 Hexadezimalversion (0xfffff8ed) des Fehlers.

Hinweis : Ereignisse 1120 und 5000 sind allgemeine Datenbankfehler starten; Sie müssen den Code in Ihren Beschreibungen zu den genauen Grund verstehen, dass die Datenbank nicht mehr reagierte interpretieren.

Ursache

Dies wird möglicherweise durch ein Problem in der Prüfpunkt-Datei verursacht. Wenn dies der Fall ist, und Sie die Datei Edb.chk löschen, wird die Datenbank gestartet. Zahlung Beachtung der im Abschnitt "Lösung" dieses Artikels vor aufgeführten Vorsichtsmaßnahmen wird jedoch die Prüfpunkt-Datei löschen.

Wenn die Umlaufprotokollierung aktiviert ist, löscht Exchange Server Transaktionsprotokolldateien, sobald alle Daten in diese die Haupt-Datenbankdateien geschrieben wurde. Dieser Prozess wird durch die Prüfpunkt nachverfolgt. Tatsächliche Prüfpunkt mit die Datenbank im Speicher gehalten, aber es ist häufig auf die EDB.chk geschrieben Datei.

Ein anderer Prozess möglicherweise öffnen die Datei Edb.chk halten die Prüfpunkt-Datei aktualisieren, wenn die Prüfpunkt setzt Exchange Server zu verhindern. Anwendungen wie Virenscanner und backup-Programmen möglicherweise "die Datei Prüfpunkt vorübergehend stehlen". Exchange Server weiterhin normal und Prüfpunkt im Speicher zu aktualisieren, während er wartet, der andere Prozess EDB.chk Datei freigeben.

Wenn die Datei Edb.chk für Exchange Server für mehr als einen kurzen Zeitraum gesperrt ist, kann die Protokolldatei in es aufgelistet gelöscht werden, bevor die Datei Edb.chk aktualisiert wird. Wenn die Datenbank plötzlich beendet wird, geht die Prüfpunkt im Arbeitsspeicher verloren. Wenn die Datenbank neu gestartet wird, muss er auf die Prüfpunkt in der Datei Edb.chk aufgezeichnet verlassen. Da die EDB.chk-Datei auf eine nicht vorhandene Transaktionsprotokolldatei verweist, die Datenbank nicht gestartet und ein JET_errFileNotFound-Fehler angezeigt.

Lösung

Die Datei Edb.chk entfernen, und starten Sie den Datenbankdienst neu.

Wenn die Datei Edb.chk, Exchange Server scannt durch alle verfügbaren Protokolldateien, und beginnt dann Wiederherstellung mithilfe von die erste Protokolldatei, die es findet.

Vorsichtsmaßnahmen

Entfernen Sie die EDB.chk-Datei nicht, wenn Sie wissen genau Warum müssen Sie es entfernen und, wenn Sie wissen, dass problemlos es in Ihrer aktuellen Umständen entfernt werden kann. Die Datei Edb.chk unter bestimmten Umständen entfernen beschädigen irreparably die Datenbank. Weitere Informationen zu den Prüfpunkt finden Sie im folgenden Artikel der Microsoft Knowledge Base:
240145  (http://support.microsoft.com/kb/240145/ ) So entfernen Sie Exchange Server-Transaktionsprotokolldateien
Wenn Sie die hier beschriebenen Bedingungen betroffen sind und wenn alle der folgenden Aussagen zutreffen, können Sie die Datei Edb.chk unbesorgt löschen:
  • Sie haben nicht verschoben, umbenannt, gelöscht, ersetzt oder mit den Protokollen Datenbank- oder Transaktionsprotokollsicherung nach nicht ordnungsgemäßes Herunterfahren verändert. Für die Wiederherstellung erfolgreich abgeschlossen werden kann müssen die Datenbank- und Transaktionsprotokolldateien Protokolle in genau demselben Zustand sein, denen Sie, waren als die Datenbank beendet.
  • Wenn Sie den Befehl Eseutil/r für die Datenbank ausgeführt, und Sie den Schalter/is oder/DS für die Ausführung verwendet. ( Eseutil/r/is -Befehl für den Informationsspeicher ist und der Befehl Eseutil/r/DS für den Verzeichnisdienst.)

    Wenn Sie den Schalter/is oder/DS weglassen, nimmt der soft Recovery die Protokolldateien im Ordner befinden, die Ausführung von Eseutil aus. Wenn die Protokolldateien an anderer Stelle, sind in der Regel sind, soft Recovery-Vorgang erstellt eine neue Datei Edb.log und versucht, anhand der falschen Protokolldateien wiederherstellen. Sie können weiterhin EDB.chk-Datei löschen, nach solches Ereignis jedoch die Datenbank weiterhin möglicherweise nicht gestartet, und möglicherweise müssen Sie es aus einer Sicherung wiederherstellen.
  • Sie haben die Umlaufprotokollierung aktiviert. Wenn zum Zeitpunkt der nicht ordnungsgemäßen Herunterfahren die Umlaufprotokollierung deaktiviert wurde, gelten keine Empfehlungen in diesem Artikel. Wenn Umlaufprotokollierung deaktiviert ist, werden Transaktionsprotokolldateien nicht automatisch gelöscht, wenn die Prüfpunkt erhöht. Dies bedeutet, dass die Ursache des Problems Neustart die Ursache hier beschriebenen abweicht.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Exchange Server 5.5 Standard Edition
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 176239  (http://support.microsoft.com/kb/176239/en-us/ )
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