ID do artigo: 176938 - Última revisão: segunda-feira, 11 de julho de 2005 - Revisão: 2.2

Erro: Oleview trava com registro TypeLib visualizar incorreta

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Ao tentar exibir uma biblioteca de tipo, Oleview parece travar e não responde à interação do usuário. Além disso, Gerenciador de tarefas mostra que os processos Oleview.exe e Rpcss.exe combinados estão ocupando quase 100 % do tempo da CPU.

Causa

Esse problema é causado por um registro incorreto do servidor em processo Iviewers.dll. Iviewers.dll contém o objeto Visualizador do tipo de biblioteca de interface usado pelo Oleview para analisar a biblioteca de tipos. O problema ocorre quando a entrada InProcServer32 para este objeto (em HKCR\CLSID\ {57EFBF49-4A8B-11CE-870B-0800368D2302}) aponta para um caminho incorreto. Isso expõe um bug em Oleview faz com que ele tenta carregar o objeto visualizador em um loop infinito.

Resolução

Para resolver esse problema, registre novamente Iviewers.dll. Essa DLL é fornecida juntamente com Oleview.exe como uma parte da plataforma SDK ou o compilador Visual C++. Localizar a DLL na máquina e registrar seus objetos emitindo o comando a seguir:
Regsvr32 iviewers.dll

Situação

A Microsoft confirmou este é um bug em produtos Microsoft listados no começo deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft OLE 4.0 nas seguintes plataformas
    • Microsoft Platform Software Development Kit-January 2000 Edition
Palavras-chave: 
kbmt kbbug KB176938 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 176938  (http://support.microsoft.com/kb/176938/en-us/ )