Los archivos .pdf de Adobe Acrobat aparecen como un marco o una ventana en blanco

Seleccione idioma Seleccione idioma
Id. de artículo: 177321
Este artículo se publicó anteriormente con el número E177321
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta ver un archivo Portable Document Format (.pdf) en Internet Explorer, es posible que aparezca una ventana en blanco o un marco en lugar del archivo .pdf. Esto puede ocurrir incluso si ha instalado el programa Adobe Acrobat Reader y normalmente puede ver archivos .pdf en ese programa.

Causa

La causa de este comportamiento puede ser alguna de las siguientes:

  • Se requiere una versión actualizada de Adobe Acrobat Reader para utilizar la activación en contexto. La activación en contexto es una función que abre un archivo de programa en Internet Explorer y muestra las barras de herramientas desde el programa asociado.
  • El nivel de seguridad para esta zona está establecido como alto en Internet Explorer 4.0, 4.01 o 5. Para obtener información acerca de las zonas de seguridad en Internet Explorer, consulte el artículo siguiente en Microsoft Knowledge Base:
    174360 Cómo utilizar las zonas de seguridad en Internet Explorer 4.0
  • Se han habilitado las clasificaciones en Internet Explorer 3.02 o el nivel de seguridad está establecido en alto.
  • El archivo .pdf se sirve desde una versión anterior de algunos servidores web (como la versión 2.0 de Microsoft Internet Information Server).
  • Esto puede estar relacionado con una conexión lenta, con una alta carga del servidor o con un tamaño excesivamente grande del archivo .pdf.
  • Está ejecutando una versión de Internet Explorer anterior a Internet Explorer 5.5.
Un control ActiveX dañado puede ser la causa de este problema. Para que Adobe Acrobat Reader 4 utilice la activación en contexto con Internet Explorer, los archivos Pdf.ocx y Pdf.tlb deben estar en la carpeta x:\Archivos de programa\Adobe\Acrobat 4.0\Acrobat\ActiveX\, donde x es la letra de unidad donde se instaló Adobe Acrobat Reader. Si falta alguno de estos archivos, es posible que Internet Explorer muestre una ventana en blanco cuando abra un archivo .pdf.

Solución

Para resolver este problema, siga los pasos de la siguiente sección:

Actualizar a Internet Explorer 5.5.

Internet Explorer 5.5 ha corregido el problema que mostraba una página en blanco al recuperar un archivo PDF con el método POST. La actualización a la versión 5.5 de Internet Explorer resuelve este problema. Visite el siguiente sitio web de Microsoft:
http://windows.microsoft.com/es-es/internet-explorer/download-ie

Internet Explorer 4.0, 4.01 y 5

Si está utilizando la versión 3.0 o una anterior de Adobe Acrobat Reader, actualícela a la versión 4.0 o posterior. Si ya está utilizando la versión 4.0 o una posterior, siga estos pasos:
  1. Cambie el nivel de seguridad utilizado por Internet Explorer a medio o inferior. Para ver los archivos .pdf en Internet Explorer 4.0, 4.01 o 5, la seguridad debe establecerse como media o baja. Para cambiar el nivel de seguridad, siga los pasos que se muestran a continuación:

    NOTA: si no desea reducir el nivel de seguridad para esta zona, vaya al paso 2.
    1. Inicie Internet Explorer y, a continuación, haga clic en Opciones de Internet en el menú Ver. En Internet Explorer 5.0, haga clic en Opciones de Internet, en el menú Herramientas.
    2. Haga clic en la pestaña Seguridad, haga clic en Zona de Internet en el cuadro Zona, haga clic en Medio (más seguro) o Bajo y, a continuación, en Aceptar.
  2. Descargue el archivo .pdf y, a continuación, ábralo con el programa Adobe Acrobat Reader.

Internet Explorer 3.02

Si está utilizando la versión 3.0 de Adobe Acrobat Reader o una anterior, actualícela a la versión 3.01 o posterior. Si ya está utilizando la versión 3.01 o posterior, aplique uno de los dos siguientes métodos (o ambos):

Deshabilitar clasificaciones en Internet Explorer

Para deshabilitar las clasificaciones en Internet Explorer, siga estos pasos:
  1. Abra Internet Explorer y, a continuación, haga clic en Opciones en el menú Ver.
  2. En la pestaña Seguridad, haga clic en Desactivar clasificaciones y, a continuación, en Aceptar.
  3. Cierre Internet Explorer.
  4. Descargue el archivo .pdf y, a continuación, ábralo con el programa Adobe Acrobat Reader.

Reducir el nivel de seguridad

Cambie el nivel de seguridad utilizado por Internet Explorer a medio o inferior. Para ello, siga estos pasos:
  1. En el menú Ver, haga clic en Opciones.
  2. En la pestaña Seguridad, haga clic en Nivel de seguridad.
  3. Haga clic en Medio, en Aceptar y de nuevo en Aceptar.
  4. Cierre Internet Explorer.
  5. Descargue el archivo .pdf y, a continuación, ábralo con el programa Adobe Acrobat Reader.

Conexión lenta

Si su conexión es lenta, el servidor está ocupado o está intentando descargar un archivo de gran tamaño, espere a que el archivo termine de descargarse para verlo.

Desinstalar y volver a instalar Adobe Acrobat Reader 4

  1. En el Panel de control, haga doble clic en Agregar o quitar programas.
  2. Haga doble clic en Adobe Acrobat Reader 4 para desinstalar el programa. Siga las instrucciones del asistente para desinstalar el programa.
  3. Descargue Adobe Acrobat Reader 4 desde el sitio web de Adobe si es necesario.
  4. Busque el archivo Rs405eng.exe y, a continuación, haga doble clic en él para reinstalar el programa.
  5. Aunque no se le pedirá que reinicie el equipo durante la instalación, apáguelo y reinicie.
  6. El archivo .pdf se mostrará en Internet Explorer cuando haga clic en un vínculo al archivo en Internet.

Solución alternativa

  1. Abra Adobe Acrobat Reader 4, en el menú Archivo, haga clic en Preferencias y, a continuación, haga clic en General.
  2. Desactive la casilla Integración del explorador web y, a continuación, haga clic en Aceptar.
  3. Cuando hace clic en un vínculo a un archivo .pdf, se le pide que guarde el archivo en el cuadro de diálogo Transferencia de archivos. Puede guardar el archivo y, a continuación, hacer doble clic para abrirlo en Adobe Acrobat Reader.

    Si selecciona Abrir este archivo desde su ubicación actual, el archivo se abrirá en Adobe Acrobat Reader 4 y no en Internet Explorer.

Más información

Internet Explorer permite utilizar el visor de Adobe Acrobat como un control. Debido a un cambio realizado en el modelo de objetos desde Internet Explorer 3.0 a Internet Explorer 4.0, era necesario que Adobe actualizara su visor para que funcionara con el modelo de objetos de Internet Explorer 4.0. Para obtener una versión actualizada de Adobe Acrobat, póngase en contacto con Adobe.

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
253213 Dirección incorrecta al utilizar el método POST en vez de GET
Los productos de terceros descritos en este artículo están fabricados por empresas independientes de Microsoft. Microsoft no ofrece ninguna garantía, implícita ni de ningún otro tipo, sobre el rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 177321 - Última revisión: viernes, 30 de noviembre de 2012 - Versión: 6.0
Palabras clave: 
kbenv kbui KB177321
Renuncia a responsabilidad de los contenidos de la KB sobre productos a los que ya no se ofrece asistencia alguna
El presente artículo se escribió para productos para los que Microsoft ya no ofrece soporte técnico. Por tanto, el presente artículo se ofrece "tal cual" y no será actualizado.

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com