Pliki pdf programu Adobe Acrobat są wyświetlane jako puste okno lub pusta ramka

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 177321
Ten artykuł został opublikowany wcześniej pod numerem PL177321
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Przy próbie wyświetlenia pliku Portable Document Format (pdf) w programie Internet Explorer może pojawić się puste okno lub pusta ramka zamiast pliku pdf. Może się tak zdarzyć nawet wtedy, gdy zainstalowano program Adobe Acrobat Reader i można w nim normalnie wyświetlać pliki pdf.

Przyczyna

Takie zachowanie może być spowodowane wystąpieniem dowolnej z następujących sytuacji:

  • Zaktualizowana wersja programu Adobe Acrobat Reader jest wymagana do użycia aktywacji w miejscu. Aktywacja w miejscu to funkcja umożliwiająca otwieranie plików programów w programie Internet Explorer i wyświetlanie pasków narzędzi ze skojarzonego programu.
  • Dla danej strefy jest ustawiony poziom zabezpieczeń Wysoki w programie Internet Explorer 4.0, 4.01 lub 5. Aby uzyskać informacje o strefach zabezpieczeń w programie Internet Explorer, zobacz następujący artykuł z bazy wiedzy Microsoft Knowledge Base:
    174360 Jak używać stref zabezpieczeń w programie Internet Explorer 4.0
  • W programie Internet Explorer 3.02 jest włączona funkcja klasyfikacji albo jest ustawiony poziom bezpieczeństwa Wysoki.
  • Plik pdf został pobrany ze starszej wersji serwera sieci Web (dotyczy to niektórych serwerów sieci Web, takich jak Microsoft Internet Information Server 2.0).
  • Problem może być związany z wolnym połączeniem, dużym obciążeniem serwera lub bardzo dużym rozmiarem pliku pdf.
  • Używana jest wersja programu Internet Explorer starsza niż Internet Explorer 5.5.
Przyczyną tego problemu może być uszkodzona kontrolka ActiveX. Aby program Adobe Acrobat Reader 4 mógł użyć aktywacji w miejscu w programie Internet Explorer, pliki Pdf.ocx i Pdf.tlb muszą być umieszczone w folderze x:\Program Files\Adobe\Acrobat 4.0\Acrobat\ActiveX\, gdzie x jest literą dysku, na którym zainstalowano program Adobe Acrobat Reader. Jeśli brakuje dowolnego z tych plików, podczas otwierania pliku pdf w programie Internet Explorer może zostać wyświetlone puste okno.

Rozwiązanie

Aby rozwiązać ten problem, należy wykonać czynności podane w odpowiedniej sekcji:

Uaktualnianie do programu Internet Explorer 5.5

W programie Internet Explorer 5.5 rozwiązano problem z wyświetlaniem pustej strony podczas pobierania pliku PDF za pomocą metody POST. Aby rozwiązać ten problem przez uaktualnienie do programu Internet Explorer 5.5, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://windows.microsoft.com/pl-pl/internet-explorer/download-ie

Internet Explorer 4.0, 4.01 i 5

Jeśli jest używany program Adobe Acrobat Reader 3.0 lub starszy, należy przeprowadzić uaktualnienie do wersji 4.0 lub nowszej. Jeśli jest już używana wersja 4.0 lub nowsza, należy wykonać następujące czynności:
  1. Zmień poziom zabezpieczeń używany przez program Internet Explorer, ustawiając poziom średni lub niższy. Aby można było wyświetlać pliki pdf w programie Internet Explorer 4.0, 4.01 lub 5, musi być ustawiony średni lub niższy poziom zabezpieczeń. Aby zmienić poziom zabezpieczeń, należy wykonać poniższą procedurę.

    UWAGA: Jeśli użytkownik nie chce zmniejszać poziomu zabezpieczeń dla danej strefy, należy przejść do kroku 2.
    1. Uruchom program Internet Explorer, a następnie kliknij pozycję Opcje internetowe w menu Widok. W programie Internet Explorer 5.0 kliknij polecenie Opcje internetowe w menu Narzędzia.
    2. Kliknij kartę Zabezpieczenia, w polu Strefa kliknij strefę Internet, kliknij pozycję Średni (większe bezpieczeństwo) lub Niski, a następnie kliknij przycisk OK.
  2. Pobierz plik pdf, a następnie otwórz go w programie Adobe Acrobat Reader.

Internet Explorer 3.02

Jeśli jest używany program Adobe Acrobat Reader 3.0 lub starszy, należy przeprowadzić uaktualnienie do wersji 3.01 lub nowszej. Jeśli jest już używana wersja 3.01 lub nowsza, należy zastosować co najmniej jedną z poniższych metod:

Wyłączanie funkcji klasyfikacji w programie Internet Explorer

Aby wyłączyć funkcję klasyfikacji w programie Internet Explorer, należy wykonać następujące czynności:
  1. Uruchom program Internet Explorer, a następnie kliknij polecenie Opcje w menu Widok.
  2. Na karcie Zabezpieczenia kliknij pozycję Wyłącz klasyfikacje, a następnie kliknij przycisk OK.
  3. Zamknij program Internet Explorer.
  4. Pobierz plik pdf, a następnie otwórz go w programie Adobe Acrobat Reader.

Zmniejszanie poziomu bezpieczeństwa

Należy zmienić poziom zabezpieczeń używany przez program Internet Explorer, ustawiając poziom średni lub niższy. W tym celu należy wykonać następujące czynności:
  1. W menu Widok kliknij polecenie Opcje.
  2. Na karcie Zabezpieczenia kliknij pozycję Poziom bezpieczeństwa.
  3. Kliknij pozycję Średni, kliknij przycisk OK, a następnie ponownie kliknij przycisk OK.
  4. Zamknij program Internet Explorer.
  5. Pobierz plik pdf, a następnie otwórz go w programie Adobe Acrobat Reader.

Wolne połączenie

Jeśli połączenie jest wolne, serwer jest obciążony lub użytkownik próbuje pobrać duży plik, w celu wyświetlenia pliku należy poczekać, aż zostanie całkowicie pobrany.

Odinstalowywanie i ponowne instalowanie programu Adobe Acrobat Reader 4

  1. W Panelu sterowania kliknij dwukrotnie pozycję Dodaj/Usuń programy.
  2. Kliknij dwukrotnie pozycję Adobe Acrobat Reader 4, aby odinstalować ten program. Postępuj zgodnie z instrukcjami kreatora, aby odinstalować program.
  3. Jeśli to konieczne, pobierz program Adobe Acrobat Reader 4 z witryny firmy Adobe w sieci Web.
  4. Odszukaj plik Rs405eng.exe, a następnie kliknij go dwukrotnie, aby rozpocząć ponowną instalację programu.
  5. Mimo że podczas instalacji nie pojawi się monit o ponowne uruchomienie komputera, zakończ działanie komputera i uruchom go ponownie.
  6. Plik pdf powinien zostać wyświetlony w programie Internet Explorer po kliknięciu łącza do pliku pdf w Internecie.

Obejście problemu

  1. Otwórz program Adobe Acrobat Reader 4, w menu File (Plik) kliknij polecenie Preferences (Preferencje), a następnie kliknij pozycję General (Ogólne).
  2. Kliknij pole wyboru Web Broswer Integration (Integracja z przeglądarką sieci Web), aby je wyczyścić, a następnie kliknij przycisk OK.
  3. Po kliknięciu łącza do pliku pdf pojawi się monit o zapisanie pliku w oknie dialogowym Pobieranie pliku. Możesz zapisać plik, a następnie kliknąć go dwukrotnie, aby go otworzyć w programie Adobe Acrobat Reader.

    W przypadku wybrania pozycji Otwórz plik z bieżącej lokalizacji plik powinien zostać otwarty w programie Adobe Acrobat Reader 4, a nie w programie Internet Explorer.

Więcej informacji

Program Internet Explorer umożliwia używanie przeglądarki programu Adobe Acrobat jako kontrolki. Ponieważ model obiektów w programie Internet Explorer 4.0 został zmieniony w porównaniu z programem Internet Explorer 3.0, firma Adobe musiała zaktualizować oferowaną przeglądarkę, aby mogła ona działać z modelem obiektów w programie Internet Explorer 4.0. Aby uzyskać zaktualizowaną wersję programu Adobe Acrobat, należy skontaktować się z firmą Adobe.

Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
253213 Niepoprawny adres przekazywany w przypadku używania metody POST zamiast metody GET (strona może być w języku angielskim)
Produkty omówione w tym artykule są wytwarzane przez producentów niezależnych od firmy Microsoft. Firma Microsoft nie udziela żadnych gwarancji, domyślnych ani żadnego innego rodzaju, odnośnie do wydajności ani niezawodności tych produktów.
Uwaga: Niniejszy artykuł, przeznaczony do „SZYBKIEJ PUBLIKACJI”, został utworzony bezpośrednio przez organizację pomocy technicznej firmy Microsoft. Zawarte w nim informacje są udostępniane „w stanie takim, w jakim są” w odpowiedzi na pojawiające się problemy. W wyniku przyspieszonego trybu udostępniania materiały mogą zawierać błędy typograficzne i mogą zostać poprawione w dowolnym momencie bez uprzedzenia. Więcej informacji można znaleźć w Warunkach użytkowania.

Właściwości

Numer ID artykułu: 177321 - Ostatnia weryfikacja: 30 listopada 2012 - Weryfikacja: 1.0
Słowa kluczowe: 
kbenv kbui KB177321
Zastrzeżenie dotyczące artykułów z bazy wiedzy o produktach wycofanych
Ten artykuł dotyczy produktów, dla których firma Microsoft nie oferuje już pomocy technicznej. Dlatego jest on oferowany w obecnej wersji i nie będzie już aktualizowany.

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com